summaryrefslogtreecommitdiff
path: root/dev-python/pygit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pygit2
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest2
-rw-r--r--dev-python/pygit2/pygit2-1.0.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 5f9e586188ae..d5c8cb5f6efe 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,3 +1,5 @@
DIST pygit2-0.28.2.tar.gz 496469 BLAKE2B 1173401d4555f6f40eaf5a27d9c0e83214b66afa609f15cc4d689e8c58cc0ae3865b4e6ebb31808d354ecef56f3a74cc777fe42314ef348c39f1f61d82655bc9 SHA512 3f742cdcc9d603c9cc9ef2e0a545da8bcfb555a0bdeea1c73c53a284b43d40ad6b28c87a029578ad7b1c8f2bf56ecd2859dac8dd836474bfc66223ff4af9e8f0
+DIST pygit2-1.0.0.tar.gz 501473 BLAKE2B 854f53113bda2ec5c1fd2ba7f2dfc4213d31d3e687fa17d8942b03dd685cd37df28fc8347bd63ede9650de00b980a4cf7aa1196b9feb9a2365e1fc118d187121 SHA512 33296f95aacbfc3cbce275f84c2025767499738495941408de15ac14f822de132995c05c713b815732dbfc3094edf64351d6240e7201e472b3c47035a7532eff
EBUILD pygit2-0.28.2.ebuild 906 BLAKE2B 9454943a79010416c8bbde14d46822be2b5315ab6c1bf902bae6362597eb242951ea93e806b6fa6a2387599f096e4130a3f4d72c5a2d9ffb64d5e1f1168d525e SHA512 0658f9d3637c5e22ce942deace28d9e55e40eb72e76cefd6d93f76b9cf6f20bdfd592ba1529da38342a194c768fda38f4404feeb5c3c02b64a0633a50d673043
+EBUILD pygit2-1.0.0.ebuild 966 BLAKE2B c286b148744ff531e89531576cd5a73935ee355fee6317fcce459fb4aa425aab33cdd2b01e0f9f67b951ae02bf5d7a063a3287fcda0f8b9874fdeeb7da06cb08 SHA512 5768ae99ddd6b11a655c8522244721f60864a2de47bef6f6fdfc6a88930ee782090ee6de1418501d8eb0690a8405b9ed386aa98a6487613e9c0f1d12ff184bb5
MISC metadata.xml 489 BLAKE2B 3733ff314640ab2cbfa07e0ea67041ddb3635b51d339070abe97c95b5b358851b412cca5d8996dc1f25abb986a03095f19e8a50cbaeab7eb156c6b9107108cf6 SHA512 d20b7ebbdb3ea2ec72c3c5ded9874b7506b3ddabb43dbf329891478fcf5d7c4b9487ab0675d735733f463dd897dd5cdcc28080ad597f4f838bbcaa565c26915e
diff --git a/dev-python/pygit2/pygit2-1.0.0.ebuild b/dev-python/pygit2/pygit2-1.0.0.ebuild
new file mode 100644
index 000000000000..ade7039d9db1
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/libgit2-0.28*
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/def no_network/a \
+ return True' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ pytest -vv hack/test || die
+}