summaryrefslogtreecommitdiff
path: root/dev-python/pygit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/pygit2
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest4
-rw-r--r--dev-python/pygit2/pygit2-1.9.0.ebuild (renamed from dev-python/pygit2/pygit2-1.7.1.ebuild)35
2 files changed, 23 insertions, 16 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index df12a7db0b8f..1c30413916ab 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,3 +1,3 @@
-DIST pygit2-1.7.1.tar.gz 281791 BLAKE2B 51f7f23752acf0abf6000f2262019db7503506267f0f5306bd53e0e15378447d2da564818c1b6efccc4759587aba6b4d7b142c760e4e2796445cd6056e949825 SHA512 a6232039b6364c7a0905aba20f7e27b43892b7067fa95fdd464438869453360ecdb885f2012cdf0eb0734c91dc79b60db894d1d0fee81922b9fb3cf920950937
-EBUILD pygit2-1.7.1.ebuild 889 BLAKE2B a9c2830744e3386f59567fce106452247e6d44f0d3214c4169d6ab53beb4e626a245c69cb70e07474c6d3145cb9a742bbfde06ce582df41269f9d8f72e1298d0 SHA512 c476479b7bdb50b3d7668213727e41d10436b771a8f1fb5c357b9b8b4b8c22f441496fbb1dff2142ce353374c396a65aaecac319e9549e18f134f9a6ec9eec82
+DIST pygit2-1.9.0.gh.tar.gz 312349 BLAKE2B 067074d58887597cdce9b7bbebb96a8ec8629c4dc42c87c2a0a9a23849bc2e8e36763273c7d883ccfadbc9f71a3b4b5612a9a7b58e3cfb39475e568d85cbdc64 SHA512 8934f1099004a536b78973f74efc8854cbfb736369a0592c382fbc1325409105640235a2b3ce4602ad0dce863cb9ffd34b2359c9840d2abdadb55e2a43df18f9
+EBUILD pygit2-1.9.0.ebuild 862 BLAKE2B 4707708fbb49544937f943955a62373e905cb05d22c1f3ae68f406d70bbbf82ef58c682ce9b5b3b1184ee26e3942668f55b20e33fbd3a81089f6f82aea6c3046 SHA512 3597f6f45971d4f6bf761d1e11ae3b12ef3d0410c17d7f5161bc8f97283f98ec40189d23ec82e3fd207167819d4251032c16412a4117d5d8160f6a1bc5a50d0b
MISC metadata.xml 490 BLAKE2B a53da88b5fe40a56d831bb5589d03d247ca1d1d843bde9a1fe6999563a42c076a9f6462b6947ae217086e5edde35a4788f4552636871891f9820534a6f0bade6 SHA512 57cb7356bbb0a22fce2d7ecd8ab346ef5c8155d0941d6a15bf2e98364e755d6e5e5d6aacf24017b4b827b983032e4d46f2363483ac66d6e3882c8be12e60fb39
diff --git a/dev-python/pygit2/pygit2-1.7.1.ebuild b/dev-python/pygit2/pygit2-1.9.0.ebuild
index e1df5178654a..ef2034d47953 100644
--- a/dev-python/pygit2/pygit2-1.7.1.ebuild
+++ b/dev-python/pygit2/pygit2-1.9.0.ebuild
@@ -1,24 +1,36 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
+
inherit distutils-r1
DESCRIPTION="Python bindings for libgit2"
-HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/"
+SRC_URI="
+ https://github.com/libgit2/pygit2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="GPL-2-with-linking-exception"
SLOT="0"
KEYWORDS="amd64 x86"
+DEPEND="
+ =dev-libs/libgit2-1.4*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
RDEPEND="
- =dev-libs/libgit2-1.3*:=
- >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+ ${DEPEND}
+ ${BDEPEND}
"
-DEPEND="${RDEPEND}"
distutils_enable_tests pytest
@@ -27,14 +39,9 @@ src_prepare() {
# unconditionally prevent it from using network
sed -i -e '/has_network/s:True:False:' test/utils.py || die
-
- # we need to move them away to prevent pytest from forcing '..'
- # for imports
- mkdir hack || die
- mv test hack/ || die
- ln -s hack/test test || die
}
-python_test() {
- epytest hack/test
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
}