summaryrefslogtreecommitdiff
path: root/dev-python/pygit2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-10-01 20:54:53 +0100
commit391b5b359a346aff490103da7dddc85047f83830 (patch)
tree29eea460a0bd7e1ff21d43b9d6df9af4d8a175e1 /dev-python/pygit2
parentc719fdcee603a5a706a45d10cb598762d56a727d (diff)
gentoo resync : 01.10.2021
Diffstat (limited to 'dev-python/pygit2')
-rw-r--r--dev-python/pygit2/Manifest2
-rw-r--r--dev-python/pygit2/files/pygit2-1.6.1-libgit2-1.2.0.patch48
-rw-r--r--dev-python/pygit2/pygit2-1.6.1-r2.ebuild45
3 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 55aa4edb5fc9..95669c18cdbf 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,3 +1,5 @@
+AUX pygit2-1.6.1-libgit2-1.2.0.patch 1870 BLAKE2B ab6d4884c5330e98f5e889f4605d8b1d9527033603707e8c3414944261aade3dfc3c8d8a0bcf7efa0d73ddee9d1390db47325d52205ee6d00ce95f39dd0b01ed SHA512 f5fb9217812057e62db50fa4f10ae0d845c031565956c60bc2b498209b11effcbf4dbd2f253c303f4b2b7192403fc777e4854ae472dc6c3e2178c19a62acfdfa
DIST pygit2-1.6.1.tar.gz 258338 BLAKE2B dc223e2a5231728c42ca7e0581483731fbab6ee090cf4aeeb27f186973b3c753fdf54c89679a88b97d834d717135f9b8f9a2adf492ed8572affa938c79d0f905 SHA512 67a78313493ba096cbae6805bda861495f33644fd180b5fb1cd99dcd226ef5a09ee85bd27d04d0697ef15503a4e902aa1384980870551f430fd9560ac949fe2f
EBUILD pygit2-1.6.1-r1.ebuild 945 BLAKE2B 79cfd82aaf7395b5adddd3b4a791f6c848221a2948d02fc75d239d77f5aa4e456a3163b5682db51ab2f8181cfc5aaec1f29c999fcec83ac26bdf77e674761160 SHA512 b0ebb0bd047fd0b1d2b58f970ed7cec2d63ec86c1b01e2461fd14fb85edc29824372b92cae3a0fdd52c22aef30d4b2ca03d401749a9ed500e543df606133a3cc
+EBUILD pygit2-1.6.1-r2.ebuild 999 BLAKE2B 5f8e1ab0c9a4041cd80821c858904debee9221ffffaf44d5933f31b73122a300e1566b4def0779dcedb0b636f54762c4b86fd656a8e3142630cd82d222adbb58 SHA512 b8bebfb9341ebbeab1daeb6207c27a131140b278dea2e8431f8dbb6140853ffc42176ab338c1fe45dd7e06a9c12423c4b7483519096e374cccdf9a1be3e5a33c
MISC metadata.xml 490 BLAKE2B a53da88b5fe40a56d831bb5589d03d247ca1d1d843bde9a1fe6999563a42c076a9f6462b6947ae217086e5edde35a4788f4552636871891f9820534a6f0bade6 SHA512 57cb7356bbb0a22fce2d7ecd8ab346ef5c8155d0941d6a15bf2e98364e755d6e5e5d6aacf24017b4b827b983032e4d46f2363483ac66d6e3882c8be12e60fb39
diff --git a/dev-python/pygit2/files/pygit2-1.6.1-libgit2-1.2.0.patch b/dev-python/pygit2/files/pygit2-1.6.1-libgit2-1.2.0.patch
new file mode 100644
index 000000000000..d3e097ba62b3
--- /dev/null
+++ b/dev-python/pygit2/files/pygit2-1.6.1-libgit2-1.2.0.patch
@@ -0,0 +1,48 @@
+From dcde9eff5950492ab0d2565a07fd18d765332a96 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?J=2E=20David=20Ib=C3=A1=C3=B1ez?= <jdavid.ibp@gmail.com>
+Date: Thu, 16 Sep 2021 11:19:04 +0200
+Subject: [PATCH] Upgrade to libgit2 1.2
+
+Closes #1089
+---
+ Makefile | 2 +-
+ build.sh | 14 +++++++-------
+ pygit2/decl/remote.h | 2 ++
+ src/types.h | 4 ++--
+ 10 files changed, 29 insertions(+), 25 deletions(-)
+
+diff --git a/pygit2/decl/remote.h b/pygit2/decl/remote.h
+index ff84371c3e1ce81a7e9914d4d4592638f41376bb..4e912c065cd6eaf19ef6d0304b0fd8f646edbff4 100644
+--- a/pygit2/decl/remote.h
++++ b/pygit2/decl/remote.h
+@@ -23,6 +23,7 @@ typedef struct {
+
+ typedef int (*git_push_negotiation)(const git_push_update **updates, size_t len, void *payload);
+ typedef int (*git_push_update_reference_cb)(const char *refname, const char *status, void *data);
++typedef int (*git_remote_ready_cb)(git_remote *remote, int direction, void *payload);
+ typedef int (*git_url_resolve_cb)(git_buf *url_resolved, const char *url, int direction, void *payload);
+
+ struct git_remote_callbacks {
+@@ -38,6 +39,7 @@ struct git_remote_callbacks {
+ git_push_update_reference_cb push_update_reference;
+ git_push_negotiation push_negotiation;
+ git_transport_cb transport;
++ git_remote_ready_cb remote_ready;
+ void *payload;
+ git_url_resolve_cb resolve_url;
+ };
+diff --git a/src/types.h b/src/types.h
+index ff967b81f76688f8f0958638d99a06f7bbacb99c..89ad3a00149a1326c3edfa20d2d69d629cb1d2a2 100644
+--- a/src/types.h
++++ b/src/types.h
+@@ -32,8 +32,8 @@
+ #include <Python.h>
+ #include <git2.h>
+
+-#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 1)
+-#error You need a compatible libgit2 version (1.1.x)
++#if !(LIBGIT2_VER_MAJOR == 1 && LIBGIT2_VER_MINOR == 2)
++#error You need a compatible libgit2 version (1.2.x)
+ #endif
+
+ /*
diff --git a/dev-python/pygit2/pygit2-1.6.1-r2.ebuild b/dev-python/pygit2/pygit2-1.6.1-r2.ebuild
new file mode 100644
index 000000000000..fa7f6c1fbf6e
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.6.1-r2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-1.2*:=
+ dev-python/cached-property[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/${P}-libgit2-1.2.0.patch
+ )
+
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ epytest hack/test
+}