summaryrefslogtreecommitdiff
path: root/dev-python/pygit2/pygit2-1.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 22:47:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 22:47:16 +0100
commit8993ea73a9714d22178ba6ada8c04be83cd71ec7 (patch)
treeeec3cc3c457b3e760f6ca631fd51e0c004705e88 /dev-python/pygit2/pygit2-1.10.1.ebuild
parentae838334efa4ecfd172331e8f5ae4eea8c5dd876 (diff)
gentoo auto-resync : 29:08:2022 - 22:47:16
Diffstat (limited to 'dev-python/pygit2/pygit2-1.10.1.ebuild')
-rw-r--r--dev-python/pygit2/pygit2-1.10.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pygit2/pygit2-1.10.1.ebuild b/dev-python/pygit2/pygit2-1.10.1.ebuild
new file mode 100644
index 000000000000..47951e5eef7a
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.10.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="
+ https://github.com/libgit2/pygit2/
+ https://pypi.org/project/pygit2/
+"
+SRC_URI="
+ https://github.com/libgit2/pygit2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ =dev-libs/libgit2-1.5*:=
+"
+BDEPEND="
+ >=dev-python/cffi-1.9.1:=[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+}
+
+src_test() {
+ rm -r pygit2 || die
+ distutils-r1_src_test
+}