summaryrefslogtreecommitdiff
path: root/dev-python/pyghmi
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/pyghmi
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/pyghmi')
-rw-r--r--dev-python/pyghmi/Manifest4
-rw-r--r--dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild (renamed from dev-python/pyghmi/pyghmi-1.0.22.ebuild)11
-rw-r--r--dev-python/pyghmi/pyghmi-1.5.5.ebuild38
3 files changed, 48 insertions, 5 deletions
diff --git a/dev-python/pyghmi/Manifest b/dev-python/pyghmi/Manifest
index 52ad95309610..9049220e1de2 100644
--- a/dev-python/pyghmi/Manifest
+++ b/dev-python/pyghmi/Manifest
@@ -1,3 +1,5 @@
DIST pyghmi-1.0.22.tar.gz 123267 BLAKE2B 8cfa716d04411dc5228d86cf8813ddb4fb61b7bfeb6618f0182fe42c7ed1deb46e876e085a732d69b3c7390c37a8bc62a3bf15313166574ec98ccefa784b97eb SHA512 9e3bc6b5f33d5496d7e58d2ea558d20d45a7690d493f2d1ad56fdd5570279a38e8934d8425c3d3207d8001da85a9a0b1319463b802fa9f121db7448aa919bddc
-EBUILD pyghmi-1.0.22.ebuild 1243 BLAKE2B d73baf3b88f5846daefdf4381b0adc2825de42ce6f0dfab8c7d98ded4ebe489dc0417606c5a1ba8fc5ffd98663a80da1a9fd44ffbc7661f842684dae4614ed91 SHA512 3ce4d7be91b8b0df06d68718f1b06ba0e693f5e0e391af001c56a6c7ab79b8530924fa9628dbad1b8da241a9282db30b45bc26b197c9b7c66b5e2d7692bd5e39
+DIST pyghmi-1.5.5.tar.gz 195830 BLAKE2B de7acc04e4b33f9a623cbe1afcd0caf869dea3e635df5e7ee1c609ac223cd6bf203735da54b6fe0e9f9a98e2371077f6e2d29dea60112014d58477195e798118 SHA512 9f1e1e0f0cf88c0ff794a29e4116b20dcf5eae141c1eefb6c5b8e3fae948fe6f928cd98dc4b95248c5cddab1cea3b841818e3255ec85c11d5c039dcc2c315cbb
+EBUILD pyghmi-1.0.22-r1.ebuild 1266 BLAKE2B bb7f5c9dc99478bce9e2fc9eea4fdb29f161eff886b94ddac468b2372c1f9fe6d91e07308c6afba6adc755d0b51f130efe9a4eeef59e702385b27fcc33036881 SHA512 43ed93ff7989d9e172d4afa1195118116fdc2fbf8b42de77afc519ec31aa34b542ccdfe8ee00fbbd49e7a163eec5271fac3639bb893c537b6e62cc8e9e517eae
+EBUILD pyghmi-1.5.5.ebuild 1147 BLAKE2B f7af8ac75f98ca2c2d5dbaf9cedd773aef142fdee6f09351a9d1f4b5c93bab1e4fa65f7bece5d83b96f9f9fe7a118090deaea0532ae6b89b68445586d36fb1dd SHA512 f54e5c3f6b2edd3374fc97cfed5828f19d7775838f4be5ecf705e8f91fb757fc537399dcda272aa697a2e6276ccab27f29577b9c2d084e7c32d5bef259d3a188
MISC metadata.xml 343 BLAKE2B 107a20dca0846a5e4dc8d61825da4193cc7525abad94e161022371ccba00523822c69cf0cae23d13b6f650ec11b98ef4640b5cf18437d60a9a5a6bf37867e9e8 SHA512 cb4c5f58339d6c5f181bb0e9a1aacb4e3c30c5690744e0ee6649e82eece03678246cfe3b13c219e177de8812c6916fe1b6b49443c2dc0a00ed1d024c8858b5c9
diff --git a/dev-python/pyghmi/pyghmi-1.0.22.ebuild b/dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild
index 39164e26ed17..d825c3250b25 100644
--- a/dev-python/pyghmi/pyghmi-1.0.22.ebuild
+++ b/dev-python/pyghmi/pyghmi-1.0.22-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
@@ -16,8 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]
- >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pbr[${PYTHON_USEDEP}]"
#636824 older versions of cli_helpers break the build
DEPEND="${RDEPEND}
!<dev-python/cli_helpers-1.0.0
@@ -25,7 +24,6 @@ DEPEND="${RDEPEND}
test? (
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
- >=dev-python/hacking-0.5[${PYTHON_USEDEP}]
>=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
>=dev-python/os-testr-0.8.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
@@ -35,6 +33,11 @@ DEPEND="${RDEPEND}
>=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
)"
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed '/^pycrypto>=2\.6$/d' -i requirements.txt || die
+}
+
python_test() {
esetup.py testr --coverage || die "Tests failed under ${EPYTHON}"
}
diff --git a/dev-python/pyghmi/pyghmi-1.5.5.ebuild b/dev-python/pyghmi/pyghmi-1.5.5.ebuild
new file mode 100644
index 000000000000..a2085f3c7d12
--- /dev/null
+++ b/dev-python/pyghmi/pyghmi-1.5.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure python implementation of IPMI protocol"
+HOMEPAGE="https://github.com/openstack/pyghmi/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/cryptography-2.1[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.5[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ stestr run || die "Tests failed under ${EPYTHON}"
+}