summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pygccxml
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest5
-rw-r--r--dev-python/pygccxml/metadata.xml13
-rw-r--r--dev-python/pygccxml/pygccxml-1.0.0.ebuild37
-rw-r--r--dev-python/pygccxml/pygccxml-1.7.5.ebuild39
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
new file mode 100644
index 000000000000..d239525aa30b
--- /dev/null
+++ b/dev-python/pygccxml/Manifest
@@ -0,0 +1,5 @@
+DIST pygccxml-1.0.0.zip 21639068 BLAKE2B 7ea93921485553f635e845e4261fcca7b995de54135ee87ca48f72c1f0bad151ac74097567e0635845bbf7d9fed09f673bf40a3c6e6ad32de97d5acf63d363cc SHA512 d2a96b5bb27c3620527839051e43fa1eee8884692707a347c76863ff44a04502dcff35fe18b95a35c32fb8a4935ed8d5d91bf41eb98aee74f6df08c48ddc0b67
+DIST pygccxml-1.7.5.tar.gz 3150295 BLAKE2B 69600641098aede52493cca2282464230602c4e329ba47c467993a2a6b0a2fa99ff100541dc8b6e8bdcb207a1906569a364ebf3917f35db1cd884ddbc5c4c02a SHA512 f76e1748646beaf1b16bd498026e177008f5ebe19e4b35ce612bb27f4f9e6174cdfe4459771adbc657b95e8d5edeea0687756f9ba82cabc10703043c4a7e6e1e
+EBUILD pygccxml-1.0.0.ebuild 808 BLAKE2B e4ac87202e0348d36b00c929757ddb44c02aabac91d1f8b832e2d3bcc8aa83197b11bc3822c7aded006ecbff355f30cc137ba57e43e6067fda04548d6be658df SHA512 6d42b8d8ca3fb291ba733c18c5ffca79cfd15b299cd0b51694578991826d7340abebb24925717fc4d7750ee07d75c40ab6997452651ef639d3ac3b48c8ae8716
+EBUILD pygccxml-1.7.5.ebuild 843 BLAKE2B f0fb8145bfb295885dd89d29ef01d91a12dbaee2350b214088e2b3cc5304540423832e484eda6b0fee265af8c5bd42f245419f1ad901950e7b1efd4a060c9066 SHA512 31f23f0d203e0c94836e92afac68bb7a7c9bbde02d8184c7f1c8c71c8143154667d289bd7936ea0f5dc0fc03035e254a1f40d0d532ce74c7695430695dee3dd3
+MISC metadata.xml 482 BLAKE2B 0d1bdb201e0d0e1db5527a2ac37725afe91f9a26c2bc2f58bd217818bb97d3033f1a1b76d5d82cd0dfa4d5c015e9b9d54d1ff8e50f0f089b3d35dc91a61d55ff SHA512 56f747acbf8018e5cadee2203ac26751e7cc146d76a7aec6875831da051e21d1ee349d98535a1a2e8c37aae869035f86479b0fdc80756baa501034c773d3398a
diff --git a/dev-python/pygccxml/metadata.xml b/dev-python/pygccxml/metadata.xml
new file mode 100644
index 000000000000..29fca4f45351
--- /dev/null
+++ b/dev-python/pygccxml/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>heroxbd@gentoo.org</email>
+ <name>Benda Xu</name>
+ </maintainer>
+ <longdescription>pygccxml is an object oriented framework for reading C++ declarations.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pygccxml</remote-id>
+ <remote-id type="github">gccxml/pygccxml</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygccxml/pygccxml-1.0.0.ebuild b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
new file mode 100644
index 000000000000..c8385483e97d
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-1.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
+HOMEPAGE="http://www.language-binding.net/"
+SRC_URI="mirror://sourceforge/pygccxml/${P}.zip"
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+DEPEND="
+ app-arch/unzip
+ doc? ( >=dev-python/epydoc-3[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-cpp/gccxml-0.6"
+
+python_compile_all() {
+ use doc && esetup.py doc
+}
+
+python_test() {
+ "${PYTHON}" unittests/test_all.py
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/apidocs/. )
+ use examples && local EXAMPLES=( docs/example/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pygccxml/pygccxml-1.7.5.ebuild b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
new file mode 100644
index 000000000000..76be4114be40
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-1.7.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generate an XML description of a C++ program from GCC's internal representation"
+HOMEPAGE="https://github.com/gccxml/pygccxml"
+SRC_URI="https://github.com/gccxml/pygccxml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ app-arch/unzip
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-cpp/gccxml-0.6"
+
+python_compile_all() {
+ use doc && emake html man
+}
+
+python_test() {
+ "${PYTHON}" unittests/test_all.py
+}
+
+python_install_all() {
+ if use doc ; then
+ local HTML_DOCS=( docs/_build/html )
+ doman docs/_build/man/${PN}.1
+ fi
+
+ distutils-r1_python_install_all
+}