summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-27 12:00:02 +0100
commit345c02ca33341652116ddec6705530223af2de85 (patch)
treebcb9923530ba0703557f280b0a2bd1343bae857c /dev-python/pygccxml
parentf300354de9fe5d997850456a9e1f400193e6544f (diff)
gentoo auto-resync : 27:08:2024 - 12:00:02
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest3
-rw-r--r--dev-python/pygccxml/files/pygccxml-2.5.0-fix-tests.patch107
-rw-r--r--dev-python/pygccxml/pygccxml-2.5.0.ebuild1
3 files changed, 110 insertions, 1 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
index 210a2e445ab6..4140b16e76eb 100644
--- a/dev-python/pygccxml/Manifest
+++ b/dev-python/pygccxml/Manifest
@@ -1,5 +1,6 @@
AUX pygccxml-2.4.0-doc.patch 798 BLAKE2B f062375f40ada000fd266f50d6fdf3ab70ef744c2dfdf29e4d80d1a2008fd910e09053f6cff0ee9b7fd0bd7b263331ca40a1349b821e2203a16a04032ada5a94 SHA512 357b35fa379f90ce56a391b54ff9b4550845747c79fd5c0f3b0a331adfbf5e157c7b9e2a0a7ea2b5929a4074e4ff02b7553d8131961c86b1993fbb627179c729
+AUX pygccxml-2.5.0-fix-tests.patch 5083 BLAKE2B d1b1863cc744ee9941b2064d0e5623988ce00141663f27dde3b3ff9d0db8a9d9ef28d85aabe4f42faf071d6b3e3b3559b6732e0e25b50beaf7d03425c9c09640 SHA512 156ad1196f2b41918fb85f493533e24a4c44c52e15dda15fdb262c4e602f12bcae9331ec16c4ae8bb8b50256a872dc88e371908b94d282ff973953ccb65e9fd9
AUX pygccxml-2.5.0-which.patch 2637 BLAKE2B 859f7418d5c427e27a925993c209ff6daff667abf0822eea8baf49a5ad5b349ccfb3083e765e6aa893019b402b7464c46ca50f7e484ded6f84c4d85c17955c4b SHA512 48d1bb31516afcefbb80dc04a47166bf9980da1aee9c5e434c7d45928cfee7abcaa0e7cc64752de78991144351c90b4c6160a42aa4d0639a791162467444c056
DIST pygccxml-2.5.0.gh.tar.gz 3163862 BLAKE2B 2a61474acab7e7a21b21bc7131a9b9aae2a318d3b761c9a3865055146331891e5fb2041a9136bd8816e60a4dc76a39a22d5f5632f22336341667eee537521a42 SHA512 499be7383ac9817c5620f7f0b2e6fdb9a6f5d934cc54a2ef9864877a2a7d896997ab5bc2e8b0c3c87df1ac7e4a384d3c8cbcc87f9496125502c97766df57b003
-EBUILD pygccxml-2.5.0.ebuild 988 BLAKE2B fddb62a0fe40ca174bb3f951c233537632bde810e2a7134a7b9bd883bb4d3d6e49d5ae57b47a04a441f92b69acc7feeae00ef7bf327b0d70f169dc72f3900b26 SHA512 9c04490fac37f89c76a2e71f34a79842905a446b6f8656b92d4e4abbff9da800a2f836cfdb2d995015be59d05674ceacc4e22af7a18280f679e9fde991a94632
+EBUILD pygccxml-2.5.0.ebuild 1032 BLAKE2B dd808c090fa1e8df91131fe5bbe8012f722efc2f87781ed6e8712652bf66d348465c215c0ff0cc14e49e1cbcc9e1b22690a52d555a559663561317fca185c414 SHA512 8a7b3a0c84070ee1f0b833e2d4873fd91e415159adddfcb9911506f08bafc6c91c963ddc7e57e55f059b61a64b34efec59c04ef3610e5ee5a71673b2dbeee947
MISC metadata.xml 554 BLAKE2B 27017dc7cae6aacbe62f9ba64896e0a247371844b0baab86c5c1b1673771b888e2043a4486863857b565ed18a7928c500c07b6c6dc4f1f50494e680367928aca SHA512 eb46746c8d9b3341d8057a457785ad0c3b34ba26ca941496bc5c37f767c7472a2ed2bb5aafe06f5b677710f969b9a9229d8c24cd3dcdd30624168765bc89e3b7
diff --git a/dev-python/pygccxml/files/pygccxml-2.5.0-fix-tests.patch b/dev-python/pygccxml/files/pygccxml-2.5.0-fix-tests.patch
new file mode 100644
index 000000000000..5a65fd826fff
--- /dev/null
+++ b/dev-python/pygccxml/files/pygccxml-2.5.0-fix-tests.patch
@@ -0,0 +1,107 @@
+diff --git a/unittests/test_cpp_standards.py b/unittests/test_cpp_standards.py
+index eb28418..7c76c73 100644
+--- a/unittests/test_cpp_standards.py
++++ b/unittests/test_cpp_standards.py
+@@ -23,7 +23,8 @@ class Test(parser_test_case.parser_test_case_t):
+ if "gccxml" in self.config.xml_generator:
+ return True
+
+- parser.parse(["cpp_standards.hpp"], self.config)
++ parser.parse(["cpp_standards.hpp"], self.config,
++ parser.COMPILATION_MODE.ALL_AT_ONCE)
+
+ if platform.system() != 'Windows':
+ self.config.cflags = "-std=c++98"
+@@ -33,7 +34,8 @@ class Test(parser_test_case.parser_test_case_t):
+ parser.parse(["cpp_standards.hpp"], self.config)
+
+ self.config.cflags = "-std=c++11"
+- parser.parse(["cpp_standards.hpp"], self.config)
++ parser.parse(["cpp_standards.hpp"], self.config,
++ parser.COMPILATION_MODE.ALL_AT_ONCE)
+
+ # This is broken with llvm 3.6.2 (the one from homebrew)
+ # It should work with never llvms but I keep the test disabled
+diff --git a/unittests/test_non_copyable_recursive.py b/unittests/test_non_copyable_recursive.py
+index cd78a9a..e18d58f 100644
+--- a/unittests/test_non_copyable_recursive.py
++++ b/unittests/test_non_copyable_recursive.py
+@@ -27,7 +27,7 @@ class Test(parser_test_case.parser_test_case_t):
+ RuntimeError: maximum recursion depth exceeded while
+ calling a Python object
+ """
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+ global_ns = declarations.get_global_namespace(decls)
+
+ # Description of the problem (before the fix):
+@@ -52,7 +52,7 @@ class Test(parser_test_case.parser_test_case_t):
+ RuntimeError: maximum recursion depth exceeded while
+ calling a Python object
+ """
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+ global_ns = declarations.get_global_namespace(decls)
+
+ # Real life example of the bug. This leads to a similar error,
+diff --git a/unittests/test_null_comparison.py b/unittests/test_null_comparison.py
+index 51caf4a..787ae79 100644
+--- a/unittests/test_null_comparison.py
++++ b/unittests/test_null_comparison.py
+@@ -22,7 +22,7 @@ class Test(parser_test_case.parser_test_case_t):
+ Test for None comparisons with default arguments
+ """
+
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+ global_ns = declarations.get_global_namespace(decls)
+
+ ns = global_ns.namespace("ns")
+diff --git a/unittests/test_overrides.py b/unittests/test_overrides.py
+index 9204efc..5ac1b25 100644
+--- a/unittests/test_overrides.py
++++ b/unittests/test_overrides.py
+@@ -23,7 +23,7 @@ class Test(parser_test_case.parser_test_case_t):
+ def setUp(self):
+
+ if not self.global_ns:
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+ Test.global_ns = declarations.get_global_namespace(decls)
+ Test.xml_generator_from_xml_file = \
+ self.config.xml_generator_from_xml_file
+diff --git a/unittests/test_pattern_parser.py b/unittests/test_pattern_parser.py
+index 00a6805..4882c26 100644
+--- a/unittests/test_pattern_parser.py
++++ b/unittests/test_pattern_parser.py
+@@ -27,7 +27,7 @@ class Test(parser_test_case.parser_test_case_t):
+ if self.config.xml_generator == "gccxml":
+ return
+
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+
+ for decl in declarations.make_flatten(decls):
+ if "myClass" in decl.name:
+@@ -44,7 +44,7 @@ class Test(parser_test_case.parser_test_case_t):
+ if self.config.xml_generator == "gccxml":
+ return
+
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+ global_ns = declarations.get_global_namespace(decls)
+ criteria = declarations.declaration_matcher(name="myClass")
+ _ = declarations.matcher.find(criteria, global_ns)
+diff --git a/unittests/test_smart_pointer.py b/unittests/test_smart_pointer.py
+index e9183b7..4a85860 100644
+--- a/unittests/test_smart_pointer.py
++++ b/unittests/test_smart_pointer.py
+@@ -22,7 +22,7 @@ class Test(parser_test_case.parser_test_case_t):
+ def setUp(self):
+ if self.config.xml_generator == "gccxml":
+ return
+- decls = parser.parse([self.header], self.config)
++ decls = parser.parse([self.header], self.config, parser.COMPILATION_MODE.ALL_AT_ONCE)
+ self.global_ns = declarations.get_global_namespace(decls)
+
+ def test_is_smart_pointer(self):
diff --git a/dev-python/pygccxml/pygccxml-2.5.0.ebuild b/dev-python/pygccxml/pygccxml-2.5.0.ebuild
index ba61c6612e8e..f9950b4f3f47 100644
--- a/dev-python/pygccxml/pygccxml-2.5.0.ebuild
+++ b/dev-python/pygccxml/pygccxml-2.5.0.ebuild
@@ -40,6 +40,7 @@ EPYTEST_DESELECT=(
python_prepare_all() {
local PATCHES=(
+ "${FILESDIR}/${PN}-2.5.0-fix-tests.patch"
"${FILESDIR}/${PN}-2.4.0-doc.patch"
# https://github.com/CastXML/pygccxml/pull/179
"${FILESDIR}/${P}-which.patch"