summaryrefslogtreecommitdiff
path: root/dev-python/pygccxml
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/pygccxml
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/pygccxml')
-rw-r--r--dev-python/pygccxml/Manifest3
-rw-r--r--dev-python/pygccxml/metadata.xml12
-rw-r--r--dev-python/pygccxml/pygccxml-2.2.1.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pygccxml/Manifest b/dev-python/pygccxml/Manifest
new file mode 100644
index 000000000000..7430b1780b8e
--- /dev/null
+++ b/dev-python/pygccxml/Manifest
@@ -0,0 +1,3 @@
+DIST pygccxml-2.2.1.tar.gz 3170283 BLAKE2B b53123c59d098f56d97841225d10ffd4156b993244e48c4ad30e2f62b6d95d69e0ae4bbfc86bb492e88e8f52d916401f29a6ec7024277d1e32b3af691a12e919 SHA512 32013617d4d632617b616d3787631c5b09da441a87bb15b88e3b287f17b85e1388308e85dd385276966ac09114536a5863edd5fbb96539547783fd2d41c6e8ce
+EBUILD pygccxml-2.2.1.ebuild 610 BLAKE2B 4fbcc2111047d33d61b6679fc53845bae7b4b93a63d47c0ccfc21758c6d09602a39ec22af74e149bc1b326bcf391404f8cd08e31ab510abaeb4cd0767562c690 SHA512 2c07b1f904dc18f6319b308766e522a0805448ef6f33434e965bd8e18e5fa2c9a60ea2f859c533830a3480aaee8c759d38da25449fe2402ed5df2c6993e4dc5c
+MISC metadata.xml 339 BLAKE2B 6a508ab09b30c771e4a962cf9d6debf8502907b91e2fea803a07f0871dbba5acc21c832d39674bf6431d6193775dacce982e3d726d32b81dee1d4fbd8ab52f7e SHA512 6bd8661c8651d51c1238fbf24a338a2179745fed87ed8012e67f163611ff5e14d50f802eddf5dc4dc7f00fd297a7734157a445a4d19163fd0df248005027b885
diff --git a/dev-python/pygccxml/metadata.xml b/dev-python/pygccxml/metadata.xml
new file mode 100644
index 000000000000..642c87f3644f
--- /dev/null
+++ b/dev-python/pygccxml/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>radio@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/pygccxml/pygccxml-2.2.1.ebuild b/dev-python/pygccxml/pygccxml-2.2.1.ebuild
new file mode 100644
index 000000000000..7dca13440725
--- /dev/null
+++ b/dev-python/pygccxml/pygccxml-2.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A specialized XML reader to navigate C++ declarations"
+HOMEPAGE="https://github.com/CastXML/pygccxml"
+SRC_URI="https://github.com/CastXML/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/castxml
+"
+
+DEPEND="${RDEPEND}"