summaryrefslogtreecommitdiff
path: root/dev-python/pygame_sdl2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pygame_sdl2
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pygame_sdl2')
-rw-r--r--dev-python/pygame_sdl2/Manifest3
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r3.ebuild42
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-7.3.5.ebuild40
3 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/Manifest b/dev-python/pygame_sdl2/Manifest
index 375e00841ee7..277ad3e08a45 100644
--- a/dev-python/pygame_sdl2/Manifest
+++ b/dev-python/pygame_sdl2/Manifest
@@ -1,4 +1,7 @@
AUX pygame_sdl2-6.99.12.4-mixer.patch 1513 BLAKE2B fa0134e7e4c458caf720169bdb655793e2caebe746e04c5204c210b3535830afa56e8cacf2972fb27953500c4e82dbcc5554fbcbbc20a098d7a325b4b30e08d3 SHA512 4c7fb5b9f55e8f4bfde5ac911bda4f83be535a101eeec80595f70a290228cbdddf2686595901aca25c429beac34ed4ee906c92ddb0522b4c73ce48c1e1556b31
DIST pygame_sdl2-2.1.0-for-renpy-6.99.12.4.tar.gz 2294620 BLAKE2B 14da5e955ca6b9f6a08be1a3ae929db63e358c53b7a05a16cda73d6e3625a7d522dd5dfc972be978f330f26bb30dc70f4657501cd5e5a6d44c1f6b81eebe3fa4 SHA512 eacce553d6729b937c13420d826f2fe327bc7aba499a06bea7f1ceedba3327a9456c023878290ace39e1a8e417f54957345b8b78500ffc9ed3d2ec9952397754
+DIST pygame_sdl2-2.1.0-for-renpy-7.3.5.tar.gz 2678274 BLAKE2B 537e63a7e4755f6fea20f4ceec065272b83879958a0a794780b8976877aa083a2a9bc1b8b4a4592accaeb59dbeeac480d75965291ddbff324aea5c90d7dbcfc0 SHA512 b58a57d70efdfcea066735e3681047bec4fc89a9b75e423f5f889cd29f89a25bd0b96fcbca17578958b677e44858aafc9c6b17aad54dae640640bb7eb54cddbd
EBUILD pygame_sdl2-6.99.12.4-r2.ebuild 992 BLAKE2B 3db7b7f60e3dceb0aeda3b74c8dd9a06bc9d9a75b8fd7be83425c3be43e9d162ea5dc4eca80425c83eef1e90cc4674e7c6f7bcf6d75591d2c1e0bbcadcae3867 SHA512 3d142c9e99ba744c550b8a598eb539087af08d0a18c5a34975bf034f646f955cdc66e8101288144f0b2be27c0053fd4d7b9677c1fdc4ae978916f5ac8adab74c
+EBUILD pygame_sdl2-6.99.12.4-r3.ebuild 1002 BLAKE2B 0421f75bedbc27a02f6701d845bf2e418e36e656a451dfc73b96002f1ff473cf9da176029c43ecbbb7c99dda4f745a48bf554dcb9266fb7265915eb3be4da439 SHA512 8e9f5e3cec0e0eff03ce356c116838c63b37ecb343fdde27c5851598d94028553eaccb1aaba77ff7815fd454ec0596c694a712734e9eb3c60ca44f7e4de4b675
+EBUILD pygame_sdl2-7.3.5.ebuild 941 BLAKE2B 9d365f8ef70e371d8dbd2893b71282f4c1431d43f76e20517b5c69c87576642900f4f56e345970945f0e0650ac16642e06035ac2f18e6a3f4f63e3ec335cd4d1 SHA512 dcd3a8f4b18abf07214a6dfaa4532ff23a41a691f58b2ad286308602bd7d6c2db70d05f3c51dace2ac3239092273c74aa611a872a72580d39ae74d2bf00288ab
MISC metadata.xml 332 BLAKE2B 3af5bfcb689c906453097e4bcc7a7b87ccec6bb1f1f8c43766d4ae5c473f9e220314b8591c63ab9b4ddd67eb411a27400a431a043ca5f696069fc4bf31291ffb SHA512 ae1f94e0d1f533a9f2db740f0a1c534456cf5a919262aebfcb501269ca3b508e697750c4bbc6eb60db8dda2182ecb712a10dad5d91efce20f24c5a736d9b3521
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r3.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r3.ebuild
new file mode 100644
index 000000000000..87e4c0444694
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+inherit distutils-r1
+
+PYSDL="${PN}-2.1.0"
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ >=media-libs/sdl2-mixer-2.0.2:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+
+PATCHES=( "${FILESDIR}/pygame_sdl2-6.99.12.4-mixer.patch" )
+
+# PyGame distribution for this version has some pregenerated files;
+# we need to remove them
+python_prepare_all()
+{
+ rm -r gen{,3} || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-7.3.5.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-7.3.5.ebuild
new file mode 100644
index 000000000000..d774c961920d
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-7.3.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+inherit distutils-r1
+
+PYSDL="${PN}-2.1.0"
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0=
+ media-libs/libsdl2:=[video]
+ media-libs/sdl2-image:=[png,jpeg]
+ >=media-libs/sdl2-mixer-2.0.2:=
+ media-libs/sdl2-ttf:=
+ virtual/jpeg:0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+
+# PyGame distribution for this version has some pregenerated files;
+# we need to remove them
+python_prepare_all()
+{
+ rm -r gen{,3} || die
+ distutils-r1_python_prepare_all
+}