summaryrefslogtreecommitdiff
path: root/dev-python/pygame_sdl2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pygame_sdl2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pygame_sdl2')
-rw-r--r--dev-python/pygame_sdl2/Manifest5
-rw-r--r--dev-python/pygame_sdl2/metadata.xml11
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild39
-rw-r--r--dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild29
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/pygame_sdl2/Manifest b/dev-python/pygame_sdl2/Manifest
new file mode 100644
index 000000000000..aa8741e4c0aa
--- /dev/null
+++ b/dev-python/pygame_sdl2/Manifest
@@ -0,0 +1,5 @@
+DIST pygame_sdl2-2.1.0-for-renpy-6.99.12.4.tar.gz 2294620 BLAKE2B 14da5e955ca6b9f6a08be1a3ae929db63e358c53b7a05a16cda73d6e3625a7d522dd5dfc972be978f330f26bb30dc70f4657501cd5e5a6d44c1f6b81eebe3fa4 SHA512 eacce553d6729b937c13420d826f2fe327bc7aba499a06bea7f1ceedba3327a9456c023878290ace39e1a8e417f54957345b8b78500ffc9ed3d2ec9952397754
+DIST pygame_sdl2-for-renpy-6.99.6.tar.bz2 133501 BLAKE2B 6d23b9bad3fad1b508525bdc7b18dbf0801d7c7e36e15b843104e763b5946c79e22663bf705e071b35c8b4742e3f8e59bfaa0345dc95b18f91b9dd186e6d4df6 SHA512 de1a40f7e8acdb46a7e0b13250c7fffdf848bd44c07408928aab6214afbc741aa77e1e8314d9049324328d9ffc645cafe077a468457a721f36e49f98e5217d53
+EBUILD pygame_sdl2-6.99.12.4.ebuild 922 BLAKE2B 061dbbc2ba3326df51f69df941fb63e8c7960bd03739c827c8f0e1f5f0047fe6424e755677146e7801c286f0cde09ead812eb0328ee1e5780dee475f3502b678 SHA512 1069188bb58137dbac5e78f62eeff2228e34508434450dc6971bb3d52a92be2677f793c8e9af18951e96b5c5f0ffbdfcf1685ad62dadc3424da164ac86e1ab2a
+EBUILD pygame_sdl2-6.99.6-r1.ebuild 729 BLAKE2B 363c8b22b45dfcb7546618a54c47e18ed89c0416cd500285b84f8e8d0a94f981ac9e6b21266df4fcca7b02a7d56c4440d8947bb6c467decd0f1758ca90b6c391 SHA512 c72b4c6c9be055a6e4301796d123b61bea2a498b7be7644a9b3b166a8425d0668f181dc83ef6956c2829e7ded467e9326bda11b2f07f615539cc5cbf4c0d1db9
+MISC metadata.xml 332 BLAKE2B 3af5bfcb689c906453097e4bcc7a7b87ccec6bb1f1f8c43766d4ae5c473f9e220314b8591c63ab9b4ddd67eb411a27400a431a043ca5f696069fc4bf31291ffb SHA512 ae1f94e0d1f533a9f2db740f0a1c534456cf5a919262aebfcb501269ca3b508e697750c4bbc6eb60db8dda2182ecb712a10dad5d91efce20f24c5a736d9b3521
diff --git a/dev-python/pygame_sdl2/metadata.xml b/dev-python/pygame_sdl2/metadata.xml
new file mode 100644
index 000000000000..88d1d1b3d9f8
--- /dev/null
+++ b/dev-python/pygame_sdl2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">renpy/pygame_sdl2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild
new file mode 100644
index 000000000000..0655887619e7
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.12.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+PYSDL="${PN}-2.1.0"
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/${PYSDL}-for-renpy-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image[png,jpeg]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ virtual/jpeg:62
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PYSDL}-for-renpy-${PV}
+
+# PyGame distribution for this version has some pregenerated files;
+# we need to remove them
+python_prepare_all()
+{
+ rm -r "${S}"/gen{,3} || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild
new file mode 100644
index 000000000000..cab2f121eb9e
--- /dev/null
+++ b/dev-python/pygame_sdl2/pygame_sdl2-6.99.6-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Reimplementation of portions of the pygame API using SDL2"
+HOMEPAGE="https://github.com/renpy/pygame_sdl2"
+SRC_URI="http://www.renpy.org/dl/${PV}/pygame_sdl2-for-renpy-${PV}.tar.bz2"
+
+LICENSE="LGPL-2.1 ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ media-libs/libpng:0
+ media-libs/libsdl2[video]
+ media-libs/sdl2-image[png,jpeg]
+ media-libs/sdl2-mixer
+ media-libs/sdl2-ttf
+ virtual/jpeg:62
+"
+DEPEND="${RDEPEND}
+ dev-python/cython[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/pygame-sdl2-for-renpy-${PV}