summaryrefslogtreecommitdiff
path: root/dev-python/pygame
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-02 11:46:02 +0100
commitfade240e5eae2521e59569af4ab63e27415f4e5b (patch)
tree18ce5cd3bed52f77d3ff5fbe8b47a025b6892619 /dev-python/pygame
parent16c48ec5caa018c82b1db0f23542c29893f9b919 (diff)
gentoo auto-resync : 02:10:2023 - 11:46:02
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/Manifest3
-rw-r--r--dev-python/pygame/files/pygame-2.5.0-cython-3.patch214
-rw-r--r--dev-python/pygame/pygame-2.5.0-r2.ebuild92
3 files changed, 0 insertions, 309 deletions
diff --git a/dev-python/pygame/Manifest b/dev-python/pygame/Manifest
index 17269271e660..9a8181bb65bb 100644
--- a/dev-python/pygame/Manifest
+++ b/dev-python/pygame/Manifest
@@ -1,6 +1,3 @@
-AUX pygame-2.5.0-cython-3.patch 8237 BLAKE2B 3de903f00f59a98f332e19ed55c0082980cd08a52ce697863e168be7af0db33c17546ed01d2ccd94ad957d57b7e094b769e4ab300974a5f97275cdfb5c816525 SHA512 f7336dea50f62ba1b2d6d0f19a24a73e776907e42a8d7ddd966f484c6660e5bb079030f174c9bf2d53eae52e80aadee4b46eb057be4d8937480d09610320d9dc
-DIST pygame-2.5.0.gh.tar.gz 6640084 BLAKE2B affa92cacee34ab1db246e80bea0ee425985c1c2a75b5702b2368536fe4b07ffb24f5e6ef345afb3ee63e7b1eccfc275082649251791a2f34a0eba019cc327a8 SHA512 741c5d11b2b52c5bc08672fb9e7420540f20879ef67b84dd18904d317f3cce7593bf08a9e7bf9d0c6470c6bb88512c9af9eb86056e654ab32d4b33532b2bf702
DIST pygame-2.5.1.gh.tar.gz 6854761 BLAKE2B e137f73a3bb718213ef92e938ed1b065f5568d7dd2ade6edd973bc55d06425874da0e89e3c102fad39adac25f977ac97025a0c59099702cfabeffd0d3b8f109f SHA512 d7aceb2bc6e40c5dc2d7a19fdc7af18abf021b79dd98b859975f99ec10895e1b09e11fbf17fd6ab925d3aa6c64e5b3dd56c0d857ecacc67303d92fc0efb2630c
-EBUILD pygame-2.5.0-r2.ebuild 1974 BLAKE2B 9aba9c5d3eda4c3b30c796660834fbb953d8c6c7ad12f8e3423722cd654b4ef61b788cad059ed8552890c63fc8e7a7876f01ab91aa50422db276f013e92372d9 SHA512 7b55f6e6dcc494a7091c5731289c48f67b1b643048a81335b2f08df54f95829a0ef2e8a1c9165a808f061b96dd3dcf0f25caee5396e778510465e336f8ed20d1
EBUILD pygame-2.5.1.ebuild 1926 BLAKE2B f08e24fb19733c2272d19122702b553b7509c852719a6ef852e76a31f3e10756effd36ae709ae0e44a820645471e1f0be0973503237ab05e197dc5a950cf4e22 SHA512 09f4845aaafb9026bf0f8f5dfbee9133b610f1ee0e8f046c1380258ae82cf9d463e221a96739e0110e4f68c44ef624771d0d0db6e7a069d6b5961c588a01b1e1
MISC metadata.xml 363 BLAKE2B a942b91aded22ec850a7b075703ce4037af9f0a61155717ac455f7d2b7779cb6f5f953b2ad8d61d7cc5254307951a20dd3edb9853e21d907e1999f7570a6b821 SHA512 15403754c9b13f9b2d8c5e7615ae0ca9359b5079e22eb5a7049424e414ebbdd8a06f6324c31594636324414e35ca34bec977b7dded9f9ea14027497b5097b060
diff --git a/dev-python/pygame/files/pygame-2.5.0-cython-3.patch b/dev-python/pygame/files/pygame-2.5.0-cython-3.patch
deleted file mode 100644
index 48e48e738ab3..000000000000
--- a/dev-python/pygame/files/pygame-2.5.0-cython-3.patch
+++ /dev/null
@@ -1,214 +0,0 @@
-https://bugs.gentoo.org/898704
-https://github.com/pygame/pygame/issues/3938
-https://github.com/pygame/pygame/pull/3956
-https://github.com/pygame/pygame/commit/bff1ba00fa58de40d357d70ba645be2957593b69
-
-From bff1ba00fa58de40d357d70ba645be2957593b69 Mon Sep 17 00:00:00 2001
-From: Matus Valo <matusvalo@gmail.com>
-Date: Wed, 12 Jul 2023 01:26:21 +0200
-Subject: [PATCH] Mark functions as noexcept
-
---- a/src_c/cython/pygame/_sdl2/audio.pyx
-+++ b/src_c/cython/pygame/_sdl2/audio.pyx
-@@ -67,7 +67,7 @@ def get_audio_device_names(iscapture = False):
- return names
-
- import traceback
--cdef void recording_cb(void* userdata, Uint8* stream, int len) nogil:
-+cdef void recording_cb(void* userdata, Uint8* stream, int len) noexcept nogil:
- """ This is called in a thread made by SDL.
- So we need the python GIL to do python stuff.
- """
---- a/src_c/cython/pygame/_sdl2/controller.pxd
-+++ b/src_c/cython/pygame/_sdl2/controller.pxd
-@@ -101,8 +101,8 @@ cdef extern from "../controllercompat.c" nogil:
- Uint16 high_frequency_rumble,
- Uint32 duration_ms)
-
--cdef bint _controller_autoinit()
--cdef void _controller_autoquit()
-+cdef bint _controller_autoinit() noexcept
-+cdef void _controller_autoquit() noexcept
-
- cdef class Controller:
- cdef SDL_GameController* _controller
---- a/src_c/cython/pygame/_sdl2/controller.pyx
-+++ b/src_c/cython/pygame/_sdl2/controller.pyx
-@@ -17,14 +17,14 @@ def _gamecontroller_init_check():
- if not SDL_WasInit(_SDL_INIT_GAMECONTROLLER):
- raise error("gamecontroller system not initialized")
-
--cdef bint _controller_autoinit():
-+cdef bint _controller_autoinit() noexcept:
- if not SDL_WasInit(_SDL_INIT_GAMECONTROLLER):
- if SDL_InitSubSystem(_SDL_INIT_GAMECONTROLLER):
- return False
- #pg_RegisterQuit(_controller_autoquit)
- return True
-
--cdef void _controller_autoquit():
-+cdef void _controller_autoquit() noexcept:
- cdef Controller controller
- for c in Controller._controllers:
- controller = c
---- a/src_c/cython/pygame/_sdl2/mixer.pxd
-+++ b/src_c/cython/pygame/_sdl2/mixer.pxd
-@@ -5,7 +5,7 @@ from .sdl2 cimport *
-
- #https://www.libsdl.org/projects/SDL_mixer/docs/SDL_mixer.html#SEC79
-
--ctypedef void (*mixcallback)(void *udata, Uint8 *stream, int len) nogil
-+ctypedef void (*mixcallback)(void *udata, Uint8 *stream, int len) noexcept nogil
-
- cdef extern from "SDL_mixer.h" nogil:
- ctypedef void (*mix_func)(void *udata, Uint8 *stream, int len)
---- a/src_c/cython/pygame/_sdl2/mixer.pyx
-+++ b/src_c/cython/pygame/_sdl2/mixer.pyx
-@@ -14,7 +14,7 @@ import traceback
- # Mix_SetPostMix(noEffect, NULL);
-
-
--cdef void recording_cb(void* userdata, Uint8* stream, int len) nogil:
-+cdef void recording_cb(void* userdata, Uint8* stream, int len) noexcept nogil:
- """ This is called in a thread made by SDL.
- So we need the python GIL to do python stuff.
- """
---- a/src_c/cython/pygame/_sdl2/video.pxd
-+++ b/src_c/cython/pygame/_sdl2/video.pxd
-@@ -430,7 +430,7 @@ cdef class Texture:
- cdef draw_internal(self, SDL_Rect *csrcrect, SDL_Rect *cdstrect, float angle=*, SDL_Point *originptr=*,
- bint flip_x=*, bint flip_y=*)
- cpdef void draw(self, srcrect=*, dstrect=*, float angle=*, origin=*,
-- bint flip_x=*, bint flip_y=*)
-+ bint flip_x=*, bint flip_y=*) noexcept
-
- cdef class Image:
- cdef Color _color
-@@ -445,4 +445,4 @@ cdef class Image:
- cdef public Texture texture
- cdef public Rect srcrect
-
-- cpdef void draw(self, srcrect=*, dstrect=*)
-+ cpdef void draw(self, srcrect=*, dstrect=*) noexcept
---- a/src_c/cython/pygame/_sdl2/video.pyx
-+++ b/src_c/cython/pygame/_sdl2/video.pyx
-@@ -731,7 +731,7 @@ cdef class Texture:
- raise error()
-
- cpdef void draw(self, srcrect=None, dstrect=None, float angle=0, origin=None,
-- bint flip_x=False, bint flip_y=False):
-+ bint flip_x=False, bint flip_y=False) noexcept:
- """ Copy a portion of the texture to the rendering target.
-
- :param srcrect: source rectangle on the texture, or None for the entire texture.
-@@ -904,7 +904,7 @@ cdef class Image:
- def get_rect(self):
- return pgRect_New(&self.srcrect.r)
-
-- cpdef void draw(self, srcrect=None, dstrect=None):
-+ cpdef void draw(self, srcrect=None, dstrect=None) noexcept:
- """ Copy a portion of the image to the rendering target.
-
- :param srcrect: source rectangle specifying a sub-image, or None for the entire image.
---- a/src_c/cython/pygame/_sprite.pyx
-+++ b/src_c/cython/pygame/_sprite.pyx
-@@ -188,10 +188,10 @@ cdef class Sprite:
- else:
- self.remove(*group)
-
-- cpdef void add_internal(self, group):
-+ cpdef void add_internal(self, group) noexcept:
- self.__g.add(group)
-
-- cpdef void remove_internal(self, group):
-+ cpdef void remove_internal(self, group) noexcept:
- self.__g.remove(group)
-
- def update(self, *args, **kwargs):
-@@ -346,16 +346,16 @@ cdef class AbstractGroup:
- """
- return list(self.spritedict)
-
-- cpdef void add_internal(self, sprite):
-+ cpdef void add_internal(self, sprite) noexcept:
- self.spritedict[sprite] = 0
-
-- cpdef void remove_internal(self, sprite):
-+ cpdef void remove_internal(self, sprite) noexcept:
- r = self.spritedict[sprite]
- if r:
- self.lostsprites.append(r)
- del self.spritedict[sprite]
-
-- cpdef bint has_internal(self, sprite):
-+ cpdef bint has_internal(self, sprite) noexcept:
- return sprite in self.spritedict
-
- def copy(self):
-@@ -650,11 +650,11 @@ cdef class OrderedUpdates(RenderUpdates):
- cpdef list sprites(self):
- return list(self._spritelist)
-
-- cpdef void add_internal(self, sprite):
-+ cpdef void add_internal(self, sprite) noexcept:
- RenderUpdates.add_internal(self, sprite)
- self._spritelist.append(sprite)
-
-- cpdef void remove_internal(self, sprite):
-+ cpdef void remove_internal(self, sprite) noexcept:
- RenderUpdates.remove_internal(self, sprite)
- self._spritelist.remove(sprite)
-
-@@ -697,7 +697,7 @@ cdef class LayeredUpdates(AbstractGroup):
-
- self.add(*sprites, **kwargs)
-
-- cpdef void add_internal(self, sprite, layer=None):
-+ cpdef void add_internal(self, sprite, layer=None) noexcept:
- """Do not use this method directly.
-
- It is used by the group to add a sprite internally.
-@@ -779,7 +779,7 @@ cdef class LayeredUpdates(AbstractGroup):
- self.add_internal(sprite, layer)
- sprite.add_internal(self)
-
-- cpdef void remove_internal(self, sprite):
-+ cpdef void remove_internal(self, sprite) noexcept:
- """Do not use this method directly.
-
- The group uses it to add a sprite.
-@@ -1059,7 +1059,7 @@ cdef class LayeredDirty(LayeredUpdates):
- if hasattr(self, key):
- setattr(self, key, val)
-
-- cpdef void add_internal(self, sprite, layer=None):
-+ cpdef void add_internal(self, sprite, layer=None) noexcept:
- """Do not use this method directly.
-
- It is used by the group to add a sprite internally.
-@@ -1333,7 +1333,7 @@ cdef class GroupSingle(AbstractGroup):
- else:
- return []
-
-- cpdef void add_internal(self, sprite):
-+ cpdef void add_internal(self, sprite) noexcept:
- if self.__sprite is not None:
- self.__sprite.remove_internal(self)
- self.remove_internal(<Sprite>self.__sprite)
-@@ -1355,13 +1355,13 @@ cdef class GroupSingle(AbstractGroup):
- None,
- "The sprite contained in this group")
-
-- cpdef void remove_internal(self, sprite):
-+ cpdef void remove_internal(self, sprite) noexcept:
- if sprite is self.__sprite:
- self.__sprite = None
- if sprite in self.spritedict:
- AbstractGroup.remove_internal(self, sprite)
-
-- cpdef bint has_internal(self, sprite):
-+ cpdef bint has_internal(self, sprite) noexcept:
- return self.__sprite is sprite
-
- # Optimizations...
-
diff --git a/dev-python/pygame/pygame-2.5.0-r2.ebuild b/dev-python/pygame/pygame-2.5.0-r2.ebuild
deleted file mode 100644
index e7cd405ad570..000000000000
--- a/dev-python/pygame/pygame-2.5.0-r2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python bindings for SDL multimedia library"
-HOMEPAGE="
- https://www.pygame.org/
- https://github.com/pygame/pygame/
- https://pypi.org/project/pygame/
-"
-SRC_URI="
- https://github.com/pygame/pygame/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-IUSE="examples opengl test X"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- media-libs/freetype
- media-libs/libjpeg-turbo:=
- media-libs/libpng:=
- media-libs/portmidi
- media-libs/sdl2-image
- media-libs/sdl2-mixer
- media-libs/sdl2-ttf
- X? ( media-libs/libsdl2[opengl?,threads,video,X] )
- !X? ( media-libs/libsdl2[threads] )
-"
-DEPEND="
- ${RDEPEND}
- test? (
- media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
- media-libs/sdl2-mixer[mp3,vorbis,wav]
- )
-"
-# fontconfig used for fc-list
-RDEPEND+="
- media-libs/fontconfig
-"
-# util-linux provides script
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- media-libs/fontconfig
- sys-apps/util-linux
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cython-3.patch
-)
-
-python_configure() {
- PORTMIDI_INC_PORTTIME=1 LOCALBASE="${EPREFIX}/usr" \
- "${EPYTHON}" "${S}"/buildconfig/config.py || die
-}
-
-python_configure_all() {
- find src_c/cython -name '*.pyx' -exec touch {} + || die
- "${EPYTHON}" setup.py cython_only || die
-}
-
-python_test() {
- local -x PYTHONPATH=${BUILD_DIR}/install/lib
- local -x SDL_VIDEODRIVER=dummy
- local -x SDL_AUDIODRIVER=disk
- script -eqc "${EPYTHON} -m pygame.tests -v" || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Bug #497720
- rm -fr "${D}$(python_get_sitedir)"/pygame/{docs,examples,tests}/ || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- use examples && dodoc -r examples
-}