summaryrefslogtreecommitdiff
path: root/dev-python/pygal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pygal
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pygal')
-rw-r--r--dev-python/pygal/Manifest3
-rw-r--r--dev-python/pygal/pygal-2.4.0-r1.ebuild45
-rw-r--r--dev-python/pygal/pygal-2.4.0.ebuild2
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-python/pygal/Manifest b/dev-python/pygal/Manifest
index da892033e311..4ed9cbc26e78 100644
--- a/dev-python/pygal/Manifest
+++ b/dev-python/pygal/Manifest
@@ -1,3 +1,4 @@
DIST pygal-2.4.0.tar.gz 4554802 BLAKE2B 9627558e734420bfb3137989d0cc1978a0a06a597d3d5d071e13653876a4bb3266f12f1a8a358076619d997998754c29ee75058356ba66da64b112a24c2cbe2a SHA512 d69fbcff3792cb0b952addc3bfbaea76628d5546482c291ef217c592a820a73a65b1eb522c5d7877e7a794d19b74636126d99a4ff280e8467ab07a95000ba823
-EBUILD pygal-2.4.0.ebuild 1564 BLAKE2B 86c89ef57c07bc87c9e8e98a1552633e2495a74532a0784ce71be5b94b675560076076ce0af104bec7ba157667cd34f1b26962801242f11f0d03fc43388bae89 SHA512 e3cf57e2dbe082e8be4621fd71b366a67d1aba37828eb92d867f5b1fced45aeca836a7ff4b9858b14da67630bb6fabf90371fbcd04acdb9ace7a3a84433e5f92
+EBUILD pygal-2.4.0-r1.ebuild 1191 BLAKE2B 83bde0e7f98f47f3cf9cb8ce1f9730a47623f7d324b76011635b685da32df852e7123ebc97c57c781b9ad6f277309aa53a3c69bee935dbe1a8cab5e9b004508c SHA512 3f61574358b3de3b253822889e8250606221d57ce2c75264a60b16844a7805b962db4511248a2170fcb3d68fddc3de7f3ebbfeccd5a3ec6717aaf56a81c90696
+EBUILD pygal-2.4.0.ebuild 1578 BLAKE2B 6f8bcd822896d4fd8c9780400cc765c5d27f450c9aa9f2ddbcf35354275d1591b6fe4e3d8134488c6188b6734fa8db60a87174314b9025f37624aad3febb2920 SHA512 50c10760f58eff1400cec24ed8719540216985018da0150de858e4c41dbf48934294b2d743cdca902ac547db4c85e6bc5836f43a0be0666e16734a25710e0e86
MISC metadata.xml 432 BLAKE2B 935ce59a5a29aecbe4015fc52312fb03be02821a20863d20171378a68ced0aadfb43f7d1898fe52b8159cc0cd5a78ae0daedb97b730fd864de39abf3a617cd92 SHA512 1d2e68e4622a235b6df15390271b1f331b366a2ad1432740de81de20b494ccfc9e5f0e94f8b63acee67679e10267c0f21c66b58514e72f32d0fa3b5b262640d3
diff --git a/dev-python/pygal/pygal-2.4.0-r1.ebuild b/dev-python/pygal/pygal-2.4.0-r1.ebuild
new file mode 100644
index 000000000000..314d9f5fee91
--- /dev/null
+++ b/dev-python/pygal/pygal-2.4.0-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="A python SVG charts generator"
+HOMEPAGE="https://github.com/Kozea/pygal/"
+# PyPI tarballs do not contain docs
+# https://github.com/Kozea/pygal/pull/428
+SRC_URI="https://github.com/Kozea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-gfx/cairosvg[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+# CHANGELOG is a symlink to docs/changelog.rst
+DOCS=( docs/changelog.rst README.md )
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Not actually required unless we want to do setup.py test
+ # https://github.com/Kozea/pygal/issues/430
+ sed -i -e "/setup_requires/d" setup.py || die
+ # [pytest] section in setup.cfg files is no longer supported
+ sed -i -e 's@\[pytest\]@[tool:pytest]@' setup.cfg || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pygal/pygal-2.4.0.ebuild b/dev-python/pygal/pygal-2.4.0.ebuild
index 6bb4f8c95ed3..b50eb480cab9 100644
--- a/dev-python/pygal/pygal-2.4.0.ebuild
+++ b/dev-python/pygal/pygal-2.4.0.ebuild
@@ -8,7 +8,7 @@ PYTHON_REQ_USE="xml(+)"
inherit distutils-r1
DESCRIPTION="A python SVG charts generator"
-HOMEPAGE="http://pygal.org/"
+HOMEPAGE="https://github.com/Kozea/pygal/"
# PyPI tarballs do not contain docs
# https://github.com/Kozea/pygal/pull/428
SRC_URI="https://github.com/Kozea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"