summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 22:23:22 +0100
commit99b2c44c1425c7b2925846d4c44b2bf2f78dc786 (patch)
tree9bf7a2d385aace0ea5f3f8d3e3657168b758fdaa /dev-python/pyftpdlib
parent39bccce90513402ec93bb0fde30678f16b07a9cc (diff)
gentoo auto-resync : 08:07:2023 - 22:23:22
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest1
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.7-r1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 9c37e3953d55..298f01657a03 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1,4 @@
DIST pyftpdlib-1.5.7.tar.gz 196076 BLAKE2B 9400fb9ff5d8c0e904f07dabef72a07528bc43a5332ad26544f0e512c457a919e887e9f9af18b75cb7853f2e0b70993bc5a858438924320e738d4bc9e2e17090 SHA512 66ad5a1ab8fde26233250351f553cdc411303616d717c416cdce059f93c64e6ef64c7707103644583249b6aba22a9841994b38e731edc7997e95e266dbdbdc22
+EBUILD pyftpdlib-1.5.7-r1.ebuild 1468 BLAKE2B 9e19bd82f4f5b891e91f56334bcc2be250ffc5e4068b1560695cdd51758ff0624bccd1c10545c2a6db069c8582b8c383cdd6d104fac6738793093b77d69b38e8 SHA512 c97d760893d9b3779953b16163c451e5af91f42ee636cecf88276475dee1d6fa5f934deeff9fb38d838a730cc5156d68df136ab28b9530489d1557228cef6ebd
EBUILD pyftpdlib-1.5.7.ebuild 3122 BLAKE2B a3b276987776a4617dd5d24e990974a83fc0071cc04571a2415d6f00ec86b245174e22289728d3d1c286368c22107ec2412cb754cd9568310e0aa1d2a6c0b851 SHA512 30f7fa9b61b144000646a76e859a69dbcba9c3e6f3e3a69b834e21ca030c0c59c995ec2be5e56a21ad6d9bf20c67953c3b3d77e22c927b221b3f72b3528650dd
MISC metadata.xml 463 BLAKE2B ad4e4d5a1717e55743061f2cb4baaa7ea8ce73f4caf0c8d62535aaf73daf12339584bf75c82c35b425223f478094bb37518b43d34694fb4bc6aef6f11033fa8e SHA512 98bb4e647da164a8676f9162d1109d1f6d1ff9279ba8d26207f2ed793537af27de11b40296bacfb478e87b6479c9d31bb24f56bc1acf2a0bc228b2d00a733e1d
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.7-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.7-r1.ebuild
new file mode 100644
index 000000000000..c5dcd0b8478b
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="ssl(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="
+ https://github.com/giampaolo/pyftpdlib/
+ https://pypi.org/project/pyftpdlib/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples ssl"
+
+RDEPEND="
+ ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_test() {
+ rm -rf pyftpdlib || die
+ # Some of these tests tend to fail
+ local EPYTEST_DESELECT=(
+ # fail because they process sys.argv and expect program args
+ # rather than pytest args, sigh
+ test/test_misc.py
+ # TODO
+ test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
+ )
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ local -x TZ=UTC+1
+ # Skips some shoddy tests plus increases timeouts
+ local -x TRAVIS=1
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest --pyargs pyftpdlib
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r demo/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}