summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /dev-python/pyftpdlib
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild9
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index e247ae22eb99..1c61717f4e67 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -3,5 +3,5 @@ DIST pyftpdlib-1.5.3.tar.gz 183189 BLAKE2B dd563f59ff21b2059e1c6d6ac6015561d5e0d
DIST pyftpdlib-1.5.4.tar.gz 184986 BLAKE2B 6973b1f7e0fc0c89eb5d79e082690a706b56553ad4b2ece68a8216bb99c185d770475e349402ec71baf1bb06e5ecca5be2a3c52512f0d8283c4cc249bc28a949 SHA512 6eb308021dad28c1c51a88b366947a71b7bc1802571dc14cedf3a264bd0cb8504ef990d7e3110d10709f971d4d5b0001bee859b58fb4d02a1b0d46532acc9295
EBUILD pyftpdlib-1.5.1.ebuild 1298 BLAKE2B 2b6ff8c9de74fc7e94720c6deecc32ac2303674f80230b7b2823f43c84755153f69d6c3254264a5b1f41ead167227b71fabca1341549765b045679686d9df1f8 SHA512 5c44d3dcb62a9b72e4773bb5eef46b69576924367db85de5a73977f187d0cf5c8023c0756b913dcc238d6e3ba16f62a06355fd74463bfbe716a900aa3eb86468
EBUILD pyftpdlib-1.5.3.ebuild 1556 BLAKE2B 06acd30f37ed3409d5919bdb11cd0b85a38714ccc2c1cf87ec9af1565f848a80f7fe0bba91529b0719a19303073c75fd855e48e66ba46bc8eb704599225f9cd1 SHA512 dcc8187355c079c8d6f6e9ba485b2b07a4f1f0e0f6ff8bb22e0932d953b55b7c01f2dfde5f815dc868fe8e826c163a72d2c300d9cbb0c1aa48b39cc175a399d2
-EBUILD pyftpdlib-1.5.4.ebuild 2536 BLAKE2B 912454d4d019c0efcca4e8a1805050e650172b1f64ace54025be850b3dcb2215febab95e8f71928886d1678675e352db1090be135f5b79b5b101f1d9feb6d257 SHA512 93e045cd4730a84e035f5e75588d637718b1a160dd5f7303ab71407ea84e93ad8a1206ba2c4658b646c8be27e98efe950132fb36d3911ef075b3087df67d3668
+EBUILD pyftpdlib-1.5.4.ebuild 2529 BLAKE2B 0d2be096e13b7d76c204d7c441a4b2ccf41104066da347538ec458a7a2a4a482166fc59bee47ad65c41311d32bc28cb29ffff067ce37e6b3034da2c34cc866dc SHA512 bf67bfe6733a3f432a81c5c1d68284aec3c69e80fdac90c62381339c765581edb25abc8a01398104bcc5883021161b7aed918d0ad8ea1827f4a5b56cf0b64386
MISC metadata.xml 438 BLAKE2B 0e0860eb9d885ec9b432b504bef6a9394cf4a2d6d99751c80fec8441d8910f8a17364e5f32782638ac689abf5cdd3ebcb5fa20e7da3d612a5e8844e8c8a34d76 SHA512 a748827370b53c94fed352cd6bbd7468a22c7ca2f15c4601c98a2689e3a7e652ed28434bcd125fe0f3018d5508600df03130c18d7d67834b28ac0c3480b16345
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
index b34a8629054b..1633ef26aff6 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -64,9 +64,10 @@ python_test() {
test_nlst
)
skipped_tests=${skipped_tests[@]/%/ or}
- # Don't load the relaxed plugin, see https://bugs.gentoo.org/661082
- py.test --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
- -p no:relaxed || die "Tests failed with ${EPYTHON}"
+ # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
+ TZ=UTC+1 pytest -vv \
+ --ignore ${PN}/test/test_misc.py -k "not (${skipped_tests% or})" \
+ || die "Tests failed with ${EPYTHON}"
}
python_install_all() {