summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 16:31:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 16:31:33 +0000
commit8cd3c41aa0ccead302235680b9e2fa9903d7548e (patch)
treeb6f2658c42bd34d0f1dc8b5f572aa5f5886c3d5d /dev-python/pyftpdlib
parent2900e684ae4bdce1f20652587728095cd01a30a1 (diff)
gentoo auto-resync : 25:11:2023 - 16:31:33
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild61
2 files changed, 0 insertions, 63 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index d80b8e97d9d0..e0ef211686a0 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,5 +1,3 @@
-DIST pyftpdlib-1.5.8.tar.gz 201963 BLAKE2B 5a957c207dcdc7c8d66d6ed4176cd12db019cf3d5247233db057b5c266a4fbda5e6e1c0b8ccdf33b4c154400d5d7a5e9a62ab9244f7c74c03c2f912a2ac0eb2f SHA512 2d4c4beb40d604d41eeed51f690b805377e84e594bdbb5d67135f50e5696824ba24aa9ae53aecced9f6c1b7eb3ec7727d31b883f9bbb0d2c43802277b2ef2aa6
DIST pyftpdlib-1.5.9.tar.gz 204755 BLAKE2B f96e670a37023489a3f70f28d7e489633031f4c8dd34e6ece04a13a36a5de60f216dc267a80650c3f315a6a83081b1afc1b470c75ca18af5a80729a7ac363b98 SHA512 3efa07f5522cee89d2bf60c93b1315dfb149da622f34e043aca0ac1c4336c0a0885d7238123068401afa6988da9cbde6adfac78f08918d3a14e84c17ebb8b32f
-EBUILD pyftpdlib-1.5.8.ebuild 1461 BLAKE2B 5959b6d5674617857d8f7f66e5010cc9fba123e3bb3c4d01d3b81ee1101dee1c534b56138cc58a44799ae12d903a5f81b2ae8506301ad241be484ef2371c2ea0 SHA512 80f23999152160d759eb71d52d6c646d0e3b69acc0272ad76c1e52eb96201a0256ef9c25e09bea1fce786870647f56cdf3e743515e0e1036f6da12cab1052777
EBUILD pyftpdlib-1.5.9.ebuild 1461 BLAKE2B 5959b6d5674617857d8f7f66e5010cc9fba123e3bb3c4d01d3b81ee1101dee1c534b56138cc58a44799ae12d903a5f81b2ae8506301ad241be484ef2371c2ea0 SHA512 80f23999152160d759eb71d52d6c646d0e3b69acc0272ad76c1e52eb96201a0256ef9c25e09bea1fce786870647f56cdf3e743515e0e1036f6da12cab1052777
MISC metadata.xml 463 BLAKE2B ad4e4d5a1717e55743061f2cb4baaa7ea8ce73f4caf0c8d62535aaf73daf12339584bf75c82c35b425223f478094bb37518b43d34694fb4bc6aef6f11033fa8e SHA512 98bb4e647da164a8676f9162d1109d1f6d1ff9279ba8d26207f2ed793537af27de11b40296bacfb478e87b6479c9d31bb24f56bc1acf2a0bc228b2d00a733e1d
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild
deleted file mode 100644
index 275a6c59bbf5..000000000000
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.8.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="ssl(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python FTP server library"
-HOMEPAGE="
- https://github.com/giampaolo/pyftpdlib/
- https://pypi.org/project/pyftpdlib/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="examples ssl"
-
-RDEPEND="
- ssl? ( dev-python/pyopenssl[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- test? (
- dev-python/psutil[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
-
-python_test() {
- rm -rf pyftpdlib || die
- # Some of these tests tend to fail
- local EPYTEST_DESELECT=(
- # fail because they process sys.argv and expect program args
- # rather than pytest args, sigh
- test/test_misc.py
- # TODO
- test/test_functional_ssl.py::TestFtpListingCmdsTLSMixin::test_nlst
- )
- # Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- local -x TZ=UTC+1
- # Skips some shoddy tests plus increases timeouts
- local -x TRAVIS=1
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest --pyargs pyftpdlib
-}
-
-python_install_all() {
- if use examples; then
- docinto examples
- dodoc -r demo/.
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}