summaryrefslogtreecommitdiff
path: root/dev-python/pyftpdlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-11 19:55:43 +0100
commit185fa19bbf68a4d4dca534d2b46729207a177f16 (patch)
treea8a537b82fda83a0799c2ca9887f212558363aa7 /dev-python/pyftpdlib
parentc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (diff)
gentoo resync : 11.05.2021
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/Manifest2
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild13
2 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/pyftpdlib/Manifest b/dev-python/pyftpdlib/Manifest
index 383a468442ab..855d86d77585 100644
--- a/dev-python/pyftpdlib/Manifest
+++ b/dev-python/pyftpdlib/Manifest
@@ -1,3 +1,3 @@
DIST pyftpdlib-1.5.6.tar.gz 188099 BLAKE2B 508e94da6b27b4b1f15306df2916c176f07ca31944398e9ac580fca8d2cdc72ca0ee8e7db282de6745e2e401b23b1fa8cb8de400dc2ba998b93ac45772c78157 SHA512 a3c3c1cac221a8a3c090ee208c03134bb1b8de58099a23ca6ee422f06fb97a0ed561c96e62c62b21fa112dd0b3458651b9fc0c55d72dc0bed79d0583b319a50d
-EBUILD pyftpdlib-1.5.6-r1.ebuild 2964 BLAKE2B 6c9e1fb018b9edeb9559d39ca9bf1e7f68fe2b3cd6a7333781f477740a44c1f79e3c844cb979a0b14d4cd4df237b936c481e4ee3772120c63a034edc0f6a2ff3 SHA512 5ac9ebb47549a7c465859341bb172bbab3b4f086954b263e35d28afa7387a3f0e306fda2b3b9bdc9b6a3817ff0c022b6fddb7bd93f0b388d3a7cb9b72c5a2796
+EBUILD pyftpdlib-1.5.6-r1.ebuild 3566 BLAKE2B d9fca8a7c37471dab8a7a8f08bf9fbd2b3998088b32beb8230a76aa11340c7a41addbcfeebaeee0f47892e254d37b254f151d8b8da2bc03413fd7bcf95ba37a1 SHA512 566835db092e438071d2ea2fb5b86cf7405838bebbb8fccee1a0f00c9b105eb8fb753912e035e7fac6fcf6502badbf24a825326c70ccb0617ef96eb0447d10c6
MISC metadata.xml 438 BLAKE2B 0e0860eb9d885ec9b432b504bef6a9394cf4a2d6d99751c80fec8441d8910f8a17364e5f32782638ac689abf5cdd3ebcb5fa20e7da3d612a5e8844e8c8a34d76 SHA512 a748827370b53c94fed352cd6bbd7468a22c7ca2f15c4601c98a2689e3a7e652ed28434bcd125fe0f3018d5508600df03130c18d7d67834b28ac0c3480b16345
diff --git a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
index 76504eb3fcad..a063b7e0f3b6 100644
--- a/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
+++ b/dev-python/pyftpdlib/pyftpdlib-1.5.6-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="ssl(+)"
inherit distutils-r1
@@ -64,10 +64,17 @@ python_test() {
# https://bugs.gentoo.org/758686
pyftpdlib/test/test_functional.py::ThreadedFTPTests::test_idle_timeout
pyftpdlib/test/test_functional.py::ThreadedFTPTests::test_stou_max_tries
+ # https://github.com/giampaolo/pyftpdlib/issues/550
+ # https://bugs.gentoo.org/759040
+ pyftpdlib/test/test_functional.py::TestConfigurableOptions::test_masquerade_address
+ pyftpdlib/test/test_functional.py::TestConfigurableOptions::test_masquerade_address_map
+ pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptions::test_masquerade_address
+ pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptions::test_masquerade_address_map
+ pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address
+ pyftpdlib/test/test_functional_ssl.py::TestConfigurableOptionsTLSMixin::test_masquerade_address_map
)
# Tests fail with TZ=GMT, see https://bugs.gentoo.org/666623
- TZ=UTC+1 pytest -vv ${skipped_tests[@]/#/--deselect } \
- || die "Tests failed with ${EPYTHON}"
+ TZ=UTC+1 epytest ${skipped_tests[@]/#/--deselect }
}
python_install_all() {