summaryrefslogtreecommitdiff
path: root/dev-python/pyformance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pyformance
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pyformance')
-rw-r--r--dev-python/pyformance/Manifest2
-rw-r--r--dev-python/pyformance/pyformance-0.4-r1.ebuild16
2 files changed, 8 insertions, 10 deletions
diff --git a/dev-python/pyformance/Manifest b/dev-python/pyformance/Manifest
index 870757a5b492..16a93b42b9c9 100644
--- a/dev-python/pyformance/Manifest
+++ b/dev-python/pyformance/Manifest
@@ -1,4 +1,4 @@
DIST pyformance-0.4-patches.tar.xz 3500 BLAKE2B 511001e9011db5ef25b802739dca51337d039193a9d3322bbf94bcb120bbbeff2e1a818217970a1a97d77cd8d7da462792248910acbb3ef586704596276b7056 SHA512 858cefd6c8b151db10c63e0d8117cd6c226bd153103993040909e8fd2ab7a41a7770a2ae6de0f395a4f9f6cce3213d7ecabc0bf647657ee04fc10d76f51e07e3
DIST pyformance-0.4.tar.gz 20683 BLAKE2B d818832b7ff43a7e1db888bdb7dc333a532c7d3365dd472f9dbb3300f676cd3cc8f82f8d1c444aa277404ff8e72843eca35e3905542700ea37b1dad3e05c8b4c SHA512 a03324977b40f5097ae4608dd7c36bdbd2a20b261c9d3e32d1be19e5fca50e17fcc24df781b6c3ab60314534368c5e9cf08bc3863d4d2d7ecc59f9af26f8d20e
-EBUILD pyformance-0.4-r1.ebuild 894 BLAKE2B f358d6cba73316bf0caa8b33397015fc9cc5dae755e995ab43f717e85261a5fe2c2b46ce337b4248f7a53424c3aa9da833d42f879093c091fa20f07e3c318844 SHA512 65ac21973830b6de557177b67b2258334c1cf8118b7798283adbd92dbbf6dbffa8590b0549209304c4af5b420bac0de20abfb7496509b65976a27780fd747f25
+EBUILD pyformance-0.4-r1.ebuild 818 BLAKE2B d47160ab1c678af76c70c5444a7ce133db4ce8093e1b70b19ed21adeceba0798a2a8c96d2adb7aa50fe957f10fb763afa72cc22bd101644c88dcf453d16d198f SHA512 ae679c8712c08a2f34c7a8c1f8bc1466c01894d4310a74bf8a18b0f1bfc918b0618b1b39370c1720dea18548b346898329914bcd647b36e636119332b82d6569
MISC metadata.xml 452 BLAKE2B c229f2c744aad33f55a3983a97780b9c0e361e8786a3c9b372f556656c7e1dec34dc30b1f9985747a8f917c8714e867b509143faffacb4242aeb1b61ecce54d1 SHA512 d1fb11333e19747774ae686b9c12f221c9b844be16ee6d2381f38d09d775118c4ffc3379d18217f83d2c0cf518de61a448680e78a1650e289c390d6437702240
diff --git a/dev-python/pyformance/pyformance-0.4-r1.ebuild b/dev-python/pyformance/pyformance-0.4-r1.ebuild
index de8932038a89..00c24dde4952 100644
--- a/dev-python/pyformance/pyformance-0.4-r1.ebuild
+++ b/dev-python/pyformance/pyformance-0.4-r1.ebuild
@@ -1,32 +1,30 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 python3_8 )
+
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- https://dev.gentoo.org/~chutzpah/dist/python/pyformance-0.4-patches.tar.xz"
+ https://dev.gentoo.org/~chutzpah/dist/python/${P}-patches.tar.xz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+BDEPEND="
test? ( dev-python/mock[${PYTHON_USEDEP}] )
"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-
distutils_enable_tests pytest
PATCHES=(
- "${WORKDIR}/pyformance-0.4-patches"
+ "${WORKDIR}/${P}-patches"
)
python_prepare() {