summaryrefslogtreecommitdiff
path: root/dev-python/pyformance/pyformance-0.3.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/pyformance/pyformance-0.3.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/pyformance/pyformance-0.3.4.ebuild')
-rw-r--r--dev-python/pyformance/pyformance-0.3.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyformance/pyformance-0.3.4.ebuild b/dev-python/pyformance/pyformance-0.3.4.ebuild
new file mode 100644
index 000000000000..b9c3c16faf96
--- /dev/null
+++ b/dev-python/pyformance/pyformance-0.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
+HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.python.org/pypi/pyformance/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ sed -i -e "s/find_packages()/find_packages(exclude=['tests'])/" setup.py || die
+ sed -i -e "s/URLError, err/URLError as err/" ${PN}/reporters/influx.py || die
+}
+
+python_test() {
+ py.test || die
+}