summaryrefslogtreecommitdiff
path: root/dev-python/pyfltk
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyfltk
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyfltk')
-rw-r--r--dev-python/pyfltk/Manifest5
-rw-r--r--dev-python/pyfltk/files/fltk_wrap.patch14
-rw-r--r--dev-python/pyfltk/files/ignore-func.patch12
-rw-r--r--dev-python/pyfltk/metadata.xml15
-rw-r--r--dev-python/pyfltk/pyfltk-1.3.3.ebuild52
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/pyfltk/Manifest b/dev-python/pyfltk/Manifest
new file mode 100644
index 000000000000..f3650fc1b0bb
--- /dev/null
+++ b/dev-python/pyfltk/Manifest
@@ -0,0 +1,5 @@
+AUX fltk_wrap.patch 247 BLAKE2B c6f16fb2c87265c7b1b9d869d9b92454eeab50f6cc8830b3946a2cc2949a3a17a9a160ffaff66f60f875674dca51e1a4aa905f15047607e64b2f4791ae027f61 SHA512 4097f9a657f0cb96e37620b939edb35f4cfcb28b2be643b87f85e5dde8ff9a4f316052cbd5403396698de3e2034bafd164c7111c890a5b6d6bcf818185342bcb
+AUX ignore-func.patch 250 BLAKE2B 3d2a979b2580881ee1fa1a6e30b2afd639974d00ec7475c005d8ca967a599ef6858d158d2de95501d7397c1cf8c5e68c0bd0a72da5fbf037bf1fdfd0e8e04600 SHA512 66854b2ce487d1182ada54b437ad79ea5395d87e4b08d89c9ed85b67b21d426609406201c19914e0872ee558d3b3109d3b43a7af036ffb98b781e07731239419
+DIST pyFltk-1.3.3.tar.gz 946763 BLAKE2B 28798578e7a90f2c3b6d0be22241207b384643ed5269ffb4bb5940d5e8776e59ae3c2b740ba7ef61f0230e037d1b3488adf78d9af69338204df9572218ed8cab SHA512 dd4bbef8e82d455237dd085622e78e046ac522449fe63610ee5405c24d759482a89aeab07435fefb5223db78cc1f810f1eca8355afb1d0ff3e4b5e10b73bef8f
+EBUILD pyfltk-1.3.3.ebuild 1093 BLAKE2B f507df4ff27f6c5402916cf3a7049a1a5c41db105ba36abdb8cca59dd2e8bad256a871760ff12e3a2baacaa7485a00ebc30b344c43180abb8bfa1b8bab7f9265 SHA512 a7c5436323ca5720e87f13311777e99c9fcb6b9445301f308214cf91dba8d86ed12e6c2d82c49111e3b4606f1d999662b8b7a23c261cd58eae23d1408aabbfb9
+MISC metadata.xml 473 BLAKE2B 0e5625017dc5f5196012da6388fd6f7ef598c005cdf6dcb358a230f7b15014f6e77666772bb351862f2e2ac8690d77132b269e9988ea63662855a85a720b321c SHA512 b6f4d80dd9e608ec2b4b1a8d799c5cf0d238a7d908de0b79d30da2d9b60f6745aa1595256e59867774814114ac0abd5dbaf8456c9f0a17f7fbcddb6d8354b4a6
diff --git a/dev-python/pyfltk/files/fltk_wrap.patch b/dev-python/pyfltk/files/fltk_wrap.patch
new file mode 100644
index 000000000000..e0c7ba3a4133
--- /dev/null
+++ b/dev-python/pyfltk/files/fltk_wrap.patch
@@ -0,0 +1,14 @@
+--- a/python/fltk_wrap.cpp
++++ b/python/fltk_wrap.cpp
+@@ -144,7 +144,9 @@
+ # define _SCL_SECURE_NO_DEPRECATE
+ #endif
+
+-
++int _fl_filename_isdir_quick(const char *n) {
++ return 0;
++}
+
+ /* Python.h has to appear first */
+ #include <Python.h>
+
diff --git a/dev-python/pyfltk/files/ignore-func.patch b/dev-python/pyfltk/files/ignore-func.patch
new file mode 100644
index 000000000000..4c3ff48fce54
--- /dev/null
+++ b/dev-python/pyfltk/files/ignore-func.patch
@@ -0,0 +1,12 @@
+https://sourceforge.net/p/pyfltk/code/506/
+
+--- a/swig/filename.i
++++ b/swig/filename.i
+@@ -14,6 +14,7 @@
+ %ignore fl_alphasort;
+ %ignore fl_casealphasort;
+ %ignore fl_casenumericsort;
++%ignore _fl_filename_isdir_quick;
+
+ %include "FL/filename.H"
+
diff --git a/dev-python/pyfltk/metadata.xml b/dev-python/pyfltk/metadata.xml
new file mode 100644
index 000000000000..f25f3f8d681b
--- /dev/null
+++ b/dev-python/pyfltk/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python wrapper for the Fast Light Tool Kit cross-platform graphical
+ user-interface library, using SWIG.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pyfltk</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyfltk/pyfltk-1.3.3.ebuild b/dev-python/pyfltk/pyfltk-1.3.3.ebuild
new file mode 100644
index 000000000000..c668e2245748
--- /dev/null
+++ b/dev-python/pyfltk/pyfltk-1.3.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# FIXME: MakeSwig.py execution should be made work from pyfltk-1.1.5.ebuild
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="pyFltk-${PV}"
+MY_P="pyFltk-${PV}_py3"
+
+DESCRIPTION="Python interface to Fltk library"
+HOMEPAGE="http://pyfltk.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz -> ${MY_PN}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE="doc"
+
+DEPEND="
+ >=x11-libs/fltk-1.3.0:1[opengl]
+ !dev-python/pyfltk:1
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}
+
+PATCHES=(
+ "${FILESDIR}"/ignore-func.patch
+ "${FILESDIR}"/fltk_wrap.patch
+ )
+
+python_prepare_all() {
+ # Disable installation of documentation and tests.
+ sed -i -e '/package_data=/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( fltk/docs/. )
+ distutils-r1_python_install_all
+}