summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 11:48:35 +0000
commite45f0df9d7f9f5260e69235b8c7c6e00153747f0 (patch)
tree1999e441fd73f9d62d9ab632067bb978b9b34f29 /dev-python/pyfakefs
parent4bc834b03b9438dcfd45780f31a02994c24608ba (diff)
gentoo auto-resync : 13:01:2023 - 11:48:35
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest2
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.1.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 7289fee0a11a..83726a87418a 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,5 @@
DIST pyfakefs-5.0.0.gh.tar.gz 211213 BLAKE2B 79b83e0a07b094727a0e8d869c99ca64e132f1b7e81202fccad2b4a34871e86630defb87bb5bcfd638a59908c5fdf230aa0cc1e2e3b8393259374a6c5087db90 SHA512 e7125d3b9b186d121bc0b0dba5acf27afe405a6e2a4d8152008450f83a65918b1f612e479ab56c065542dd070b84aeb97cd281123636c062981873d94e4d935a
+DIST pyfakefs-5.1.0.gh.tar.gz 212507 BLAKE2B b9607ff2af71d6697bb5ea5ceae0bb1b92b9aa2e91bafdf24d3dab6f5412a6fd8ff590983085079e9a7b1569b839f4fc5b443d5904decf2de5511ab856e8de7d SHA512 40d4e3fb422c2d9515c00bfa9940a8799d5e102a5775ac34d45e99286759451d1287df1e32f45956a84c1052cc02eed98a8f9789a628ac253771042b011ddd3e
EBUILD pyfakefs-5.0.0.ebuild 734 BLAKE2B 09c5599dab366d87ed26d687620d240e7f946e7163d51f639b3bd1a2d5722010cc2c8ed63c66d9707c6208e0d6ef91fea81a9b6030dc49528cfc142711d6bd3e SHA512 55c6351c9bd67d87af19eb9960e4ea08b675598312bb744c4f1cb53ed1b1a8ac00b11179d82f0d0b4e7ca17bfd7e240216a0ded1d3c6714e3ae681110a2abfe1
+EBUILD pyfakefs-5.1.0.ebuild 742 BLAKE2B 428f21da67ae8dc66c3ef980ccdc4df66c240e18e63d35dd64e56e04cbaa824a5953cd3cc0564b8e389ad13792bdbb6b2d0a0f34ff96c4302d29e915c1cb12e4 SHA512 745db13d85691ff115e87151c54980caf322a10b24a17c0d5473b21ef19113ba3cc0c21c1e9fa8e1bebbdc1cef0a031a959ffe369078c807cdbaa6192041e259
MISC metadata.xml 395 BLAKE2B add696dab9f93cad522087325d7cea08bb0d6905a093c0dd721b8ee0cc5f06a97e8b29663920e5131fd1cfaf38a1fb1c22908daa155025713ffbf18d87a2d5ec SHA512 454f9cf42ae315bb9d4b7c9a2a8b9a690163befc8f738b1fe4a145f1f3a9a5f59693e4cd1ebd4c501005cac1ab81c8b57b2316ac50739dfa96919b6de4850b9a
diff --git a/dev-python/pyfakefs/pyfakefs-5.1.0.ebuild b/dev-python/pyfakefs/pyfakefs-5.1.0.ebuild
new file mode 100644
index 000000000000..a48afea766e6
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}