summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-15 06:41:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-15 06:41:45 +0000
commit8e26aeaca2a19592a9eea3917f3139bfde8641f0 (patch)
tree3ddb856d2a1de70a5caf3b8f7737425b7f8b0796 /dev-python/pyfakefs
parent6e1fc32629c46e29012a7e22b07085307d65ac96 (diff)
gentoo auto-resync : 15:01:2025 - 06:41:45
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest2
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.7.4.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 3a261c0484bc..fadebb50c953 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,5 @@
DIST pyfakefs-5.7.3.gh.tar.gz 247632 BLAKE2B c57b90cdb1e054125a55b32ef5bb400295cc18a23496d614ce06daf1e2d99a194fc3fb7c9853112461779b95d6dd7f4f0d92efa8b1769898cd9868cddcec57ad SHA512 a9c41fcb75314a8674b29b678c5af610b4f75a1738da205e6c48c6acaadba537fcd827097130f82262560918a43e45ff0cc86639b1b3b776a57ab3f8d758e692
+DIST pyfakefs-5.7.4.gh.tar.gz 248270 BLAKE2B 3690b07f2030dc2428936fa34264c6e43b8145f1cfddade3c95bcebb337e483e9cff3e048f0a9d2d1bd6d542d9dc99a3b489a6fedf44c4ef84f2aaeb42200864 SHA512 305e794a66f3e490a60d1e256133edeef8266739fba73b99314a8e2c71990b9a8d774c5b8575709c0cfff7180ff2c4fcf41736d4f8207998053f87ba45d908be
EBUILD pyfakefs-5.7.3.ebuild 1116 BLAKE2B a751908b464ec4f30a6329a787ceb5cd916971f467c0a93e6ca69eeed0ad618ec7afbedd0003e6f1b6087f9680e4633f8af2b6da1a2a5420579315129469a0d2 SHA512 468a00a927a58ffe7ea681d2cb09ffb50ced2d9a1a4d7734210975d784f9899f75f190c8895ce875d882d221b2265fe8e0240b2981f6d24c04954526344552d1
+EBUILD pyfakefs-5.7.4.ebuild 1124 BLAKE2B 1f5244d3a0fb4a123125e164af78aedf3b57da86f8c77090a4735e6e9bdbe6e516909073f2d9992e7a7d236bbeb0969fe72c292a745e195ede4f0ec9277ec4cf SHA512 5b641c12ccfbf62734a451571b171246e08ab8448cc64f7c59fe6609b938ef072fa7d8706b66c219dfd137216e8c67a0c6ce969956cc4d50327d1f363bae0af5
MISC metadata.xml 395 BLAKE2B add696dab9f93cad522087325d7cea08bb0d6905a093c0dd721b8ee0cc5f06a97e8b29663920e5131fd1cfaf38a1fb1c22908daa155025713ffbf18d87a2d5ec SHA512 454f9cf42ae315bb9d4b7c9a2a8b9a690163befc8f738b1fe4a145f1f3a9a5f59693e4cd1ebd4c501005cac1ab81c8b57b2316ac50739dfa96919b6de4850b9a
diff --git a/dev-python/pyfakefs/pyfakefs-5.7.4.ebuild b/dev-python/pyfakefs/pyfakefs-5.7.4.ebuild
new file mode 100644
index 000000000000..4dbd3a1bc4cf
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.7.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ # test for regression with undefined package
+ pyfakefs/pytest_tests/pytest_fixture_test.py
+ )
+
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ pyfakefs/pytest_tests/pytest_reload_pandas_test.py
+ )
+ fi
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}