summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-19 23:22:40 +0100
commit4ae4e74a3a13c7c5aaebf61e650538b005204fcb (patch)
tree4abb4271a26b735b28a4eb8b69206cbcc8e7b4e2 /dev-python/pyfakefs
parentb2a3508c3634488d32ec5bbe6b4365ab27185ebd (diff)
gentoo auto-resync : 19:09:2022 - 23:22:40
Diffstat (limited to 'dev-python/pyfakefs')
-rw-r--r--dev-python/pyfakefs/Manifest2
-rw-r--r--dev-python/pyfakefs/pyfakefs-4.7.0.ebuild30
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/Manifest b/dev-python/pyfakefs/Manifest
index 1b7c5c023600..52f695009588 100644
--- a/dev-python/pyfakefs/Manifest
+++ b/dev-python/pyfakefs/Manifest
@@ -1,3 +1,5 @@
DIST pyfakefs-4.6.3.gh.tar.gz 209890 BLAKE2B 71f84ca02a8a1f9fa5541e0cac1cddd270a8fc66fe5d1f62e8c7bf017f4992e93a6d1bce83847c3833f841e7935d86d6b59b17ee114c82a9d2c36e9c5fe87d02 SHA512 b34091e4311c69ee3eb46cc631c00ec07804c6d5add42887f850275dc0c22d07a893d5dadf2febcbee15c631b476573e63ae52a9ae5780d83a0ef774cff11a5a
+DIST pyfakefs-4.7.0.gh.tar.gz 212406 BLAKE2B e6ed1d28fd45657ae221cbd33b00c46fb0a926b6c7f038c0f34e07223062316b772812d860a39986bd6c8e7f23c3d356f2b484a57e971c160ffb6a0ac19a6089 SHA512 0a1b6cacead6260242f0a1a13753e523f516ed90c0a1cdf92f1caeed24b8dd985f90a216410e3d538f0db087b65b1cc21aae3681250cf7ce393ab7b2e5ac2944
EBUILD pyfakefs-4.6.3.ebuild 731 BLAKE2B 0ab11240761da6c015697ee57291a238f1ad87c84066bff7716a9a1f04204875d7440ae0b1b887c23a28fdd21081e69a9adc71c90793ce9bce3d365f43b5995c SHA512 14c671284240177c0ec575a886bf6131d90894ecfe3feef00299a94f20f2804bf89a221e355d93d30b5ac56dda8cc56dfcdab8a89c5453094c9506866e40d93c
+EBUILD pyfakefs-4.7.0.ebuild 739 BLAKE2B 106b475508e75d0cc59630362ac5b424330ff9bbab6521b9b1fd4e47a8a6a828a03a1d65c26d625c9d0e73fa1d00ca94a05f8707fd33439f8235cdded55051c9 SHA512 f64f1538e124fbd96d49c8323dda92f6b21f4f69d67f974f8b6c42a32a89ac567ebf749dda480ef6a35eac8ee950c657a10c74aaca80881d40573612b86eb569
MISC metadata.xml 395 BLAKE2B 8db2ffc4bcdcf27ed640f08d3f79b1dac72f3609d2113c5e2590c9b127ba0e20bf27f040976a34fd8a08166c455140cbc586da72d22ca67c329717bf5d54798d SHA512 86850a2bdfbc39096105db00d9b249224ab57c1fac71738f0a5df2b83bec7773f4150f7480b18fb066122fe0ed46fbc923a72e837db429b5b322e658bb340010
diff --git a/dev-python/pyfakefs/pyfakefs-4.7.0.ebuild b/dev-python/pyfakefs/pyfakefs-4.7.0.ebuild
new file mode 100644
index 000000000000..54098f2af2c1
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-4.7.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/jmcgeheeiv/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}