summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-31 11:48:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-31 11:48:59 +0000
commit0c7c7c833ab740636f5a76d53ebe5bb6e0e793a8 (patch)
treec54041f822e7291ee0e13d0fa320d348bacdf4d9 /dev-python/pyfakefs/pyfakefs-5.3.5.ebuild
parent14cf0565bbb816bd0cf9ecd14bec28dacfac2d57 (diff)
gentoo auto-resync : 31:01:2024 - 11:48:58
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-5.3.5.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-5.3.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild b/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild
new file mode 100644
index 000000000000..754709257053
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-5.3.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A fake file system that mocks the Python file system modules"
+HOMEPAGE="
+ https://github.com/pytest-dev/pyfakefs/
+ https://pypi.org/project/pyfakefs/
+"
+SRC_URI="
+ https://github.com/pytest-dev/pyfakefs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # test for regression with opentimelineio package
+ pyfakefs/pytest_tests/segfault_test.py
+ # test for regression with undefined package
+ pyfakefs/pytest_tests/pytest_fixture_test.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pyfakefs.pytest_plugin
+}