summaryrefslogtreecommitdiff
path: root/dev-python/pyfakefs/pyfakefs-3.4.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /dev-python/pyfakefs/pyfakefs-3.4.3.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'dev-python/pyfakefs/pyfakefs-3.4.3.ebuild')
-rw-r--r--dev-python/pyfakefs/pyfakefs-3.4.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyfakefs/pyfakefs-3.4.3.ebuild b/dev-python/pyfakefs/pyfakefs-3.4.3.ebuild
new file mode 100644
index 000000000000..4c18bdf736f2
--- /dev/null
+++ b/dev-python/pyfakefs/pyfakefs-3.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="a fake file system that mocks the Python file system modules"
+HOMEPAGE="https://github.com/jmcgeheeiv/pyfakefs/ https://pypi.org/project/pyfakefs/"
+SRC_URI="https://github.com/jmcgeheeiv/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
+
+python_test() {
+ "${PYTHON}" -m ${PN}.tests.all_tests || die "tests failed under ${EPYTHON}"
+}