summaryrefslogtreecommitdiff
path: root/dev-python/pyelftools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-18 18:16:17 +0100
commitfc637fb28da700da71ec2064d65ca5a7a31b9c6c (patch)
tree326613a08f25851c388715e205576a2e7d25dc4f /dev-python/pyelftools
parentb24bd25253fe093f722ab576d29fdc41d04cb1ee (diff)
gentoo resync : 18.08.2019
Diffstat (limited to 'dev-python/pyelftools')
-rw-r--r--dev-python/pyelftools/Manifest1
-rw-r--r--dev-python/pyelftools/pyelftools-0.24-r1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyelftools/Manifest b/dev-python/pyelftools/Manifest
index 613c9640cabf..76feb45b60df 100644
--- a/dev-python/pyelftools/Manifest
+++ b/dev-python/pyelftools/Manifest
@@ -1,3 +1,4 @@
DIST pyelftools-0.24.tar.gz 411874 BLAKE2B 304721cc440599d6436366c14a17d7e3132464686cdd870257a0180dd5f292a23c50a4e654966552d643875ac2683fda8584684cfeb611a3f22f02f73852a288 SHA512 5169617f9a8446ffc21dfc44ee185a388c8945a0296bdc6752483b0756888dccb10e3ee88e529d101cf31a4595de924b5c95f5459d5ee4448f57c0c4f2c56887
+EBUILD pyelftools-0.24-r1.ebuild 911 BLAKE2B cc788c1e11f053a2d18d2e6fcab92a0b19dee1941306bc1fba74e5c3b021b5517089771909274e4274253cdfa6a54f88b67467355d75570f55c80aa02d1434b8 SHA512 1419c340802f3d47b5cba9b410db2ab3bbf462b381155be3d87c06d81de137563482919679a34a94cbf6fac71a2aedf4db5820165bd14ef794d9926415134c70
EBUILD pyelftools-0.24.ebuild 896 BLAKE2B b752f1ce23fda2f2598e139c602aaaa274ccee4771bcde48ef471bed7ebf588562b1803415088dc0137fb955d0d49aa9976f66420a463fd99ca0a13bf0d3e374 SHA512 ec95772ce69ea09ba8c921ef2b34002a0104b11c5c31fd90c1a8e84b6d0356193b1a128ce15db50584b86cd91807be2b9f9394edb9218208a8942f50b1805bc9
MISC metadata.xml 370 BLAKE2B 8dcbbb8d9add514bc0daf421c6739f8ee8426af39a0cf36758c594ee859a1aead4bddcfab3466cb50761ae289f7d58426dacb5a51b745a290530abeb511204eb SHA512 0f00113fb42e48e7b232b8a500ac77958f3ead50ff51d547e015a2c1aa7b87ff7a25495094ba10480176f3653742f18473378fe336f544ec93d645db9057ec20
diff --git a/dev-python/pyelftools/pyelftools-0.24-r1.ebuild b/dev-python/pyelftools/pyelftools-0.24-r1.ebuild
new file mode 100644
index 000000000000..d8bfc6dcef85
--- /dev/null
+++ b/dev-python/pyelftools/pyelftools-0.24-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
+HOMEPAGE="https://pypi.org/project/pyelftools/ https://github.com/eliben/pyelftools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_test() {
+ # readelf_tests often fails due to host `readelf` changing output format
+ local t
+ for t in all_unittests examples_test ; do
+ "${PYTHON}" ./test/run_${t}.py || die "Tests fail with ${EPYTHON}"
+ done
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}