summaryrefslogtreecommitdiff
path: root/dev-python/pyelftools/pyelftools-0.31.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-15 06:47:25 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-15 06:47:25 +0000
commitbc5dfb0671fb08c7da579b38b0e6abdd19da103f (patch)
tree1be81dbc48e2e0ec0cc322ab3062f1c56edd88be /dev-python/pyelftools/pyelftools-0.31.ebuild
parent4614848cbaec61bd1083af01a41f39c3b4a9e274 (diff)
gentoo auto-resync : 15:03:2024 - 06:47:25
Diffstat (limited to 'dev-python/pyelftools/pyelftools-0.31.ebuild')
-rw-r--r--dev-python/pyelftools/pyelftools-0.31.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyelftools/pyelftools-0.31.ebuild b/dev-python/pyelftools/pyelftools-0.31.ebuild
new file mode 100644
index 000000000000..cd8c3640972e
--- /dev/null
+++ b/dev-python/pyelftools/pyelftools-0.31.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="pure-Python library for analyzing ELF files and DWARF debugging information"
+HOMEPAGE="
+ https://pypi.org/project/pyelftools/
+ https://github.com/eliben/pyelftools/
+"
+# PyPI tarball lacks some test files
+SRC_URI="
+ https://github.com/eliben/pyelftools/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ # readelf_tests often fails due to host `readelf` changing output format
+ "${EPYTHON}" test/run_all_unittests.py || die
+ "${EPYTHON}" test/run_examples_test.py || die
+}