summaryrefslogtreecommitdiff
path: root/dev-python/pydotplus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pydotplus
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pydotplus')
-rw-r--r--dev-python/pydotplus/Manifest3
-rw-r--r--dev-python/pydotplus/metadata.xml19
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2.ebuild38
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pydotplus/Manifest b/dev-python/pydotplus/Manifest
new file mode 100644
index 000000000000..7de98a91ba83
--- /dev/null
+++ b/dev-python/pydotplus/Manifest
@@ -0,0 +1,3 @@
+DIST pydotplus-2.0.2.tar.gz 278677 BLAKE2B 879271ba7e2104134a71caef7676082420770dcdb34aeabfe76232ad8f9774d3e90a9f7ca5fb407a7a4e8e0c4e5e01824bd0d5936fe77554cc661839fcc0dc7b SHA512 6f06a1f284401123a4514f9e9a4974dee8dc8d01e6b7c40a797fb70eed22b99fe774272f8b106b5632a33f524b356349fe1ff9633101ff61ef2fc3fe69d641ac
+EBUILD pydotplus-2.0.2.ebuild 950 BLAKE2B 088e98e12044088299327b6d836e18d978b871bf265b4f49b750cc56a9961c45c98ed0db5a0c6ffc131756f84a1ccc7ff274dc9d4a234f161ad9527d5aa36ca1 SHA512 273751bd4b1287793f8871215807bcf48c1239824114262f598c722d994a80eadac636d5c28979ac6a5e6c402ab7158e5302ec21773494e4a989d2db112522fc
+MISC metadata.xml 616 BLAKE2B b3b59bc1482de96d68d0fa8c4d63e9683ad39f7201eca9008bebdcc703978c1313d973d8ee8839625962d2c4b8fb965df88e27ff89b57c0330990fd6ffd1de11 SHA512 684ead6a0a6f5ff7a9afa13e819e0c444e1d87b50f1cc97567de0c9d5b2e22b6b21a44e28887f430c37358eede53521377f89773687ef5d08cd9e626427fd081
diff --git a/dev-python/pydotplus/metadata.xml b/dev-python/pydotplus/metadata.xml
new file mode 100644
index 000000000000..6014a676412f
--- /dev/null
+++ b/dev-python/pydotplus/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ PyDotPlus is an improved version of the old pydot project that provides a Python
+ Interface to Graphviz’s Dot language.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">pydotplus</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydotplus/pydotplus-2.0.2.ebuild b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
new file mode 100644
index 000000000000..7ffae86161ad
--- /dev/null
+++ b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Improved version of the old pydot project"
+HOMEPAGE="http://pydotplus.readthedocs.org/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+# test? (
+# dev-python/flake8[${PYTHON_USEDEP}]
+# dev-python/pytest[${PYTHON_USEDEP}]
+# dev-python/pytest-cov[${PYTHON_USEDEP}]
+# dev-python/sphinx[${PYTHON_USEDEP}]
+# dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+# dev-python/tox[${PYTHON_USEDEP}]
+# )
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ "
+
+#test phase curently disabled, waiting on upstream to include
+#the required files:
+#https://github.com/carlos-jenkins/pydotplus/issues/12
+#python_test() {
+# ${EPYTHON} -m unittest discover || die
+# tox
+#}