summaryrefslogtreecommitdiff
path: root/dev-python/pydotplus/pydotplus-2.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pydotplus/pydotplus-2.0.2.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pydotplus/pydotplus-2.0.2.ebuild')
-rw-r--r--dev-python/pydotplus/pydotplus-2.0.2.ebuild40
1 files changed, 17 insertions, 23 deletions
diff --git a/dev-python/pydotplus/pydotplus-2.0.2.ebuild b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
index f2a0a8effac2..c8aa79de634c 100644
--- a/dev-python/pydotplus/pydotplus-2.0.2.ebuild
+++ b/dev-python/pydotplus/pydotplus-2.0.2.ebuild
@@ -1,38 +1,32 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1
DESCRIPTION="Improved version of the old pydot project"
-HOMEPAGE="http://pydotplus.readthedocs.org/"
+HOMEPAGE="https://pydotplus.readthedocs.org/"
SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# test? (
-# dev-python/flake8[${PYTHON_USEDEP}]
-# dev-python/pytest[${PYTHON_USEDEP}]
-# dev-python/pytest-cov[${PYTHON_USEDEP}]
-# dev-python/sphinx[${PYTHON_USEDEP}]
-# dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-# dev-python/tox[${PYTHON_USEDEP}]
-# )
+IUSE="test"
+RESTRICT="!test? ( test )"
+
RDEPEND="
dev-python/pyparsing[${PYTHON_USEDEP}]
- "
-
-#test phase curently disabled, waiting on upstream to include
-#the required files:
-#https://github.com/carlos-jenkins/pydotplus/issues/12
-#python_test() {
-# ${EPYTHON} -m unittest discover || die
-# tox
-#}
+ media-gfx/graphviz
+"
+DEPEND="test? ( ${RDEPEND} )"
+
+PATCHES=( "${FILESDIR}/${P}-tests.patch" )
+
+python_test() {
+ pushd test > /dev/null || die
+ python pydot_unittest.py || die
+ popd > /dev/null || die
+}