summaryrefslogtreecommitdiff
path: root/dev-python/pydot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/pydot
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/Manifest2
-rw-r--r--dev-python/pydot/files/pydot-1.4.2-pyparsing-3.patch22
-rw-r--r--dev-python/pydot/pydot-1.4.2-r3.ebuild36
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
index 0f4838e09b3e..105d793c40af 100644
--- a/dev-python/pydot/Manifest
+++ b/dev-python/pydot/Manifest
@@ -1,3 +1,5 @@
+AUX pydot-1.4.2-pyparsing-3.patch 738 BLAKE2B eb89ff2dabde77e8fcf9fdcad29cb9080d0c290457140b67eb697ebba50cbcb48c0cc66058defcf110d3aa414f9e98d6af136a862e2dcda1f27a2bf0d3a0df5a SHA512 c917ad4943fc0cca00f13eeb0722f476b2c57ffaecdab9c54714e32dc1fddce3006d9a10d4f7947dd0f1272133901fbf46271f4524b1d7758f43c6ef352794c0
DIST pydot-1.4.2.tar.gz 272678 BLAKE2B 966f2c4ef3e26a63cc50ab89b5b6b5b413aabdfeddf994f2d5ba9dedaa1ed3152dd8060186e7380c3e768b783f7bfe1971cd600c18d1b73f7ac63db08ee3ace9 SHA512 caa8051561710129b5164fd1392da941829fd977092a6ec8b00efe7a199d2d60bc7ef13cb0e51615f384550f0fb80190d0f56b83d8d80d1fe372efb5dbbd3632
EBUILD pydot-1.4.2-r1.ebuild 933 BLAKE2B 4365ef5cb9ac25fffc7e8482dfbc8c350ae182de6121c31f68479d2ccc1479e4e435d3e2ebbe9942cbac3a74b6e49030bf3d3893c50f1b10795d13417e06955e SHA512 d4d70146029cf57f1f739c83fdf8a26736ee9694414fa5f39c4564390aa93417f575ce444ad4080fc55b5e3c8c4889b9f8c4dc20b63cc0f0f9135c8e3f81edd2
+EBUILD pydot-1.4.2-r3.ebuild 928 BLAKE2B 6f3af350f3e176d9e87ca748a99a0832e1afef1e71a48a3ab0e157ebb9e82e04696f23bbd4aec01942ab84b73524f6fb5430255da5e770f104ee4ef04eceea39 SHA512 c4c754be8b247d6fd8f3d47b7a3951cac95dcc1cfe6e09797e58b780c153d64d94460272317d9421cdf8fb1fab4f1624d5375a4181eaa5a65a0c6f6577176b0b
MISC metadata.xml 372 BLAKE2B faad24394ef27dedc8b563e505444b414fe95cb6097bd2bebe01232e68c975b77d415c2a05ec1ad19f0ce1218d1c3f057beea6deecef01b940962a287ad8ce46 SHA512 281a6e2097fcf978f7e691640e257a5f60b242570f8a5715e078363c5658b96b50d3c29ccaad448c0b2ac3dd7b898dcae457bafdb08952163de8d1af81954d75
diff --git a/dev-python/pydot/files/pydot-1.4.2-pyparsing-3.patch b/dev-python/pydot/files/pydot-1.4.2-pyparsing-3.patch
new file mode 100644
index 000000000000..09d4c654ac17
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.4.2-pyparsing-3.patch
@@ -0,0 +1,22 @@
+https://github.com/pydot/pydot/pull/281
+https://bugs.gentoo.org/830676
+
+(rebased)
+
+From 4ab2c033c0dd67cab87be9a9392c558359caf80c Mon Sep 17 00:00:00 2001
+From: Anton Bolshakov <blshkv@users.noreply.github.com>
+Date: Tue, 4 Jan 2022 16:05:51 +0800
+Subject: [PATCH] Update dot_parser.py
+
+https://github.com/pydot/pydot/issues/277
+--- a/dot_parser.py
++++ b/dot_parser.py
+@@ -439,6 +439,8 @@ def graph_definition():
+
+ noncomma = "".join([c for c in printables if c != ","])
+ alphastring_ = OneOrMore(CharsNotIn(noncomma + ' '))
++ # override pyparsing tightened whitespace-skipping logic
++ alphastring_.skipWhitespace = True
+
+ def parse_html(s, loc, toks):
+ return '<%s>' % ''.join(toks[0])
diff --git a/dev-python/pydot/pydot-1.4.2-r3.ebuild b/dev-python/pydot/pydot-1.4.2-r3.ebuild
new file mode 100644
index 000000000000..14efe9d3a7b6
--- /dev/null
+++ b/dev-python/pydot/pydot-1.4.2-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://github.com/pydot/pydot https://pypi.org/project/pydot/"
+# pypi releases don't include tests
+SRC_URI="https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.2-pyparsing-3.patch
+)
+
+python_test() {
+ cd test || die
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}