summaryrefslogtreecommitdiff
path: root/dev-python/pydot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pydot
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/Manifest7
-rw-r--r--dev-python/pydot/files/pydot-1.0.23-setup.patch21
-rw-r--r--dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch14
-rw-r--r--dev-python/pydot/metadata.xml12
-rw-r--r--dev-python/pydot/pydot-1.0.28-r2.ebuild27
-rw-r--r--dev-python/pydot/pydot-1.2.3.ebuild29
6 files changed, 110 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
new file mode 100644
index 000000000000..074d7a6a6280
--- /dev/null
+++ b/dev-python/pydot/Manifest
@@ -0,0 +1,7 @@
+AUX pydot-1.0.23-setup.patch 623 BLAKE2B e0403d397baed897de27782fc6bf5223f0c0c0148e36f214614bcc4ce0bd9d5bbdbf4979272e4395dd8632321605c83ec7d8e0552960895e7890983adfe5925d SHA512 74202787584f9ed4f9aac5038d200fe7c64d0da906226f11e29897a30f371a200787a585d1d151a8ac2191f160d3cd3029ea6f4f4e388e04e7e80d443227dd61
+AUX pydot-1.0.28-pyparsing2fix.patch 836 BLAKE2B f6b629e47032087241e239d3a7515711739a4a4566fb0291b2e612f9ef498ecf6e64da0f2ae8effea647d24f726c8f265548e5aca6f2f3d7483e7a7e77a4e91e SHA512 c50f6a21609acd177cdc954d5adc967d4cb99177467df4c76cad379050968f86375f61d1a17d0377c9dfe4f23ec1b1647cf85d9c3fd1d6c409387d15de81eeb0
+DIST pydot-1.0.28.tar.gz 19711 BLAKE2B 73fa2a614de998d4b53065a350768dbf1c0a4aef60edd9d0515ebfc9c685aba09dc42f89849c1eb609e469a4036062d3f0b83b364d89557f73414143c2c78d59 SHA512 54b4d7bfb01bbcae9a4832d1c3321d4f453a93f062ee55b35e3d59bee3f8989f4a544afb56c3d16b22bca8e6ef24b6286ac2688c9045b16906ef625999b35055
+DIST pydot-1.2.3.tar.gz 262660 BLAKE2B b5acfc365f7864c2b1fb419e5d4624ebeabef2e969dcf545668062ad46b33de5b5ee65271ac6b0fe0abb48df83f6c24bf3598798eb8879a998c06d91b6a5ac00 SHA512 0527279174bd9d5703131ab6c16365d66e392e27597b5d2d536d43f783a59139913a6dbfa1cc022993f842843f5d79e4e0b2a1435ce3427ebc534ef7b1ef2e9b
+EBUILD pydot-1.0.28-r2.ebuild 741 BLAKE2B 85ad002f01f5b5bffea1c6e33a6a18b5669bd50c8716d925ef3f619976e26fe6c34b03078bac1c8a4b7f32d2d92c82b5b2114dd8854bac60a807e8fd256ff020 SHA512 f799da04096a862642cd27f1b31de006fe71fe47c80ee0d9cc12d7139982047c029af4fe62aaf25752d6d73fe2505a0c6597e3878ecb83938c34ebef96d64511
+EBUILD pydot-1.2.3.ebuild 922 BLAKE2B 9f1130a63de99d9a2f0d5b741319130e686ae7cbeec4a1e9236e614fec676b6d98c8ccf76ba2a738549b3eb1b0a8d6fde5df6da7d812b0bf8dbd703a127ff056 SHA512 ff4854f56395bfb372c6ddac42a557b72bf72c41b882cacf5ebe5417829e5455918ee67226b3ffa1570214d16e8f2517e2e520b0dabf1698afd71a0fc7258ecb
+MISC metadata.xml 376 BLAKE2B 2118896ad9769d359f3d1573285cc61affc3989d2ea81d0914e01b5e8882ff94fd70a06324ce3cdc38146edc8513aa67457dc65b81af93474568e9a1b3b23c47 SHA512 0f67a0286f6ff6c6b35e67ff08abb0b86f9ac60e57d321ac7ca0508383b5ce8b0c091a3b023e87d20f3705887db40a5edde2055fa96ec7bca21a5b8aacac31ce
diff --git a/dev-python/pydot/files/pydot-1.0.23-setup.patch b/dev-python/pydot/files/pydot-1.0.23-setup.patch
new file mode 100644
index 000000000000..c87cc32b30d1
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.0.23-setup.patch
@@ -0,0 +1,21 @@
+--- setup.py
++++ setup.py
+@@ -1,9 +1,9 @@
+ #!/usr/bin/env python
+
+ try:
+- from distutils.core import setup
+-except ImportError, excp:
+ from setuptools import setup
++except ImportError, excp:
++ from distutils.core import setup
+
+ import pydot
+ import os
+@@ -31,5 +31,4 @@
+ 'Topic :: Software Development :: Libraries :: Python Modules'],
+ long_description = "\n".join(pydot.__doc__.split('\n')),
+ py_modules = ['pydot', 'dot_parser'],
+- install_requires = ['pyparsing', 'setuptools'],
+- data_files = [('.', ['LICENSE', 'README'])] )
++ install_requires = ['pyparsing', 'setuptools'] )
diff --git a/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch b/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch
new file mode 100644
index 000000000000..12a01091223c
--- /dev/null
+++ b/dev-python/pydot/files/pydot-1.0.28-pyparsing2fix.patch
@@ -0,0 +1,14 @@
+diff -up pydot-1.0.28/dot_parser.py.pyparsing2fix pydot-1.0.28/dot_parser.py
+--- pydot-1.0.28/dot_parser.py.pyparsing2fix 2013-12-09 08:59:24.660145534 -0500
++++ pydot-1.0.28/dot_parser.py 2013-12-09 09:00:10.021222397 -0500
+@@ -25,8 +25,9 @@ from pyparsing import __version__ as pyp
+ from pyparsing import ( nestedExpr, Literal, CaselessLiteral, Word, Upcase, OneOrMore, ZeroOrMore,
+ Forward, NotAny, delimitedList, oneOf, Group, Optional, Combine, alphas, nums,
+ restOfLine, cStyleComment, nums, alphanums, printables, empty, quotedString,
+- ParseException, ParseResults, CharsNotIn, _noncomma, dblQuotedString, QuotedString, ParserElement )
++ ParseException, ParseResults, CharsNotIn, dblQuotedString, QuotedString, ParserElement )
+
++_noncomma = "".join( [ c for c in printables if c != "," ] )
+
+ class P_AttrList:
+
diff --git a/dev-python/pydot/metadata.xml b/dev-python/pydot/metadata.xml
new file mode 100644
index 000000000000..a44c00e7d6b3
--- /dev/null
+++ b/dev-python/pydot/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pydot</remote-id>
+ <remote-id type="github">erocarrera/pydot</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydot/pydot-1.0.28-r2.ebuild b/dev-python/pydot/pydot-1.0.28-r2.ebuild
new file mode 100644
index 000000000000..da31180ccee8
--- /dev/null
+++ b/dev-python/pydot/pydot-1.0.28-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://pypi.org/project/pydot/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.23-setup.patch
+ "${FILESDIR}"/${P}-pyparsing2fix.patch )
diff --git a/dev-python/pydot/pydot-1.2.3.ebuild b/dev-python/pydot/pydot-1.2.3.ebuild
new file mode 100644
index 000000000000..d830cd777110
--- /dev/null
+++ b/dev-python/pydot/pydot-1.2.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="https://github.com/erocarrera/pydot https://pypi.org/project/pydot/"
+# pypi releases don't include tests
+SRC_URI="https://github.com/erocarrera/pydot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="test"
+
+RDEPEND="
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/chardet[${PYTHON_USEDEP}] )"
+
+python_test() {
+ cd test || die
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}