summaryrefslogtreecommitdiff
path: root/dev-python/pydot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-31 11:45:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-31 11:45:37 +0000
commit0f7bcc64cee796c21b0ea6af6e171e89fd33966e (patch)
tree9807c45157c7191f4a297fe4d6f93e94f74d3106 /dev-python/pydot
parent8507777b4ede346b47aafc436295a51890b9cea3 (diff)
gentoo auto-resync : 31:12:2023 - 11:45:37
Diffstat (limited to 'dev-python/pydot')
-rw-r--r--dev-python/pydot/Manifest2
-rw-r--r--dev-python/pydot/pydot-2.0.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pydot/Manifest b/dev-python/pydot/Manifest
index c445843d1ae2..34285bce000a 100644
--- a/dev-python/pydot/Manifest
+++ b/dev-python/pydot/Manifest
@@ -1,4 +1,6 @@
AUX pydot-1.4.2-pyparsing-3.patch 738 BLAKE2B eb89ff2dabde77e8fcf9fdcad29cb9080d0c290457140b67eb697ebba50cbcb48c0cc66058defcf110d3aa414f9e98d6af136a862e2dcda1f27a2bf0d3a0df5a SHA512 c917ad4943fc0cca00f13eeb0722f476b2c57ffaecdab9c54714e32dc1fddce3006d9a10d4f7947dd0f1272133901fbf46271f4524b1d7758f43c6ef352794c0
DIST pydot-1.4.2.gh.tar.gz 272678 BLAKE2B 966f2c4ef3e26a63cc50ab89b5b6b5b413aabdfeddf994f2d5ba9dedaa1ed3152dd8060186e7380c3e768b783f7bfe1971cd600c18d1b73f7ac63db08ee3ace9 SHA512 caa8051561710129b5164fd1392da941829fd977092a6ec8b00efe7a199d2d60bc7ef13cb0e51615f384550f0fb80190d0f56b83d8d80d1fe372efb5dbbd3632
+DIST pydot-2.0.0.gh.tar.gz 275188 BLAKE2B 58f1598196861795bd44c6b97683e0c37b3c05e848a69d42a3fc898849f272466c989e7ff72e0be22a322a1e92c31c6b76a9317e56f3ec26743c20801daf8bfd SHA512 09102930a59ac4339e1d1e4f7a9d075f99eda6cb060885631a72f1fded90d001bd02940b55addc0c92856e95321cb3b344a1797b4809ac7c9048ac57c81d4707
EBUILD pydot-1.4.2-r4.ebuild 1152 BLAKE2B bfe6190ce6a82f847693c8a86c8c35a14d4f4c6ca02ab62f954ae6ecd197ac60874b0a8a3071033fcfe3f0f41bcbcd36c17f22ec21812324f5372349d755e30a SHA512 130a1e06b0d1daf1dc0a4a5b6ef77492a7917278fa5ffda1f4386c5043b3e1896139413b436f2de3dd85ff2a3fa377af50fdd5a671a5ea026456621840d37a47
+EBUILD pydot-2.0.0.ebuild 971 BLAKE2B a0ac04b79161c17f7e68725130ced1df7dc28172975c57893dea63df0621ed0b7fc979820c2410fb635281aeb14ab4f2e2f151c978c75e6e327fce733dd1cdbd SHA512 4e0f7f32b9cf6546112436fcaf9a48243a01b4a5af1ea28dad549dfb4a9bf2a2dc136a0f4ef6260c1d9d0bc528854c38c9cb4eecf53d06cf9f27c52b8d6eebd7
MISC metadata.xml 372 BLAKE2B faad24394ef27dedc8b563e505444b414fe95cb6097bd2bebe01232e68c975b77d415c2a05ec1ad19f0ce1218d1c3f057beea6deecef01b940962a287ad8ce46 SHA512 281a6e2097fcf978f7e691640e257a5f60b242570f8a5715e078363c5658b96b50d3c29ccaad448c0b2ac3dd7b898dcae457bafdb08952163de8d1af81954d75
diff --git a/dev-python/pydot/pydot-2.0.0.ebuild b/dev-python/pydot/pydot-2.0.0.ebuild
new file mode 100644
index 000000000000..4547bc0f8b06
--- /dev/null
+++ b/dev-python/pydot/pydot-2.0.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to Graphviz's Dot language"
+HOMEPAGE="
+ https://github.com/pydot/pydot/
+ https://pypi.org/project/pydot/
+"
+# pypi releases don't include tests
+SRC_URI="
+ https://github.com/pydot/pydot/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd test || die
+ local -x PYTHONPATH="${BUILD_DIR}/install$(python_get_sitedir)"
+ "${PYTHON}" pydot_unittest.py || die "Test failed with ${EPYTHON}"
+}