summaryrefslogtreecommitdiff
path: root/dev-python/pydocstyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pydocstyle
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest2
-rw-r--r--dev-python/pydocstyle/pydocstyle-5.1.1.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index 24b66d8f0227..752e9f220061 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1,3 +1,5 @@
DIST pydocstyle-5.0.2.tar.gz 68063 BLAKE2B 6d7bf04e97c853e50d953342d332847d0e80b080d5ab044f9d444536ed0352ad44402a1af0c3a6f552ec9f3bb3a372a84af2a5bbdaee58bb18dab585cad5dddb SHA512 5ac2e017ae95ff5c7759d6a2cb9ac990f94f668f5fd940792d927cc62628cd036afcf39ab5db6a11100dcca32af344b47f4a7319dd3a47c36367844d0c06d34a
+DIST pydocstyle-5.1.1.tar.gz 70759 BLAKE2B 3cdb519d7f9459a201c9b7bc3002e69dae76b79758b155198b3101c6817c66db01616723e789dd8105d0339d6163fec02ab50db2370b13d3a8d1c5a17ecded6c SHA512 70c7408dfa4c8e54a3abf0548a9af26a7ad7ee0bb76f3a41bf6f2297ce09c13c03ab5e066b1b15404ba6390ddfcacbc5e199d8b73ee74e3b184759d88c8b2a51
EBUILD pydocstyle-5.0.2.ebuild 955 BLAKE2B c2f040156346bcb23a85f42b6b7ff3ed0d8d59321b5da4fb8fb8f5c4ab795b4cea15b9547324ea3e920f3525aeb2f8bbc69653928233e51fcc85cfcabe96c72b SHA512 9f401abfdf48c389747a92b2a84668fced98e6cb624d8dd2fddc472bbbe5c0428e291c43437220adc7630917b81ec6cf109e789e676f89c979f98622a6143792
+EBUILD pydocstyle-5.1.1.ebuild 985 BLAKE2B 53013f661970331d3ec7af2111d3971c4e4a1b727b92add28a5bf23aab0fffe64a053a2018dadc97a319e317e4619842ce4cb7a35d6192b2ec06318959885335 SHA512 901d8b2299a1d09551ae37425f65698e05f2f506d07c07f2c1a72f732a3c8f8b776faff13e85565b5720c084f142e50a4f0b340eedf12af835f7a0a91efe3f31
MISC metadata.xml 762 BLAKE2B 3beb9d084f02d336a8b8785df8bcad21c5e49f972b3a9a255eba79291630a1cb6dedd77d1a6c72c7cf787149b6a8ed0c4df2cc49dfb3eb0d9094ca271bbd5220 SHA512 8c3ddff21e08bce744df0d7f6157e0024f13f4e6dbc51c053b46058152c6c889ab529dcc423659f993b79b8292a5a76ad1bb161e3fd949a9bc3a3e7b416a86bb
diff --git a/dev-python/pydocstyle/pydocstyle-5.1.1.ebuild b/dev-python/pydocstyle/pydocstyle-5.1.1.ebuild
new file mode 100644
index 000000000000..002dcd2f4f59
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-5.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+
+DEPEND="test? (
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/tox[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+python_prepare_all() {
+ # These tests call pip.
+ # pip install fails because we are not allowed to do that inside an ebuild.
+ rm "${S}/src/tests/test_integration.py" || die
+
+ distutils-r1_python_prepare_all
+}