summaryrefslogtreecommitdiff
path: root/dev-python/pydocstyle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/pydocstyle
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/pydocstyle')
-rw-r--r--dev-python/pydocstyle/Manifest4
-rw-r--r--dev-python/pydocstyle/metadata.xml4
-rw-r--r--dev-python/pydocstyle/pydocstyle-6.0.0.ebuild30
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/pydocstyle/Manifest b/dev-python/pydocstyle/Manifest
index f3dffdfd66b9..e0ca4a60ec3c 100644
--- a/dev-python/pydocstyle/Manifest
+++ b/dev-python/pydocstyle/Manifest
@@ -1,3 +1,5 @@
DIST pydocstyle-5.1.1.tar.gz 70759 BLAKE2B 3cdb519d7f9459a201c9b7bc3002e69dae76b79758b155198b3101c6817c66db01616723e789dd8105d0339d6163fec02ab50db2370b13d3a8d1c5a17ecded6c SHA512 70c7408dfa4c8e54a3abf0548a9af26a7ad7ee0bb76f3a41bf6f2297ce09c13c03ab5e066b1b15404ba6390ddfcacbc5e199d8b73ee74e3b184759d88c8b2a51
+DIST pydocstyle-6.0.0.tar.gz 72143 BLAKE2B 1036a5eab38a38bda0f98371f7e4094248cf5057a9afd8743a478f153a5f06feab6b3e7d6be031615b5e88c388786f59a0619f774f492e40a722f39973051d5b SHA512 609a10307aa24513f476ef639771fc095fe7a65ffd8d530fad02886369c62969c69a5134fd0ec79a1e07d1b6cb8f920c3478db546c26aefb0e45771777c02a0b
EBUILD pydocstyle-5.1.1.ebuild 909 BLAKE2B 78ffa0615df8e0b6ee603a26d800321f90d0528032084f515a284c7b8c3af58dc75be2f47abb26eff07143ec2464235735441c15c5d1835d1a9ab29b199a78dc SHA512 4da34c492a74c28dcc9b2212b9a79d7cbbb557b2c4cbd8bfa74f29a5f6c70f59dee98f1fe4d55c5376a1bac106ca0fc475dfbf560a1e8415e371e147793055f7
-MISC metadata.xml 787 BLAKE2B 15d107190e09858b1c4642148e64d288ec11c96509ab438488cb1aba5ca0640a8ca779c585221d6bfb066c5983f6f243c2c74fc099dbd4b09d026ec48dac662e SHA512 1d38ca977db0ecf99ce5c8a8bf6b57f897b7fd1d9b087075dcdfc5891959a6bf15baf0a8ae44202fc6a9645d08a0a0c52fa6e1e39ce08f7d6eb80f797476cd70
+EBUILD pydocstyle-6.0.0.ebuild 875 BLAKE2B 8b3b39f07dfa8c85baaeac6cbd3cd775b63f357f63b9ceda46e814ab0d7901bd44268082f51227a222548d871eb44d1b92fba2c7c3530742863ac0ac6e2fdb8e SHA512 f6436fd155f5b2bbb5a8e0d3edd3a325bbdf77fbbe20b1b7339496c69c84760cb46e6eb797f2e7625b96cc77164da90f75e897127589c6f06af5b7f39fe592a8
+MISC metadata.xml 817 BLAKE2B 850fe7b35b30a2d302a49409979b3ff43916b19bf2e970da7b1cad7e76cabb66c217fa68198959a1c2595766398151221643184812d98165045e7498b2d38932 SHA512 8e9b85d0e13750e8beacc06c3c448a6a9e3876216d882f34c7a0f75bf64911aa8335dd38221af8852fa399008ba740c5dd3038f465de14d55b465c3114754920
diff --git a/dev-python/pydocstyle/metadata.xml b/dev-python/pydocstyle/metadata.xml
index e21c2c68f714..0923fdb760e9 100644
--- a/dev-python/pydocstyle/metadata.xml
+++ b/dev-python/pydocstyle/metadata.xml
@@ -9,11 +9,11 @@
<email>monsieurp@gentoo.org</email>
<name>Patrice Clement</name>
</maintainer>
- <maintainer type="person">
+ <maintainer type="person" proxied="yes">
<email>andrewammerlaan@riseup.net</email>
<name>Andrew Ammerlaan</name>
</maintainer>
- <maintainer type="project">
+ <maintainer type="project" proxied="proxy">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
diff --git a/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild b/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild
new file mode 100644
index 000000000000..13f713bc7638
--- /dev/null
+++ b/dev-python/pydocstyle/pydocstyle-6.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python docstring style checker"
+HOMEPAGE="https://github.com/PyCQA/pydocstyle/"
+SRC_URI="https://github.com/PyCQA/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="dev-python/snowballstemmer[${PYTHON_USEDEP}]"
+
+distutils_enable_tests --install pytest
+# Requires network to lookup github issues
+#distutils_enable_sphinx docs dev-python/sphinx_rtd_theme dev-python/sphinxcontrib-issuetracker
+
+src_prepare() {
+ # no, seriously, you don't need to install it yourself
+ sed -i -e '/pip/d' src/tests/test_integration.py || die
+
+ distutils-r1_src_prepare
+}