summaryrefslogtreecommitdiff
path: root/dev-python/pydns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pydns
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pydns')
-rw-r--r--dev-python/pydns/Manifest5
-rw-r--r--dev-python/pydns/metadata.xml17
-rw-r--r--dev-python/pydns/pydns-2.3.6-r1.ebuild47
-rw-r--r--dev-python/pydns/pydns-3.1.1.ebuild38
4 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/pydns/Manifest b/dev-python/pydns/Manifest
new file mode 100644
index 000000000000..9c1567d702e9
--- /dev/null
+++ b/dev-python/pydns/Manifest
@@ -0,0 +1,5 @@
+DIST py3dns-3.1.1.tar.gz 29981 BLAKE2B b8f1aaeb95764f4d332ec05a367557a24fdd9171e98349668995687052cbd392169a76aaf24e3d29c94ca1c232f04842b84a2320eab5e553de12c278af23975c SHA512 5f22ba12db502f997be4c2479697cc21fe15aac218da1d347bd400a3ab73d86ad32b57740292a10eacb73e07eba977f67b881e59be16f902afab47053efd6c6e
+DIST pydns-2.3.6.tar.gz 28220 BLAKE2B 81d48c57bc90641c2e1667a951e3af3dc75dc1055e6f3f7b45e57d66bb1d391fc55ef0fa9fd261821de22c9119564cfc2b5a18f7a9780fe708b676c427824261 SHA512 261598c085c7d9f7adf5ce881814e444cdcf48a946dc17db467268ab6164f6045c204507cc58eff8e6f826b9786715ad2a9e766a72193ac8666969913180954b
+EBUILD pydns-2.3.6-r1.ebuild 1145 BLAKE2B 91c22bffc1e37f981dce98784180d81869ae6006ecceed2ceae6588c252aa48e00f9151fd1632688cd6cc9719270c3479319442618fc2f142cec43b5736ec274 SHA512 4a0a0074b935f4ab2c4a7a635be6e5132c0e9b748dd7cd6c6213de760689120b6f8223c2a4c98f16aebb515c1457126ae610a0e7a5957618eca1fbca6f3162b6
+EBUILD pydns-3.1.1.ebuild 861 BLAKE2B c7d0d7523135af0ca9183fc972e9008e4760f00b26aac8c4c87045bcf63f65d83d61f5835f5d90961af812ee12bc26269024a852ef727127fca389e5303f203a SHA512 2b44f04bc0702fb34482c210bdb24c7ae129ad04cbba586ac8bf0b011a8bdeb8067c6226d2f6402c300fb977c48e9ddd26954dd8a42b87f6dc686bcdb7360cfa
+MISC metadata.xml 662 BLAKE2B a86ca878eddec2ae971f3fdbda533d9fff639c7619aeb25997bf335de25d0738c9370a1b68d6e6fd8fe5eca6237d124a0fa629c048ba9e1772b42e42a1b0edd8 SHA512 a87cafcd69bb347d9737d97589211360b71181b80caa73c4f117790596f5482e0b3177dc712eb89afb200c7a56669eb8a805f7c3f4974f9527dcaff8c4cbc821
diff --git a/dev-python/pydns/metadata.xml b/dev-python/pydns/metadata.xml
new file mode 100644
index 000000000000..199be52bf51b
--- /dev/null
+++ b/dev-python/pydns/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">PyDNS provides a module for performing DNS queries from python
+ applications. This was originally based on Guido van Rossum's DNS
+ library code, but has drifted further and further away from it over
+ time.</longdescription>
+ <upstream>
+ <remote-id type="pypi">pydns</remote-id>
+ <remote-id type="launchpad">py3dns</remote-id>
+ <remote-id type="sourceforge">pydns</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydns/pydns-2.3.6-r1.ebuild b/dev-python/pydns/pydns-2.3.6-r1.ebuild
new file mode 100644
index 000000000000..5299102538ad
--- /dev/null
+++ b/dev-python/pydns/pydns-2.3.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for DNS (Domain Name Service)"
+HOMEPAGE="http://pydns.sourceforge.net/ https://pypi.org/project/pydns/"
+SRC_URI="http://downloads.sourceforge.net/project/pydns/pydns/${P}/${P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="2"
+KEYWORDS="amd64 hppa ~ia64 ~ppc ~sparc x86"
+IUSE="examples"
+
+DEPEND="!dev-python/pydns:0
+ virtual/libiconv"
+RDEPEND=""
+
+# Funny a dns package attempts to use the network on tests
+# Await the day that gentoo chills out on such a blanket law.
+RESTRICT=test
+
+python_prepare_all() {
+ # Fix encodings (should be utf-8 but is latin1).
+ local i
+ for i in DNS/{Lib,Type}.py; do
+ iconv -f ISO-8859-1 -t UTF-8 "${i}" > "${i}.utf8" || die
+ mv -f "${i}.utf8" "${i}" || die
+ done
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local test
+ for test in tests/{test.py,test[2-5].py,testsrv.py}
+ do
+ "${PYTHON}" $test || die
+ done
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( ./{tests,tools}/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pydns/pydns-3.1.1.ebuild b/dev-python/pydns/pydns-3.1.1.ebuild
new file mode 100644
index 000000000000..6004c2f169d1
--- /dev/null
+++ b/dev-python/pydns/pydns-3.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="${PN/py/py3}"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Python DNS (Domain Name System) library"
+HOMEPAGE="https://launchpad.net/py3dns"
+SRC_URI="https://launchpad.net/${MY_PN}/trunk/${PV}/+download/${MY_P}.tar.gz"
+
+LICENSE="CNRI"
+SLOT="3"
+KEYWORDS="amd64 hppa ~ia64 ~ppc ~sparc x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Tests require network access
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ "${EPYTHON}" -m unittest || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docinto examples
+ dodoc -r tests/. tools/.
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}