summaryrefslogtreecommitdiff
path: root/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'dev-python/pydispatcher/pydispatcher-2.1.2.ebuild')
-rw-r--r--dev-python/pydispatcher/pydispatcher-2.1.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild b/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
new file mode 100644
index 000000000000..f5b1510f8dae
--- /dev/null
+++ b/dev-python/pydispatcher/pydispatcher-2.1.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_P="PyPyDispatcher-${PV}"
+DESCRIPTION="Multi-producer-multi-consumer signal dispatching mechanism"
+HOMEPAGE="https://github.com/scrapy/pypydispatcher https://pypi.python.org/pypi/PyPyDispatcher"
+SRC_URI="mirror://pypi/${MY_P::1}/${MY_P%-*}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+python_compile_all() {
+ if use doc; then
+ cd docs/pydoc || die
+ "${EPYTHON}" builddocs.py || die
+ fi
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail for ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/pydoc/. )
+ distutils-r1_python_install_all
+}