summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-13 23:50:08 +0000
commitea8740cede74808fe1546789e18738612217bb97 (patch)
tree50a16d926ab0d05dd840e745118ff229fcaf0b78 /dev-python/pydevd
parent06bb974d894b86598af155dc76a6fbd76c4fa30c (diff)
gentoo auto-resync : 13:01:2023 - 23:50:08
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest4
-rw-r--r--dev-python/pydevd/pydevd-2.9.1.ebuild89
-rw-r--r--dev-python/pydevd/pydevd-2.9.3.ebuild2
3 files changed, 2 insertions, 93 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 44ba6ae05abe..6221b7c4eb0e 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,5 +1,3 @@
-DIST pydev_debugger_2_9_1.tar.gz 3974089 BLAKE2B 73e0cea547964e313120af2d27ce0166b5afc2d613428ce96cbc58786dddae99507058a217c0eac7cb071bead8d52b2e9bda8e0c88aff31566a979edc420278b SHA512 67f4d31fa59512ec6738a777537a6f856d312f3a81d7bee497ddc50bf02dcab8c04c64c7e5181e48afea01f9de4300a1cafeb3745cea841d7bb7c26b15ced40b
DIST pydevd-2.9.3.gh.tar.gz 3979334 BLAKE2B f26af62d12d89317ffc9e670c78bac2c977195897dfb858861f6d12a331714c084d11dc030efe82777d51f9cd429b54d78c7126f366fdda15ebd315121b55dcd SHA512 c8d30658e84a1edd3e4d0cd35563f50231b6a2df247fecab5e90236c4c80da10e7fe5f182b1791f86063d3228d115d32d388087605e58842505ab19aabe75444
-EBUILD pydevd-2.9.1.ebuild 2542 BLAKE2B bb9fb5090ed69c9bb5bf449f4ebb4a0e80769d32d58154dc21954d5c89f5d21acef555ad6ca452b3e14139c487b3ac2f204f475a62728968c771b01ede98679f SHA512 379d01cf0221e84f589a694b39cb5b72be8416dd58474dd50778b732345594c84ba03b197f6841b33116c9799003b8b8a62ac012627fb8b9618347fbd367f136
-EBUILD pydevd-2.9.3.ebuild 2569 BLAKE2B 90d27b9a19b94b7dc1a16b5768806e9ad513369af467efa1fb916eceb362115a0210ade3b9a6a4f8da2835410ad8ce196767ed3be8abe8d4afbc4afb804df4aa SHA512 630569a3110efa4bdfcbaac0851d9cbfc2d7cbc5cf13fb8facd88a542a3bfe5e599b8ea1943e4f251f98cf86e9b71be40335713d51ea43d65cb489e162527c56
+EBUILD pydevd-2.9.3.ebuild 2565 BLAKE2B 85db918cb4aac525acb86d4762d4b05e31464807d036cd6d29ab97e5d2ad387be2ad09d4b98907acd4796da2fd7c66fad927760a2d1f111d4618a49c77d60dc8 SHA512 e43214ccb2b54f83d329f4116f4a25d00b8506f3ed43df8279afb9592dd1dd0bbf2ab580e65e033dfb2a4c76199dfdbc3325832b1c8581f39a751fe91d41935b
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-2.9.1.ebuild b/dev-python/pydevd/pydevd-2.9.1.ebuild
deleted file mode 100644
index 61856148ccbe..000000000000
--- a/dev-python/pydevd/pydevd-2.9.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1 toolchain-funcs
-
-MY_P="pydev_debugger_${PV//./_}"
-
-DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
-HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
-SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz"
-S="${WORKDIR}/PyDev.Debugger-${MY_P}"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# After removing and recompiling the prebuilt lib the tests fail?
-# For some reason the test suite is executing a slightly different gdb command
-# then before, which is lacking the file name of the lib that was pre built:
-# gdb: No symbol table is loaded. Use the "file" command
-# This also happens outside of portage so it is not related to any *FLAGS
-RESTRICT="test"
-
-BDEPEND="
- test? (
- dev-python/untangle[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# Block against the version of debugpy that still bundles pydevd
-RDEPEND="
- !<dev-python/debugpy-1.4.2
- sys-devel/gdb
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Drop -O3 and -flto compiler args
- sed -i \
- -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
- -e '/extra_compile_args/d' \
- setup.py || die
-
- # Clean up some prebuilt files
- rm -r third_party || die
- cd pydevd_attach_to_process || die
-
- # Remove these Windows files
- rm attach_{amd64,x86}.dll || die
- rm inject_dll_{amd64,x86}.exe || die
- rm run_code_on_dllmain_{amd64,x86}.dll || die
- rm -r windows winappdbg || die
-
- # Remove these MacOS files
- rm attach_x86_64.dylib || die
-
- # Remove these prebuilt linux files
- rm attach_linux_{amd64,x86}.so || die
-
- cd linux_and_mac || die
- rm compile_mac.sh || die
-}
-
-src_compile() {
- pushd pydevd_attach_to_process/linux_and_mac || die
- # recompile removed file (extracted from compile_linux.sh)
- $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} -o "attach_linux_${ARCH}.so" \
- ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
- mv "attach_linux_${ARCH}.so" ../ || die
- popd || die
-
- distutils-r1_src_compile
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Remove this duplicate that is installed directly to /usr/
- # These files are also correctly installed to the python site-packages dir
- rm -r "${ED}/usr/pydevd_attach_to_process" || die
-}
diff --git a/dev-python/pydevd/pydevd-2.9.3.ebuild b/dev-python/pydevd/pydevd-2.9.3.ebuild
index b85d9b201d16..684fd05826e8 100644
--- a/dev-python/pydevd/pydevd-2.9.3.ebuild
+++ b/dev-python/pydevd/pydevd-2.9.3.ebuild
@@ -19,7 +19,7 @@ S="${WORKDIR}/PyDev.Debugger-${MY_P}"
LICENSE="EPL-1.0"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
# After removing and recompiling the prebuilt lib the tests fail?
# For some reason the test suite is executing a slightly different gdb command