summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-01 23:44:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-01 23:44:31 +0000
commitc641f12d6bd92a8ea812f9b0e68a9a525a9c9ecc (patch)
tree87930b7fd113ac54da0b92db8b9df7652d5595e4 /dev-python/pydevd
parent22230e510e031a97cafc85353610e573b7508e98 (diff)
gentoo auto-resync : 01:02:2024 - 23:44:31
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest2
-rw-r--r--dev-python/pydevd/pydevd-3.0.3.ebuild134
2 files changed, 136 insertions, 0 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index cbd59f2766af..d12e39a3faa0 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,5 +1,7 @@
DIST PyDev.Debugger-pydev_debugger_2_10_0.gh.tar.gz 4019265 BLAKE2B e72c96576588ac3cbfcdd71a1a8e96d41b9d6757b3468c372b45a9c91a887c693f7309467fe8ea27d29c4775cc8df9ebd610b015cecabaaea43c8aa75229bc25 SHA512 a475e4f4cd9f883307d30b0bb2ebd5095de426b52f0f70b1a557095c06241149ad105ca4cbb31d311fa54e4387bbed27e5cf2712ba7447b19720d46dac21a101
+DIST PyDev.Debugger-pydev_debugger_3_0_3.gh.tar.gz 4287855 BLAKE2B 2f9f9cc892a19e42a37190966f2d2897f3e5da477c88d76d4b61b3062b6482db4c4cf5672efe75a1c139aa42a6b017cb5b276cede1167d0e91ca50009706e7e7 SHA512 4a5d03ea69e9eb40ee09c8d9a2258655f1645076757fa02bf92c8ad1b4fbb0570c1ac55464d8dd44cea6187ad2fa858851e02a86dc18b2343411cd8c56dc0c6a
DIST pydevd-2.9.5.gh.tar.gz 3982897 BLAKE2B 06f0712301b419c472bcef2443a2ed277eb477041ff2e40e41b57f61649d84a7559dcae82c30ac572b14e90b98c2b9b9542c7360deded087eec92aeb0372ad67 SHA512 9aa38bc9a238e6f2956883a6318536382726013ea9e4a9d902b36d60df0cf924c279545bcdf92afdb435bfe36598982edd5805725860798fb3970b105254ba1d
EBUILD pydevd-2.10.0.ebuild 4031 BLAKE2B a3cf8ec94770baf402bae877bc33d96cc6305bf6c6b3facf5b727deb725f629e667275e9f04692fe80856686d0189a925a0f005d5dce57a9e739d90c096154c3 SHA512 4100da7309d494045ee017bc0fb1d566a4b02176498fd62d21502b5e99ac5ccacd923808113033248a65754883bf18aa9e6e665d196271eb595abdafc5edb024
EBUILD pydevd-2.9.5.ebuild 2487 BLAKE2B 6280a4631cf006bed5e2ae84f07155cdd3372e36427f66ca77f6e99aeedfb137ad9080adadd2436077181db427917c25bf688058ab50a3042f0918e2f9ff972f SHA512 122916be19c8728c0c155b23dfa8818def24fdfb66bb1806e0da6475d9eb460bb596e00c7958c4c52753f94987d05b23357e0d03d5ae5917c83e756f3e8abc66
+EBUILD pydevd-3.0.3.ebuild 3674 BLAKE2B a7527a18708ae0ef42f0cb3cd8881bde4050b0ac83bfba3a908a3f901abfb5fb5a1aa42b5f9646c076d6ac8777e6ffb6f81dbe67bce7c73f3854129e5b65f125 SHA512 6684587ea44bddc8b6903fad8bda3e0cd38629398cf99930ef8d3c76f588caec343a2d751ba973691586c0e96b279ec48182e834699ecdf47e5d0bcc8da65393
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-3.0.3.ebuild b/dev-python/pydevd/pydevd-3.0.3.ebuild
new file mode 100644
index 000000000000..10a71edeee13
--- /dev/null
+++ b/dev-python/pydevd/pydevd-3.0.3.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 toolchain-funcs
+
+TAG="pydev_debugger_${PV//./_}"
+MY_P="PyDev.Debugger-${TAG}"
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="
+ https://github.com/fabioz/PyDev.Debugger/
+ https://pypi.org/project/pydevd/
+"
+SRC_URI="
+ https://github.com/fabioz/PyDev.Debugger/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-debug/gdb
+"
+BDEPEND="
+ test? (
+ dev-python/untangle[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Drop -O3 and -flto compiler args
+ sed -i \
+ -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
+ -e '/extra_compile_args/d' \
+ setup.py || die
+
+ # Disable tests incompatible with new package versions
+ sed -e '/TEST_\(DJANGO\|FLASK\)/s:True:False:' \
+ -i tests_python/debug_constants.py || die
+
+ # Clean up some prebuilt files
+ rm -r third_party || die
+ cd pydevd_attach_to_process || die
+
+ # Remove these Windows files
+ rm attach_{amd64,x86}.dll || die
+ rm inject_dll_{amd64,x86}.exe || die
+ rm run_code_on_dllmain_{amd64,x86}.dll || die
+ rm -r windows winappdbg || die
+
+ # Remove these MacOS files
+ rm attach_x86_64.dylib || die
+
+ # Remove these prebuilt linux files
+ rm attach_linux_{amd64,x86}.so || die
+
+ cd linux_and_mac || die
+ rm compile_mac.sh || die
+}
+
+src_compile() {
+ pushd pydevd_attach_to_process/linux_and_mac || die
+ # recompile removed file (extracted from compile_linux.sh)
+ $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} \
+ -o "../attach_linux_${ARCH}.so" \
+ ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
+ popd || die
+
+ distutils-r1_src_compile
+
+ # C extensions
+ rm -r _pydevd* || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ # NB: upstream seems to run tests via runfiles.py but that script
+ # is a horror and it seems broken for us anyway
+ tests_python/test_debugger.py::test_attach_to_pid_halted
+ tests_python/test_debugger.py::test_attach_to_pid_no_threads
+ 'tests_python/test_debugger.py::test_path_translation[False]'
+ tests_python/test_debugger_json.py::test_attach_to_pid
+ tests_python/test_debugger_json.py::test_evaluate_exception_trace
+ tests_python/test_debugger_json.py::test_gui_event_loop_custom
+ tests_python/test_debugger_json.py::test_path_translation_and_source_reference
+ tests_python/test_utilities.py::test_tracing_basic
+ tests_python/test_utilities.py::test_tracing_other_threads
+ # incompatible with xdist
+ tests_python/test_utilities.py::test_is_main_thread
+ )
+
+ case ${EPYTHON} in
+ python3.10)
+ EPYTEST_DESELECT+=(
+ tests_python/test_debugger.py::test_frame_eval_limitations
+ )
+ ;&
+ python3.11)
+ EPYTEST_DESELECT+=(
+ tests_python/test_debugger.py::test_remote_debugger_threads
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # this is only used to compare against getpid() to detect that xdist
+ # is being used
+ local -x PYDEV_MAIN_PID=1
+ epytest -p rerunfailures --reruns=5
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process" || die
+}