summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-16 22:04:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-16 22:04:19 +0100
commitaccc284898c2b08d44aca3a4207c0e1c9fac05f5 (patch)
treee657eeb464e8448e3c061045531567b462a53a63 /dev-python/pydevd
parent7f1592d914f244f1c2ab9e4bf84c003131f6d3b8 (diff)
gentoo auto-resync : 16:10:2023 - 22:04:19
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest2
-rw-r--r--dev-python/pydevd/pydevd-2.10.0.ebuild119
2 files changed, 121 insertions, 0 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 608a9b078a29..99dfc8655fc7 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,3 +1,5 @@
+DIST PyDev.Debugger-pydev_debugger_2_10_0.gh.tar.gz 4019265 BLAKE2B e72c96576588ac3cbfcdd71a1a8e96d41b9d6757b3468c372b45a9c91a887c693f7309467fe8ea27d29c4775cc8df9ebd610b015cecabaaea43c8aa75229bc25 SHA512 a475e4f4cd9f883307d30b0bb2ebd5095de426b52f0f70b1a557095c06241149ad105ca4cbb31d311fa54e4387bbed27e5cf2712ba7447b19720d46dac21a101
DIST pydevd-2.9.5.gh.tar.gz 3982897 BLAKE2B 06f0712301b419c472bcef2443a2ed277eb477041ff2e40e41b57f61649d84a7559dcae82c30ac572b14e90b98c2b9b9542c7360deded087eec92aeb0372ad67 SHA512 9aa38bc9a238e6f2956883a6318536382726013ea9e4a9d902b36d60df0cf924c279545bcdf92afdb435bfe36598982edd5805725860798fb3970b105254ba1d
+EBUILD pydevd-2.10.0.ebuild 3438 BLAKE2B ed1434d99e4135b30f23200e1958cbeea181a3bb4207a5d5b2bcb66dabc2d0e130a722ee6838a8303f85c9c4c51d8ead526b70d3a555b1c5c34d2216281bd534 SHA512 a5f11cdb7be849db8622a9f31014adfe63bffebb4510783f3f11c38ffb94e69157135f99e8bb55b3873ced215a00d69c9e7a1cff4fd815ad4e9ec00414ff2bbf
EBUILD pydevd-2.9.5.ebuild 2486 BLAKE2B 9cd5204a2d55d776fdd7aa76d25ae3a80389030ee7ba2afcae7744f97a193cb061854430d6c2c245c5e17bbf9af6ecc32290090bd2223d1c03ee27019ea7dbe3 SHA512 dbaba2eff4f733601794436640e65381fbf5476da5215436e06db165aaaf96e5e3eda2847e293ab3a163cd54ebf860eb689c2c961d6a20152d9a3598be2633c6
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-2.10.0.ebuild b/dev-python/pydevd/pydevd-2.10.0.ebuild
new file mode 100644
index 000000000000..ea5745003d08
--- /dev/null
+++ b/dev-python/pydevd/pydevd-2.10.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing toolchain-funcs
+
+TAG="pydev_debugger_${PV//./_}"
+MY_P="PyDev.Debugger-${TAG}"
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="
+ https://github.com/fabioz/PyDev.Debugger/
+ https://pypi.org/project/pydevd/
+"
+SRC_URI="
+ https://github.com/fabioz/PyDev.Debugger/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ sys-devel/gdb
+"
+BDEPEND="
+ test? (
+ dev-python/untangle[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Drop -O3 and -flto compiler args
+ sed -i \
+ -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
+ -e '/extra_compile_args/d' \
+ setup.py || die
+
+ # Disable tests incompatible with new package versions
+ sed -e '/TEST_\(DJANGO\|FLASK\)/s:True:False:' \
+ -i tests_python/debug_constants.py || die
+
+ # Clean up some prebuilt files
+ rm -r third_party || die
+ cd pydevd_attach_to_process || die
+
+ # Remove these Windows files
+ rm attach_{amd64,x86}.dll || die
+ rm inject_dll_{amd64,x86}.exe || die
+ rm run_code_on_dllmain_{amd64,x86}.dll || die
+ rm -r windows winappdbg || die
+
+ # Remove these MacOS files
+ rm attach_x86_64.dylib || die
+
+ # Remove these prebuilt linux files
+ rm attach_linux_{amd64,x86}.so || die
+
+ cd linux_and_mac || die
+ rm compile_mac.sh || die
+}
+
+src_compile() {
+ pushd pydevd_attach_to_process/linux_and_mac || die
+ # recompile removed file (extracted from compile_linux.sh)
+ $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} \
+ -o "../attach_linux_${ARCH}.so" \
+ ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
+ popd || die
+
+ distutils-r1_src_compile
+
+ rm -r _pydevd_bundle || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ # NB: upstream seems to run tests via runfiles.py but that script
+ # is a horror and it seems broken for us anyway
+ tests_python/test_debugger.py::test_attach_to_pid_halted
+ tests_python/test_debugger.py::test_attach_to_pid_no_threads
+ 'tests_python/test_debugger.py::test_path_translation[False]'
+ tests_python/test_debugger.py::test_remote_debugger_threads
+ tests_python/test_debugger_json.py::test_attach_to_pid
+ tests_python/test_debugger_json.py::test_evaluate_exception_trace
+ tests_python/test_debugger_json.py::test_gui_event_loop_custom
+ tests_python/test_debugger_json.py::test_path_translation_and_source_reference
+ tests_python/test_utilities.py::test_tracing_basic
+ tests_python/test_utilities.py::test_tracing_other_threads
+ # incompatible version?
+ tests_python/test_debugger_json.py::test_pandas
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # this is only used to compare against getpid() to detect that xdist
+ # is being used
+ local -x PYDEV_MAIN_PID=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process" || die
+}