summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /dev-python/pydevd
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest3
-rw-r--r--dev-python/pydevd/metadata.xml12
-rw-r--r--dev-python/pydevd/pydevd-2.5.0.ebuild53
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
new file mode 100644
index 000000000000..392dacdbe11e
--- /dev/null
+++ b/dev-python/pydevd/Manifest
@@ -0,0 +1,3 @@
+DIST pydev_debugger_2_5_0.tar.gz 4140556 BLAKE2B 8630fc35138b3bb768b8a62a2f1388a1144baa9207aec49717c3c04843a393b130dfaef3266ad8fce5a5aa3af4e25d4441b075da0aa36ec1a8716db5ba5ac56c SHA512 7ebf1a5405a376fb19fb4bab0f4874e6be273d3c095338d8a2bfad433b0ec306918b2c650bd20dc5ffd835dd01e7398da2b66607a66dad931f98764f572e0be8
+EBUILD pydevd-2.5.0.ebuild 1671 BLAKE2B 1a8d1d3d9f052f9fc9a6dd3d7b1aa4ae5173cc3f0c0bf43841ace81553faad172cd71685c747ada3c04d74e009f0ff82a90de2943cf569329b1efeb016e73699 SHA512 db2b559c93b55297491b6ed3066b5d0e7c715aa6dab76400cd6ef421633617280f984b30418d2a45dc282590578b0b6471bccecf284b059d1857b628f7084a1f
+MISC metadata.xml 383 BLAKE2B 9e19205c72d69665eb973aa1683148b5fabd3cee8b96d84c22b9335e6d41370c651c6a088c4ac5ae0f590f2bfd0ec48fc6d344dea5486b2b0288d368a3003f7f SHA512 a0b68a79685c07caf6b85847a889932814e8843413456fe5f1a469cccffabab838b6a0b7999bba087fcd3c3aee103fc6dc4f2a3519d65c8d330755496aec8e7a
diff --git a/dev-python/pydevd/metadata.xml b/dev-python/pydevd/metadata.xml
new file mode 100644
index 000000000000..8ff81dffad43
--- /dev/null
+++ b/dev-python/pydevd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pydevd</remote-id>
+ <remote-id type="github">fabioz/PyDev.Debugger</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydevd/pydevd-2.5.0.ebuild b/dev-python/pydevd/pydevd-2.5.0.ebuild
new file mode 100644
index 000000000000..bc1f3680e196
--- /dev/null
+++ b/dev-python/pydevd/pydevd-2.5.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
+HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
+SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/refs/tags/pydev_debugger_${PV//./_}.tar.gz"
+S="${WORKDIR}/PyDev.Debugger-pydev_debugger_${PV//./_}"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="test? ( dev-python/untangle[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+# These files are included pre-built in the sources
+# TODO: Investigate what this is and if/how we can compile this properly
+QA_PREBUILT="
+ /usr/lib/python*/site-packages/pydevd_attach_to_process/attach_linux_*.so
+"
+
+python_prepare_all() {
+ # AssertionError: TimeoutError (note: error trying to dump threads on timeout).
+ # TODO: investigate and fix this
+ sed -i \
+ -e 's:test_case_qthread4:_&:' \
+ -e 's:test_path_translation:_&:' \
+ -e 's:test_asyncio_step_over_basic:_&:' \
+ -e 's:test_asyncio_step_over_end_of_function:_&:' \
+ -e 's:test_asyncio_step_in:_&:' \
+ -e 's:test_asyncio_step_return:_&:' \
+ tests_python/test_debugger.py || die
+ sed -i \
+ -e 's:test_evaluate_exception_trace:_&:' \
+ -e 's:test_path_translation_and_source_reference:_&:' \
+ tests_python/test_debugger_json.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Remove this duplicate that is installed directly to /usr/
+ # These files are also correctly installed to the python site-packages dir
+ rm -r "${ED}/usr/pydevd_attach_to_process"
+}