summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-06 09:19:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-06 09:19:37 +0000
commit6003fc7a6eda56862fcff321f47e40cd34e60098 (patch)
tree342368c16c4837b5d9eaf8c4d8c0ea298d1e3308 /dev-python/pydevd
parent30c2cb2c8971dc95b672303f9191d166d622fe47 (diff)
gentoo auto-resync : 06:11:2022 - 09:19:37
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest2
-rw-r--r--dev-python/pydevd/pydevd-2.8.0-r1.ebuild89
2 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 131641abb1b6..3895662ad3f9 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,5 +1,3 @@
-DIST pydev_debugger_2_8_0.tar.gz 4171117 BLAKE2B 4f0ea0eeb228cb66f71e2046438396ff5ce59b42e620a067bc515ff504fa2da151e05f8ea6cf2d1aaa0768122431ccb45708a88c0616fb2859e96671b172e822 SHA512 b0189f1824b52f8ad35d1d1cfba0bd734806541ae2ff4f410c110763201630d296d10c2b7eaac8c656dfb3ff0f3c31bfdf2de28323778000cc7821e123a877d3
DIST pydev_debugger_2_9_1.tar.gz 3974089 BLAKE2B 73e0cea547964e313120af2d27ce0166b5afc2d613428ce96cbc58786dddae99507058a217c0eac7cb071bead8d52b2e9bda8e0c88aff31566a979edc420278b SHA512 67f4d31fa59512ec6738a777537a6f856d312f3a81d7bee497ddc50bf02dcab8c04c64c7e5181e48afea01f9de4300a1cafeb3745cea841d7bb7c26b15ced40b
-EBUILD pydevd-2.8.0-r1.ebuild 2535 BLAKE2B 18ce93e55e8ab42920d85fdca24c3523014cfc3df61a6f17eb06caf09ba07d9ab15902f03fe150983bf027bfcbe0f63d4ab084a49badc28295ee41522b347667 SHA512 dfc41379f6d0fa9aedc028bc0e09a082854c532379f8fc1242cc9e6aeb615a08390042ae1c2974e683c908b29b7ef5ea3abe0c3e4e1ae89ce65ae7489461e6be
EBUILD pydevd-2.9.1.ebuild 2535 BLAKE2B 18ce93e55e8ab42920d85fdca24c3523014cfc3df61a6f17eb06caf09ba07d9ab15902f03fe150983bf027bfcbe0f63d4ab084a49badc28295ee41522b347667 SHA512 dfc41379f6d0fa9aedc028bc0e09a082854c532379f8fc1242cc9e6aeb615a08390042ae1c2974e683c908b29b7ef5ea3abe0c3e4e1ae89ce65ae7489461e6be
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-2.8.0-r1.ebuild b/dev-python/pydevd/pydevd-2.8.0-r1.ebuild
deleted file mode 100644
index 26d973b1c209..000000000000
--- a/dev-python/pydevd/pydevd-2.8.0-r1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1 toolchain-funcs
-
-MY_P="pydev_debugger_${PV//./_}"
-
-DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
-HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
-SRC_URI="https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz"
-S="${WORKDIR}/PyDev.Debugger-${MY_P}"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# After removing and recompiling the prebuilt lib the tests fail?
-# For some reason the test suite is executing a slightly different gdb command
-# then before, which is lacking the file name of the lib that was pre built:
-# gdb: No symbol table is loaded. Use the "file" command
-# This also happens outside of portage so it is not related to any *FLAGS
-RESTRICT="test"
-
-BDEPEND="
- test? (
- dev-python/untangle[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# Block against the version of debugpy that still bundles pydevd
-RDEPEND="
- !<dev-python/debugpy-1.4.2
- sys-devel/gdb
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Drop -O3 and -flto compiler args
- sed -i \
- -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
- -e '/extra_compile_args/d' \
- setup.py || die
-
- # Clean up some prebuilt files
- rm -r third_party || die
- cd pydevd_attach_to_process || die
-
- # Remove these Windows files
- rm attach_{amd64,x86}.dll || die
- rm inject_dll_{amd64,x86}.exe || die
- rm run_code_on_dllmain_{amd64,x86}.dll || die
- rm -r windows winappdbg || die
-
- # Remove these MacOS files
- rm attach_x86_64.dylib || die
-
- # Remove these prebuilt linux files
- rm attach_linux_{amd64,x86}.so || die
-
- cd linux_and_mac || die
- rm compile_mac.sh || die
-}
-
-src_compile() {
- pushd pydevd_attach_to_process/linux_and_mac || die
- # recompile removed file (extracted from compile_linux.sh)
- $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} -o "attach_linux_${ARCH}.so" \
- ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
- mv "attach_linux_${ARCH}.so" ../ || die
- popd || die
-
- distutils-r1_src_compile
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Remove this duplicate that is installed directly to /usr/
- # These files are also correctly installed to the python site-packages dir
- rm -r "${ED}/usr/pydevd_attach_to_process" || die
-}