summaryrefslogtreecommitdiff
path: root/dev-python/pydevd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-11 12:07:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-11 12:07:11 +0000
commit44a6f923079d51164af67c7bc3f3e0db24658088 (patch)
tree887711eae2249a5c6ddbd27a28150c485e7b5475 /dev-python/pydevd
parent81e061dafc8bba274946b1e96d43863977187080 (diff)
gentoo auto-resync : 11:03:2023 - 12:07:11
Diffstat (limited to 'dev-python/pydevd')
-rw-r--r--dev-python/pydevd/Manifest4
-rw-r--r--dev-python/pydevd/pydevd-2.9.3.ebuild92
-rw-r--r--dev-python/pydevd/pydevd-2.9.5.ebuild2
3 files changed, 2 insertions, 96 deletions
diff --git a/dev-python/pydevd/Manifest b/dev-python/pydevd/Manifest
index 79ead8cf2f18..c181ef1a2d19 100644
--- a/dev-python/pydevd/Manifest
+++ b/dev-python/pydevd/Manifest
@@ -1,5 +1,3 @@
-DIST pydevd-2.9.3.gh.tar.gz 3979334 BLAKE2B f26af62d12d89317ffc9e670c78bac2c977195897dfb858861f6d12a331714c084d11dc030efe82777d51f9cd429b54d78c7126f366fdda15ebd315121b55dcd SHA512 c8d30658e84a1edd3e4d0cd35563f50231b6a2df247fecab5e90236c4c80da10e7fe5f182b1791f86063d3228d115d32d388087605e58842505ab19aabe75444
DIST pydevd-2.9.5.gh.tar.gz 3982897 BLAKE2B 06f0712301b419c472bcef2443a2ed277eb477041ff2e40e41b57f61649d84a7559dcae82c30ac572b14e90b98c2b9b9542c7360deded087eec92aeb0372ad67 SHA512 9aa38bc9a238e6f2956883a6318536382726013ea9e4a9d902b36d60df0cf924c279545bcdf92afdb435bfe36598982edd5805725860798fb3970b105254ba1d
-EBUILD pydevd-2.9.3.ebuild 2565 BLAKE2B c6d62cc33736c89466e0100815f7d1f1a3b084ae27cc4af1fc653578ec46b6b449775058a431ef6a2173eb06580f0447ccc0821eeaa07516f41bc4a52d1e81fe SHA512 1a04cac3328fba3b39a8516d6f4647c732c284df3c42ce58e71d7c76759dd6895ec3af7520d73caf245777c26d749665cb787886ba95194b7f01e590e732f8b9
-EBUILD pydevd-2.9.5.ebuild 2477 BLAKE2B cdc0a3ada74fbc8bcfd3846ed16a93dc60fe9044d77398ab153675eb2cd7764b63495128fac223631efa52bc738fe3fee7ae69d0e9b80fa0d738fa8a0494b9d3 SHA512 cece7dc3808387b462f86bc2b8fe7d8322d4824513d41af50e2a23083941a8dd5b6a263ac9a3dd65132b0603a359f37daba542fe68ac42ffcc6829bfa743b1ea
+EBUILD pydevd-2.9.5.ebuild 2469 BLAKE2B e896d796689ee3729b7a24f7e7048c795ab163b0aa854b30cc8e53a7e7d412b9ee3d995b5a53958f7e11f424f6545ee7488fc35ac768d8012ae45a93a6ddecfb SHA512 584ea1de51b034222720d6cd40d04b7d24366c175496b43f326c4c6fda8239f8cc0525932c951a9702ed337cd4224f0694b60ca18a02ff36fde6ea14520de771
MISC metadata.xml 384 BLAKE2B 37a4caa01a28f98ec8d141129c08754e6ba4dee5910a81c26f3eafcd7ac832962e91d3e39783e4859ac7e5ae5754837c89e496c4c2c205d12626359adf7dddae SHA512 5cf80b2e0eaf21e900c83341e9bef5c74a36d3c0a7354e3b6a832184cc60c42eeef6a22236e4fd9d484dc8834e5d4f98facd2578c223da2cc187dd76f91db764
diff --git a/dev-python/pydevd/pydevd-2.9.3.ebuild b/dev-python/pydevd/pydevd-2.9.3.ebuild
deleted file mode 100644
index a78c1bb016df..000000000000
--- a/dev-python/pydevd/pydevd-2.9.3.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1 toolchain-funcs
-
-MY_P="pydev_debugger_${PV//./_}"
-
-DESCRIPTION="PyDev.Debugger (used in PyDev, PyCharm and VSCode Python)"
-HOMEPAGE="https://github.com/fabioz/PyDev.Debugger/"
-SRC_URI="
- https://github.com/fabioz/PyDev.Debugger/archive/${MY_P}.tar.gz
- -> ${P}.gh.tar.gz
-"
-S="${WORKDIR}/PyDev.Debugger-${MY_P}"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-# After removing and recompiling the prebuilt lib the tests fail?
-# For some reason the test suite is executing a slightly different gdb command
-# then before, which is lacking the file name of the lib that was pre built:
-# gdb: No symbol table is loaded. Use the "file" command
-# This also happens outside of portage so it is not related to any *FLAGS
-RESTRICT="test"
-
-BDEPEND="
- test? (
- dev-python/untangle[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- )
-"
-
-# Block against the version of debugpy that still bundles pydevd
-RDEPEND="
- !<dev-python/debugpy-1.4.2
- sys-devel/gdb
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- # Drop -O3 and -flto compiler args
- sed -i \
- -e 's/extra_link_args = extra_compile_args\[\:\]/pass/g' \
- -e '/extra_compile_args/d' \
- setup.py || die
-
- # Clean up some prebuilt files
- rm -r third_party || die
- cd pydevd_attach_to_process || die
-
- # Remove these Windows files
- rm attach_{amd64,x86}.dll || die
- rm inject_dll_{amd64,x86}.exe || die
- rm run_code_on_dllmain_{amd64,x86}.dll || die
- rm -r windows winappdbg || die
-
- # Remove these MacOS files
- rm attach_x86_64.dylib || die
-
- # Remove these prebuilt linux files
- rm attach_linux_{amd64,x86}.so || die
-
- cd linux_and_mac || die
- rm compile_mac.sh || die
-}
-
-src_compile() {
- pushd pydevd_attach_to_process/linux_and_mac || die
- # recompile removed file (extracted from compile_linux.sh)
- $(tc-getBUILD_CXX) ${CXXFLAGS} ${CPPFLAGS} -o "attach_linux_${ARCH}.so" \
- ${LDFLAGS} -nostartfiles attach.cpp -ldl || die
- mv "attach_linux_${ARCH}.so" ../ || die
- popd || die
-
- distutils-r1_src_compile
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # Remove this duplicate that is installed directly to /usr/
- # These files are also correctly installed to the python site-packages dir
- rm -r "${ED}/usr/pydevd_attach_to_process" || die
-}
diff --git a/dev-python/pydevd/pydevd-2.9.5.ebuild b/dev-python/pydevd/pydevd-2.9.5.ebuild
index aa9a8f932b61..8c93d22eebc4 100644
--- a/dev-python/pydevd/pydevd-2.9.5.ebuild
+++ b/dev-python/pydevd/pydevd-2.9.5.ebuild
@@ -19,7 +19,7 @@ S="${WORKDIR}/PyDev.Debugger-${MY_P}"
LICENSE="EPL-1.0"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
# After removing and recompiling the prebuilt lib the tests fail?
# For some reason the test suite is executing a slightly different gdb command