summaryrefslogtreecommitdiff
path: root/dev-python/pydecomp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pydecomp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pydecomp')
-rw-r--r--dev-python/pydecomp/Manifest4
-rw-r--r--dev-python/pydecomp/metadata.xml21
-rw-r--r--dev-python/pydecomp/pydecomp-0.2.ebuild36
-rw-r--r--dev-python/pydecomp/pydecomp-9999.ebuild43
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/pydecomp/Manifest b/dev-python/pydecomp/Manifest
new file mode 100644
index 000000000000..1bc0be033f2e
--- /dev/null
+++ b/dev-python/pydecomp/Manifest
@@ -0,0 +1,4 @@
+DIST pydecomp-0.2.tar.gz 9819 BLAKE2B fc2078b00f152e598599b1fc4b1239035d1d21789689fb49605a4c3afb6d9201a1b1635d6f1971edf98fef8de02caeb6ea5e6bae1fe2b21f546e8a712ca94949 SHA512 1cec8ba501cf6223740c50751508a83f474a9acbce811c82f6d8beb5536ea8ce9c1d04a218503acd13b6eec8d9a68ef4b712049a7e0ae94ff34ba05c6f50ebc9
+EBUILD pydecomp-0.2.ebuild 973 BLAKE2B a83d018c4cce344da3aebe2510497435f779ec19dea46693a87cd881d1232a20b70cae241bedf279ed9fac89332e1b7b0f6d7f8cd4c34d56060d7c452568673a SHA512 e936a0480345bcf53574250c1c6854d70a288c59f97d0d9ac136fc61d3377cf1899852db8fe2791758b50d45ea6a534a92c60befeded03a987ef7b92a2b5a6cd
+EBUILD pydecomp-9999.ebuild 1245 BLAKE2B 43296d7b9f499162f48989d2eb61f090fe94fdfeb4fa5b2ca82da9f31c406ccf681bbba9ce1d2a976a2e9bd6b68f44d3afb48d2c53c45377a600365980cf7ceb SHA512 4d7a54d420c9151150380a71b35c5995f838ff2eeebeeb7120933a6cb270d4381fa9e5af1a27d96da0f3b5a6c730312971cb9a61360c3fca4becf2ef8e6e9e9a
+MISC metadata.xml 796 BLAKE2B e83d6be3e1700f9be8b80c72d0d30868757a53d225df068d58991f945d7089a0769efe1fc7984f1a8a218e54d4a25b81c4a9ce7d2fbe28f2d65f9419b49a0d64 SHA512 ec96d316559404d556dee6f64807d44a4b201028000d4ba527743b2f6f18fbd3354e4dd5cf811512edf9bfc7cd1ea176bdb7c6ce1e04efc154b0f8f564c675c7
diff --git a/dev-python/pydecomp/metadata.xml b/dev-python/pydecomp/metadata.xml
new file mode 100644
index 000000000000..89e66023cb0f
--- /dev/null
+++ b/dev-python/pydecomp/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>tools-portage@gentoo.org</email>
+ <name>Gentoo Portage tools team</name>
+ </maintainer>
+ <longdescription>A python interface library for common compression ,
+ decompression and contents generation. It aims to create a simple,
+ easily extended and configurable common interface to various compressison
+ routines. It can easily be extended with custom compression,
+ decompression, and contents definitions.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">dol-sen/pyDeComp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pydecomp/pydecomp-0.2.ebuild b/dev-python/pydecomp/pydecomp-0.2.ebuild
new file mode 100644
index 000000000000..2a4799a2e0f3
--- /dev/null
+++ b/dev-python/pydecomp/pydecomp-0.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 python-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://github.com/dol-sen/pyDeComp.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+ S="${WORKDIR}/pyDeComp-${PV}"
+fi
+
+DESCRIPTION="A python library of common (de)compression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyDeComp/issues"
+ einfo "I am also on IRC @ #gentoo-releng of the freenode network"
+}
diff --git a/dev-python/pydecomp/pydecomp-9999.ebuild b/dev-python/pydecomp/pydecomp-9999.ebuild
new file mode 100644
index 000000000000..c25e7e24119c
--- /dev/null
+++ b/dev-python/pydecomp/pydecomp-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 python-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_BRANCH="master"
+ EGIT_REPO_URI="https://github.com/dol-sen/pyDeComp.git"
+ inherit git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/pyDeComp-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+ S="${WORKDIR}/pyDeComp-${PV}"
+fi
+
+DESCRIPTION="A python library of common (de)compression and contents handling"
+HOMEPAGE="https://github.com/dol-sen/pyDeComp"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is new software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://github.com/dol-sen/pyDeComp/issues"
+ einfo "I am also on IRC @ #gentoo-releng of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in github or bugzilla."
+}