summaryrefslogtreecommitdiff
path: root/dev-python/pydbus
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-31 20:59:14 +0100
commite748ba9741f6540f4675c23e3e37b73e822c13a4 (patch)
tree23dece8beabb3a3d7c6c0273b0eb40b21c62a889 /dev-python/pydbus
parent908778078736bd36f7a60a2d576d415cb8e000fa (diff)
gentoo resync : 31.05.2021
Diffstat (limited to 'dev-python/pydbus')
-rw-r--r--dev-python/pydbus/Manifest3
-rw-r--r--dev-python/pydbus/metadata.xml10
-rw-r--r--dev-python/pydbus/pydbus-0.6.0.ebuild25
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pydbus/Manifest b/dev-python/pydbus/Manifest
new file mode 100644
index 000000000000..d79c616072af
--- /dev/null
+++ b/dev-python/pydbus/Manifest
@@ -0,0 +1,3 @@
+DIST pydbus-0.6.0.tar.gz 2083046 BLAKE2B 65b50b272b004b30411ff396a9c50d8602485f281100467e2c75ed300cdb0a83532a354a62ef1a8e7ee38a41af243ea7de7a5e80232cfc7c79540e8ed71741c6 SHA512 65ac490dd44ad0aba0b3ea5c58cf6a99bd9de0ce86c6f03b9696335fb2d3f63df0e2e23a022d31d0185f7b8307bcc0f6e230efecc31199fc177f9a8a25929ad7
+EBUILD pydbus-0.6.0.ebuild 499 BLAKE2B ec5b91ca0fd12afbbe0e08a61e29c7998bb21fc45ccdd8661286bfbea93a737040f6cf8a28a98a311e37e8aba496a1359e1dbe3980dc0987d06849db40d2ccc8 SHA512 763732703aea034eea479a34b81750bd974c8f4403600646d9599e4295ca8301e677e077179029b9b21e181678535031c847f99d45364c71871a6b9d6abf80ad
+MISC metadata.xml 283 BLAKE2B ef3dfe1a27e46c933f7ae0bbdece78cab262e4c6a5713caceabd3cc11e5150ff4ad87da258f9a9aee61eb0b4f84dd8aa4b5537bdee54c0eee3d219666c436a46 SHA512 1401089263deca8f8539e7242fd5a68f32c51f8eeb44c05639cc5bee57781948443fd8fe3912c77dc7bbd61181c0b1d7ded90c7c7c3ae161d681d050ec990bda
diff --git a/dev-python/pydbus/metadata.xml b/dev-python/pydbus/metadata.xml
new file mode 100644
index 000000000000..213b9d4ff05b
--- /dev/null
+++ b/dev-python/pydbus/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <stabilize-allarches/>
+</pkgmetadata>
diff --git a/dev-python/pydbus/pydbus-0.6.0.ebuild b/dev-python/pydbus/pydbus-0.6.0.ebuild
new file mode 100644
index 000000000000..e0e4e179657e
--- /dev/null
+++ b/dev-python/pydbus/pydbus-0.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic DBus library"
+HOMEPAGE="https://github.com/LEW21/pydbus"
+SRC_URI="https://github.com/LEW21/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ sys-apps/dbus
+"
+
+python_test() {
+ sh tests/run.sh "${PYTHON}" || die
+}