summaryrefslogtreecommitdiff
path: root/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-08 23:06:07 +0100
commite23a08d0c97a0cc415aaa165da840b056f93c997 (patch)
tree4c5f7db60483518201fef36f8cc0712789a08db2 /dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild
parent391b5b359a346aff490103da7dddc85047f83830 (diff)
gentoo resync : 08.10.2021
Diffstat (limited to 'dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild')
-rw-r--r--dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild
new file mode 100644
index 000000000000..66be2db1eeeb
--- /dev/null
+++ b/dev-python/pydata-sphinx-theme/pydata-sphinx-theme-0.7.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Bootstrap-based Sphinx theme from the PyData community"
+HOMEPAGE="https://github.com/pydata/pydata-sphinx-theme"
+SRC_URI="https://github.com/pydata/pydata-sphinx-theme/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/pytest-regressions[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+"
+
+# TODO: fix this: Sandbox violation to /usr/local/share
+#distutils_enable_sphinx docs dev-python/commonmark dev-python/recommonmark dev-python/numpydoc dev-python/jupyter-sphinx dev-python/plotly dev-python/xarray
+distutils_enable_tests pytest