summaryrefslogtreecommitdiff
path: root/dev-python/pydantic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-12 06:33:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-12 06:33:48 +0100
commited7b29dac0f97dbcf5472b7556b83731a6b6b0d4 (patch)
treef33c5735088b95071719669ecfc18f0aef491ee9 /dev-python/pydantic
parent3a6d209caa07e3be8e8423251b70c8bbeeedb17f (diff)
gentoo auto-resync : 12:04:2024 - 06:33:48
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest2
-rw-r--r--dev-python/pydantic/pydantic-2.7.0.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 9dd995d2a96b..4873870848a0 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,5 +1,7 @@
DIST pydantic-2.6.3.tar.gz 680427 BLAKE2B 28d8d4edcfeeae4f0ba70ed09987e26ba569c38b2c511b6d0b4277b830173302228c964f4c086ac4412a331afa3fba16d9581bd31446fb1dfb43065eb29dfc59 SHA512 2eca898328beb1f33e343d3aa7edf8847baae0569d078507a58bbe0fcf355250c72b70a33f6b79cef697f41ced91eaeee1ffc4a7712fd6fd251fd64557e390d0
DIST pydantic-2.6.4.tar.gz 680828 BLAKE2B 264698f21e4d57656f5a28651019956349a018f16b11099d4afd796329a8ad12847e45250372e5c7b189493e9c73efa624006cb2e6b5a7d77b2c45973a0d813f SHA512 9386c2e04ff71bc182be4892d1cdb910ca60ee68b7cc5c6e86a58529b51707094532dc5315bf152b147979bace3d2e4f6bb4fed546e16fe27b5ecd35c7d0541a
+DIST pydantic-2.7.0.tar.gz 710409 BLAKE2B 79b426edaa599dac99bb4d465690738be2fae5ffb6ba588491470d41d71fc8aecb4cf731457b00dc22911106c86d549ce11118bdc386dfba210cb5973b366aec SHA512 06254a99456a999dd5b165c032e3d5fb48a59d56beb51c1ff77d2dbf181bc2b535801307adf00f3547d5f60fd868ead8d6baf507564c52e09e1efe04c155aeb9
EBUILD pydantic-2.6.3.ebuild 1402 BLAKE2B f36b75b435586e2302aba86a1730320d87e36b355652732db040d34dd28799d986a0449211d01cbc221fece60438bf13f7db9a55c79c9a2921768bc2e10c0e8e SHA512 58723385c1b26becdf2842ed0dc6ab17928841f66b3d45db98460196a3382f97849645fd42985300ad48fd2d5b008d63327264d1ae2c6e57b9369c974f4d981c
EBUILD pydantic-2.6.4.ebuild 1403 BLAKE2B 35c0eb7bbed528ccc8d3ffec2d15e84e14d29f9081fa2d83c586cc68b45457c456d1cdb923db5964b7f0272b79933e61bacbada09c7a29264d1ca971eab51aeb SHA512 bee1a90fbbee1e7f6823ad2f2d00e08bf7fddf57449cabfcaef8b5709e6bc8a30ae855fad77936ca461f44f02266b48df7c659a5032901051e29ea6d147f525e
+EBUILD pydantic-2.7.0.ebuild 1307 BLAKE2B 534277781f1a3798337ba809501910186734fb5a4c7415208c94ea16b9be51a5641347aaa043a70dbf686afb55b9700fc7caf4e32c8d46a9df7fe7c1757d2398 SHA512 66f9c1c673fb41b7d4f7ec43b10e926b106e7cf522a7356346ce33cd7db50d7340c5a7b000d4091fc05bf0417a8efa5988ee3c648035435e3d952edda4f024ee
MISC metadata.xml 550 BLAKE2B ca3a62e01a928ac12964e9a8f291073465c66951082b68cb408a8dec48eeab226c1955782fbb6c82d95c495a790b7d5b84b8f69ab7d3b0acfd2883d3ad2d8e5e SHA512 247144ea1634fd80f8ec461fcb2f8e7383b65185426d0df283ec5345d7612abc3ceee7b6d0df7a3ba858ba8483884507fb443b75cd812bab8d0e6a8293cbb855
diff --git a/dev-python/pydantic/pydantic-2.7.0.ebuild b/dev-python/pydantic/pydantic-2.7.0.ebuild
new file mode 100644
index 000000000000..29b3c947ef29
--- /dev/null
+++ b/dev-python/pydantic/pydantic-2.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
+ ~dev-python/pydantic-core-2.18.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/dirty-equals[${PYTHON_USEDEP}]
+ >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Faker-18.13.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/benchmark/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # require pytest-examples
+ tests/test_docs.py
+ # benchmarks
+ tests/benchmarks
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}