summaryrefslogtreecommitdiff
path: root/dev-python/pydantic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 14:22:05 +0100
commit7c68db06bb531670c1261374c0133d652b476bd7 (patch)
tree5bbbde86ec021664b3c6dfaf90e1175f8378949c /dev-python/pydantic
parent0987983e8588d2819bb2ceb029792d511cee0bda (diff)
gentoo auto-resync : 12:08:2022 - 14:22:05
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest2
-rw-r--r--dev-python/pydantic/pydantic-1.9.2.ebuild77
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index eb28f510f7b2..c6e6346c7757 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,3 +1,5 @@
DIST pydantic-1.9.1.tar.gz 306846 BLAKE2B c22e892f403b6ca5eff7f888c68f9df5c198fa03c8dab833edc556b3b1a4819fc28c9818a649bf5d9c4bb745b0bde826e164eda7760cd26f88e278c86776ad84 SHA512 19d2a50ef054b76cc7e8756759f3d67a14a58614dd6ff1b4f60e73354b0028e08743aa3bb5944da7ae357ab279134d3685c454d6affa6524b267c7cd9a40375e
+DIST pydantic-1.9.2.tar.gz 307957 BLAKE2B ee3b188dcf058fc81b5f8491a5e757114a3b39db4d9aee3265051559f6ac25cff01bfb3b0536d0f0425534bd9a5a6444b6e6f2ef84b91a6c11085e15ac25265a SHA512 524595aea9401e82d2e985fdb5aa9b4a8b39edfed856d08e057695c786d65c3455991e4f57ce326902ff9cbed328bcb5e6f4133bda769fecea5affb68f3b4345
EBUILD pydantic-1.9.1.ebuild 2099 BLAKE2B 10a509b9b1b527e01c0aac2542a09dd9dd0a38132d45c2e02f3b8c0fc1d469d4d4ae6a5245e27ccc7cc85f8538edc86cf249c14e365e43233dee0a5127f85852 SHA512 c28f602375c529b5081ba5823c68452f5372fe97b9cddcd09100a617834f01fc9bfac731643cc18dc370387934c14c40a9afb4405a8c56f589545b243f82ac05
+EBUILD pydantic-1.9.2.ebuild 2107 BLAKE2B b1b0ec5c6da55a5b43219e43d49faecd2cdd5f9e44e681a7aaebadcd858dfd62c8ebc73da614e3871fdc7a6dad6d2e3580f398c749ac64a06eab2b04f6898b63 SHA512 e153ac82345090fe983b411395c2f7950bd884460e42b572108b0253a8a75606f835e122731df70a6f7c1d38658ecfcef5d092762a899a5266331d5f91710141
MISC metadata.xml 492 BLAKE2B e21bc5a40669b2b321ba310df9dd4c6ff424e77d9d961b3aebc1f62b579444c7f505c19dae02590de999cfd8168ac522034275583fb4835e97e8db9b153fefda SHA512 bfb9c7a069a79735543dc12101af7cca16acc5fd93cae01515dc35a106c16a419c0e0e3a97a6bc8426c3db776417f7d29231022cb6ac27020f97e5dcfe0d0cbb
diff --git a/dev-python/pydantic/pydantic-1.9.2.ebuild b/dev-python/pydantic/pydantic-1.9.2.ebuild
new file mode 100644
index 000000000000..82f3a0b71858
--- /dev/null
+++ b/dev-python/pydantic/pydantic-1.9.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="https://github.com/samuelcolvin/pydantic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ >=dev-python/python-email-validator-1.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/CFLAGS/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ # do not build extensions on PyPy to workaround
+ # https://github.com/cython/cython/issues/4763
+ local -x SKIP_CYTHON=1
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_mock
+
+ local EPYTEST_DESELECT=(
+ # flaky test, known upstream
+ tests/test_hypothesis_plugin.py::test_can_construct_models_with_all_fields
+ )
+ case ${EPYTHON} in
+ python3.8)
+ EPYTEST_DESELECT+=(
+ # Those fail on python 3.8 as None changed typing semantic on >=3.9
+ "tests/test_types.py::test_none[value_type3]"
+ tests/test_typing.py::test_is_none_type
+ )
+ ;;
+ pypy3)
+ EPYTEST_DESELECT+=(
+ tests/test_dataclasses.py::test_self_reference_dataclass
+ tests/test_private_attributes.py::test_private_attribute
+ tests/test_private_attributes.py::test_private_attribute_annotation
+ tests/test_private_attributes.py::test_private_attribute_factory
+ tests/test_private_attributes.py::test_private_attribute_multiple_inheritance
+ tests/test_private_attributes.py::test_underscore_attrs_are_private
+ )
+ ;;
+ esac
+ rm -rf pydantic || die
+ epytest
+}