summaryrefslogtreecommitdiff
path: root/dev-python/pydantic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-12 21:55:15 +0000
commit7218e1b46bceac05841e90472501742d905fb3fc (patch)
tree56fae051db521b8fce8014cbc8b11484885b14b3 /dev-python/pydantic
parent6d691ad5b6239929063441bbd14c489e92e7396e (diff)
gentoo resync : 12.03.2021
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest2
-rw-r--r--dev-python/pydantic/pydantic-1.8.1.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 554f240ac07b..0df213ed8dfe 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,5 +1,7 @@
AUX pydantic-1.6.1-fix-tests.patch 1616 BLAKE2B 80a3c209bd9a94aeef76b0aa564abd349cd458d767c73ab531d0a04df174f816ad2d237ee2fd53146e49d30dda449aeaf0487d890756b58eeea534a11bb9d923 SHA512 dfb6096266510fed229e24bffce280c45e72da5a2bb18cbba3bac6098e6175cc515d58c3dc8e0e256f58ff3bffb23fe123c815c7a538fe48b85d4e0304b5a830
AUX pydantic-1.6.1-py39.patch 13658 BLAKE2B d9562e5f36fbaf9c9489d045d833499caa750922156d74936a18ca35db65c223ae19935b059225408d6070d6583107a292c726155f66d722505c3b9a41fe6d60 SHA512 a671b538a84857227da5e062763c86d9308e10fdbdc1ef04a1e07220f60280a089ea836fd1a0e7ef2f936c6cf02895efd39259eeb9cf1b9fe041e429579d808e
DIST pydantic-1.6.1.tar.gz 244677 BLAKE2B 0a1d6986858ab753cbc4dd262bd268b2a365c241a7de106a7bf21714c6c499c7dbacaea095789d3503507965ca50106da32545be670ed0261827f1fe0316ff67 SHA512 b0442f78a661f56d29697da7e27393261420bdb0f08473d2f7872145a49a18de8c17c903d0899a44263bcd8229e8790161da032dd5a3d5f2dae347c66bd6a567
+DIST pydantic-1.8.1.tar.gz 300512 BLAKE2B a7840bd895c73c3049184fc2c4a165783fd68a82290c3826be53667e7b7919580493aff9f2aaa25274b0251da14218dd6f7a41c1cb3cb55f0fbb0c90f79b7833 SHA512 dc58ab2e411744e63408c952c92c589acf037e809c60b85e02f277af2c6342c99c4fbfa7a585f14e57256912c0e6471821973bd2f755aac3822eb3a7883fd407
EBUILD pydantic-1.6.1.ebuild 1002 BLAKE2B 74967cc5755ab17a7ba321d2d59cae28b2665f26389dcd0769bdce7f4600b3bc89bbf370829d0f43e59e5c85b7c0ad8c0787d77a64cc08e7f68ea10f1e5ce271 SHA512 341ce3fe397c40be7271a1c25d32e334a2766066ca13525468da3b5b9980007346f7ec5e6a07245527c0c661ec58060036d850caaf844896bc9cb5e1d8e6f553
+EBUILD pydantic-1.8.1.ebuild 917 BLAKE2B e1db90e2bc6e8842876b77ab98b0c85dfdd3af411d1aa4e06300489942497e567f773782c7617aaa0adf73292d9abf66acce514a3fb9bb1338b596891b34e28d SHA512 d3baa0113efd4eaafc5734b9258ac1901cc26f3572246386c094ed7fe323547bec2f9c21326963b9ae37b96b1af15f70045166db02389403e7b6bb2a37e0320b
MISC metadata.xml 491 BLAKE2B 1c17cf9901705ce6aa44e87902e2d52dbebf6c465ce3210b005ce0a2a69df04f91f90d3f8bfb3f44c1ce804bdb02bfd959920564b5e496ea58089fa77b4ccb22 SHA512 f7fd4fa24b1df7ecb7260f74569413af570c75df6e2c52fa59a8e01d030e4c0bbef120e53f6c3a6b0ad8100d8797c86dd8c1586f86f02c3a740362f6f0b96479
diff --git a/dev-python/pydantic/pydantic-1.8.1.ebuild b/dev-python/pydantic/pydantic-1.8.1.ebuild
new file mode 100644
index 000000000000..26b8dccc514f
--- /dev/null
+++ b/dev-python/pydantic/pydantic-1.8.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="https://github.com/samuelcolvin/pydantic"
+# No tests on PyPI: https://github.com/samuelcolvin/pydantic/pull/1976
+SRC_URI="https://github.com/samuelcolvin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-email-validator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # seriously?
+ sed -i -e '/CFLAGS/d' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # TODO
+ epytest --deselect tests/test_hypothesis_plugin.py
+}