summaryrefslogtreecommitdiff
path: root/dev-python/pydantic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 21:33:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 21:33:19 +0100
commit19e23b194d10e420ec050c4d8a6253aad17694b1 (patch)
tree44ef9c9c2f5433a2251428352e4c9afb877e2500 /dev-python/pydantic
parentc74abf990d32765245eeb94b36ad4af642cae8c0 (diff)
gentoo auto-resync : 17:08:2023 - 21:33:19
Diffstat (limited to 'dev-python/pydantic')
-rw-r--r--dev-python/pydantic/Manifest2
-rw-r--r--dev-python/pydantic/pydantic-2.2.0.ebuild65
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index 8e8da5da0a1f..3b295c99c4f5 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,5 +1,7 @@
DIST pydantic-1.10.12.gh.tar.gz 766366 BLAKE2B b00885b86ef331f3f8531d1514f4e3e1ef10d009b35453c6d5a6295ecfe2d2b842f66c7ea2a79ca1d235d54fa38b42432e14804163f944c4455f05c06869815a SHA512 413d433decfa3bb7173d6f4e6e06f746cfbf95f6d27c6a17098216ba81d64d7f8bb956cda195d0676559f96278f3800c77be53ecf46496ac009f130120642cc2
DIST pydantic-2.1.1.tar.gz 611057 BLAKE2B b414fa698fdc8aee12427d38d0c410ffdd9a39e271858f939587c4a58cd3f579f9d5406b44c1c27350040a036af3badf58b4e10657b52b2d8a720e37720dcda3 SHA512 02703bb889d517f14a977835e553356ddd4d25abf4c8e30df157d68d8006a7ac9ed95feeda73548560b5705ca0d2305af8c49d683d5f0178e48643bef03761e2
+DIST pydantic-2.2.0.tar.gz 620963 BLAKE2B 64b32daf0d6161a70364bdf21e4f868547253106ded166212faf7ae6dc4861ca21078c0f261af1e86b4d300de790f59bb641b76f0c046172a1240fce0135be86 SHA512 b9558cc9ba7da65507e13beb553e616a653169600c2898d783fcb761286674add7afccb39b90400875c0fe1b1a6fdde6e028fae39770fe3be767a9cdb94df5af
EBUILD pydantic-1.10.12.ebuild 2518 BLAKE2B 84f7ee9b095b56518792f81df308652cdc725c6accef3388615bfea735c676f45e449e0c60ec030349b067a8a97833669071f493325c6644c7a73d08d348dcc3 SHA512 7fedbe4158ce80d41e8686ed19618bb818d3efdf8d508a8d4fdef7f8525a3e4e1364a340ba0d710f2b33327a280e33e5df15c0ea2920446dfee3d1b95cc4862f
EBUILD pydantic-2.1.1.ebuild 1668 BLAKE2B 6bac6d6e3ea60e26dc99e89f7420f483dd6c1153d0ae44f7558457c828e7c014efc0595c372f5c74010bb11b526dc4631044d18743edd73c1d9acaeee2eb8ad3 SHA512 b42cd39cde88d30cf3e67845ca6026c6f4ac581b055b0a4a40b6ac26db3f593c1dd7c8e249f26246c65e88678050cbd049f073259d70faa58075d1267c840d05
+EBUILD pydantic-2.2.0.ebuild 1668 BLAKE2B d265789b35bc51e465a93a04c9abf4eb755793a76c56ab63a42af9b50301a2c03949b8f58db1eabf8dcd9d8119d4a8ff3732267b6f24357c5affa7b145560313 SHA512 0cbca4fc50c0fbba6abdb84daa63774873205a55e477a3347dc2befa5b76626b877c8a1f7e024d483d7a3222427fca6c3dcf0c1116dbfc2c88417bd92b60839a
MISC metadata.xml 630 BLAKE2B e765d13d92f634fcd09ce51499a64149ca11f46c8b45d9a41c35382ed84686326b5dd9aeeb0d780d34f38f0cf99b08de6269f1671642aeb389bfd9b8abe18dba SHA512 43f108a909059554ea0fba2055739d23d889f1cf5e01c8f54c4e926062055d042b77412faa9f60af41697c155914907c87455361bb0d32edfdfcf5ff8ce1b2eb
diff --git a/dev-python/pydantic/pydantic-2.2.0.ebuild b/dev-python/pydantic/pydantic-2.2.0.ebuild
new file mode 100644
index 000000000000..3301cd976203
--- /dev/null
+++ b/dev-python/pydantic/pydantic-2.2.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
+ ~dev-python/pydantic-core-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/dirty-equals[${PYTHON_USEDEP}]
+ >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Faker-18.13.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/benchmark/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # require pytest-examples
+ tests/test_docs.py
+ # benchmarks
+ tests/benchmarks
+ )
+ case ${EPYTHON} in
+ python3.12)
+ EPYTEST_DESELECT+=(
+ tests/test_abc.py::test_model_subclassing_abstract_base_classes_without_implementation_raises_exception
+ tests/test_computed_fields.py::test_abstractmethod_missing
+ tests/test_edge_cases.py::test_abstractmethod_missing_for_all_decorators
+ tests/test_generics.py::test_partial_specification_name
+ tests/test_model_signature.py::test_annotated_field
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}