summaryrefslogtreecommitdiff
path: root/dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild')
-rw-r--r--dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild b/dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild
deleted file mode 100644
index 6077218fea52..000000000000
--- a/dev-python/pydantic/pydantic-1.8.2_p20210719.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-COMMIT=0c26c1c4e288e0d41d2c3890d5b3befa7579455c
-
-DESCRIPTION="Data parsing and validation using Python type hints"
-HOMEPAGE="https://github.com/samuelcolvin/pydantic"
-# No tests on PyPI: https://github.com/samuelcolvin/pydantic/pull/1976
-SRC_URI="
- https://github.com/samuelcolvin/pydantic/archive/${COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-email-validator[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-update-py3.10rc1.patch"
-)
-
-distutils_enable_tests --install pytest
-
-EPYTEST_DESELECT=(
- # flaky test, known upstream
- tests/test_hypothesis_plugin.py::test_can_construct_models_with_all_fields
-)
-
-src_prepare() {
- # seriously?
- sed -i -e '/CFLAGS/d' setup.py || die
- distutils-r1_src_prepare
-}