summaryrefslogtreecommitdiff
path: root/dev-python/pydantic/pydantic-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/pydantic/pydantic-1.8.2.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/pydantic/pydantic-1.8.2.ebuild')
-rw-r--r--dev-python/pydantic/pydantic-1.8.2.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/pydantic/pydantic-1.8.2.ebuild b/dev-python/pydantic/pydantic-1.8.2.ebuild
deleted file mode 100644
index 40c0a3ad124d..000000000000
--- a/dev-python/pydantic/pydantic-1.8.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} )
-inherit distutils-r1
-
-DESCRIPTION="Data parsing and validation using Python type hints"
-HOMEPAGE="https://github.com/samuelcolvin/pydantic"
-# No tests on PyPI: https://github.com/samuelcolvin/pydantic/pull/1976
-SRC_URI="https://github.com/samuelcolvin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/python-email-validator[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # seriously?
- sed -i -e '/CFLAGS/d' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local ignore=(
- # mypy results depend on version
- tests/mypy/test_mypy.py
- # TODO
- tests/test_hypothesis_plugin.py
- )
- epytest ${ignore[@]/#/--ignore }
-}